aboutsummaryrefslogtreecommitdiff
path: root/audio/alsa-lib
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2012-10-04 17:04:44 +0000
committerFlorian Smeets <flo@FreeBSD.org>2012-10-04 17:04:44 +0000
commitd3c505e60098b5b8ca502d71bfcff824fda33131 (patch)
tree1a06b1632d608fb96f5a4d8b7c7263a36c91be53 /audio/alsa-lib
parent8abb75929679a8cd4ef6f6dd5117496aaefe900d (diff)
downloadports-d3c505e60098b5b8ca502d71bfcff824fda33131.tar.gz
ports-d3c505e60098b5b8ca502d71bfcff824fda33131.zip
Notes
Diffstat (limited to 'audio/alsa-lib')
-rw-r--r--audio/alsa-lib/Makefile9
-rw-r--r--audio/alsa-lib/distinfo4
-rw-r--r--audio/alsa-lib/files/patch-alsa-lib30
-rw-r--r--audio/alsa-lib/files/patch-versionsort157
-rw-r--r--audio/alsa-lib/pkg-plist1
5 files changed, 29 insertions, 172 deletions
diff --git a/audio/alsa-lib/Makefile b/audio/alsa-lib/Makefile
index 279b697cb006..c37e8413bb51 100644
--- a/audio/alsa-lib/Makefile
+++ b/audio/alsa-lib/Makefile
@@ -6,12 +6,10 @@
#
PORTNAME= alsa-lib
-PORTVERSION= 1.0.25
+PORTVERSION= 1.0.26
CATEGORIES= audio
-MASTER_SITES= ftp://ftp.silug.org/pub/alsa/lib/ \
- ftp://gd.tuwien.ac.at/opsys/linux/alsa/lib/ \
- http://dl.ambiweb.de/mirrors/ftp.alsa-project.org/lib/ \
- ftp://ftp.alsa-project.org/pub/lib/
+MASTER_SITES= ALSA/lib \
+ GENTOO/distfiles
MAINTAINER= aragon@phat.za.net
COMMENT= ALSA compatibility library
@@ -24,6 +22,7 @@ CONFIGURE_ARGS+=--disable-aload --disable-python \
post-patch: .SILENT
${REINPLACE_CMD} -e '/LIBS/ { s/-ldl//g; s/-lrt//g; }' \
+ -e '/-D_GNU_SOURCE/d' \
-e '/lt_cv_dlopen/s/-ldl//g' ${WRKSRC}/configure
${REINPLACE_CMD} '/LIBADD/s/-ldl//g' \
${WRKSRC}/modules/mixer/simple/Makefile.in
diff --git a/audio/alsa-lib/distinfo b/audio/alsa-lib/distinfo
index 958672220651..b9dbfec4478a 100644
--- a/audio/alsa-lib/distinfo
+++ b/audio/alsa-lib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (alsa-lib-1.0.25.tar.bz2) = 5a1a805cf04106316d549ec650116ce6711a162e107ba8b3c551866680e286e6
-SIZE (alsa-lib-1.0.25.tar.bz2) = 838403
+SHA256 (alsa-lib-1.0.26.tar.bz2) = 8c9f8161603cc3db640619650401292c3e110da63429ab6938aac763319f6e7d
+SIZE (alsa-lib-1.0.26.tar.bz2) = 883076
diff --git a/audio/alsa-lib/files/patch-alsa-lib b/audio/alsa-lib/files/patch-alsa-lib
index 4bae5afd8627..f70f09a66ad3 100644
--- a/audio/alsa-lib/files/patch-alsa-lib
+++ b/audio/alsa-lib/files/patch-alsa-lib
@@ -154,13 +154,23 @@
#if __BYTE_ORDER == __LITTLE_ENDIAN
#define __cpu_to_le32(x) (x)
#define __cpu_to_be32(x) bswap_32(x)
---- src/async.c.orig 2009-09-09 20:34:54.000000000 +0800
-+++ src/async.c 2009-09-15 00:49:34.000000000 +0800
-@@ -51,6 +51,7 @@
+$NetBSD: patch-bk,v 1.1 2008/12/25 13:18:00 hasso Exp $
+
+--- src/async.c.orig 2008-12-25 08:18:22 +0200
++++ src/async.c 2008-12-25 08:20:39 +0200
+@@ -51,6 +51,15 @@ static LIST_HEAD(snd_async_handlers);
static void snd_async_handler(int signo ATTRIBUTE_UNUSED, siginfo_t *siginfo, void *context ATTRIBUTE_UNUSED)
{
-+#ifndef __FreeBSD__
++#if defined(__DragonFly__) || defined(__FreeBSD__)
++ /* XXX XXX XXX */
++ struct list_head *i;
++ list_for_each(i, &snd_async_handlers) {
++ snd_async_handler_t *h = list_entry(i, snd_async_handler_t, glist);
++ if (h->callback)
++ h->callback(h);
++ }
++#else
int fd;
struct list_head *i;
//assert(siginfo->si_code == SI_SIGIO);
@@ -174,12 +184,14 @@
/**
--- src/compat/hsearch_r.c.orig 2009-09-09 20:34:54.000000000 +0800
+++ src/compat/hsearch_r.c 2009-09-15 00:22:11.000000000 +0800
-@@ -18,7 +18,9 @@
+@@ -18,7 +18,11 @@
Boston, MA 02111-1307, USA. */
#include <errno.h>
-+#ifndef __FreeBSD__
++#ifdef __GLIBC__
#include <malloc.h>
++#else
++#include <stdlib.h>
+#endif
#include <string.h>
@@ -448,12 +460,14 @@
#ifndef DOC_HIDDEN
--- src/shmarea.c.orig 2009-09-09 20:34:54.000000000 +0800
+++ src/shmarea.c 2009-09-15 00:22:00.000000000 +0800
-@@ -19,7 +19,9 @@
+@@ -19,7 +19,11 @@
*/
#include <stdio.h>
-+#ifndef __FreeBSD__
++#ifdef __GLIBC__
#include <malloc.h>
++#else
++#include <stdlib.h>
+#endif
#include <string.h>
#include <errno.h>
diff --git a/audio/alsa-lib/files/patch-versionsort b/audio/alsa-lib/files/patch-versionsort
deleted file mode 100644
index 8009c8c117d5..000000000000
--- a/audio/alsa-lib/files/patch-versionsort
+++ /dev/null
@@ -1,157 +0,0 @@
-based on https://bugs.busybox.net/show_bug.cgi?id=3529
-
---- include/local.h.orig
-+++ include/local.h
-@@ -285,4 +285,125 @@ int snd_config_search_alias_hooks(snd_co
- const char *base, const char *key,
- snd_config_t **result);
-
-+#ifdef NEED_VERSIONSORT
-+
-+/* Compare strings while treating digits characters numerically.
-+ Copyright (C) 1997, 2002 Free Software Foundation, Inc.
-+ This file is part of the GNU C Library.
-+ Contributed by Jean-François Bignolles <bignolle@ecoledoc.ibp.fr>, 1997.
-+
-+ The GNU C Library is free software; you can redistribute it and/or
-+ modify it under the terms of the GNU Lesser General Public
-+ License as published by the Free Software Foundation; either
-+ version 2.1 of the License, or (at your option) any later version.
-+
-+ The GNU C Library is distributed in the hope that it will be useful,
-+ but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ Lesser General Public License for more details.
-+
-+ You should have received a copy of the GNU Lesser General Public
-+ License along with the GNU C Library; if not, write to the Free
-+ Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-+ 02111-1307 USA. */
-+
-+#include <string.h>
-+#include <ctype.h>
-+
-+
-+/* states: S_N: normal, S_I: comparing integral part, S_F: comparing
-+ fractionnal parts, S_Z: idem but with leading Zeroes only */
-+#define S_N 0x0
-+#define S_I 0x4
-+#define S_F 0x8
-+#define S_Z 0xC
-+
-+/* result_type: CMP: return diff; LEN: compare using len_diff/diff */
-+#define CMP 2
-+#define LEN 3
-+
-+/* Compare S1 and S2 as strings holding indices/version numbers,
-+ returning less than, equal to or greater than zero if S1 is less than,
-+ equal to or greater than S2 (for more info, see the texinfo doc).
-+*/
-+static inline
-+int strverscmp (s1, s2)
-+ const char *s1;
-+ const char *s2;
-+{
-+ const unsigned char *p1 = (const unsigned char *) s1;
-+ const unsigned char *p2 = (const unsigned char *) s2;
-+ unsigned char c1, c2;
-+ int state;
-+ int diff;
-+
-+ /* Symbol(s) 0 [1-9] others (padding)
-+ Transition (10) 0 (01) d (00) x (11) - */
-+ static const unsigned int next_state[] =
-+ {
-+ /* state x d 0 - */
-+ /* S_N */ S_N, S_I, S_Z, S_N,
-+ /* S_I */ S_N, S_I, S_I, S_I,
-+ /* S_F */ S_N, S_F, S_F, S_F,
-+ /* S_Z */ S_N, S_F, S_Z, S_Z
-+ };
-+
-+ static const int result_type[] =
-+ {
-+ /* state x/x x/d x/0 x/- d/x d/d d/0 d/-
-+ 0/x 0/d 0/0 0/- -/x -/d -/0 -/- */
-+
-+ /* S_N */ CMP, CMP, CMP, CMP, CMP, LEN, CMP, CMP,
-+ CMP, CMP, CMP, CMP, CMP, CMP, CMP, CMP,
-+ /* S_I */ CMP, -1, -1, CMP, +1, LEN, LEN, CMP,
-+ +1, LEN, LEN, CMP, CMP, CMP, CMP, CMP,
-+ /* S_F */ CMP, CMP, CMP, CMP, CMP, LEN, CMP, CMP,
-+ CMP, CMP, CMP, CMP, CMP, CMP, CMP, CMP,
-+ /* S_Z */ CMP, +1, +1, CMP, -1, CMP, CMP, CMP,
-+ -1, CMP, CMP, CMP
-+ };
-+
-+ if (p1 == p2)
-+ return 0;
-+
-+ c1 = *p1++;
-+ c2 = *p2++;
-+ /* Hint: '0' is a digit too. */
-+ state = S_N | ((c1 == '0') + (isdigit (c1) != 0));
-+
-+ while ((diff = c1 - c2) == 0 && c1 != '\0')
-+ {
-+ state = next_state[state];
-+ c1 = *p1++;
-+ c2 = *p2++;
-+ state |= (c1 == '0') + (isdigit (c1) != 0);
-+ }
-+
-+ state = result_type[state << 2 | (((c2 == '0') + (isdigit (c2) != 0)))];
-+
-+ switch (state)
-+ {
-+ case CMP:
-+ return diff;
-+
-+ case LEN:
-+ while (isdigit (*p1++))
-+ if (!isdigit (*p2++))
-+ return 1;
-+
-+ return isdigit (*p2) ? -1 : diff;
-+
-+ default:
-+ return state;
-+ }
-+}
-+
-+static inline
-+int versionsort(const void * a, const void * b)
-+{
-+ return strverscmp ((*(const struct dirent **) a)->d_name,
-+ (*(const struct dirent **) b)->d_name);
-+}
-+
-+#endif
- #endif
---- src/conf.c.orig
-+++ src/conf.c
-@@ -419,6 +419,9 @@ beginning:</P>
- #include <sys/stat.h>
- #include <dirent.h>
- #include <locale.h>
-+#if defined(__FreeBSD__) || __UCLIBC_MAJOR__ == 0 && __UCLIBC_MINOR__ == 9 && __UCLIBC_SUBLEVEL__ <= 30
-+#define NEED_VERSIONSORT
-+#endif
- #include "local.h"
- #ifdef HAVE_LIBPTHREAD
- #include <pthread.h>
---- src/ucm/parser.c.orig
-+++ src/ucm/parser.c
-@@ -30,8 +30,11 @@
- * Jaroslav Kysela <perex@perex.cz>
- */
-
--#include "ucm_local.h"
- #include <dirent.h>
-+#if defined(__FreeBSD__) || __UCLIBC_MAJOR__ == 0 && __UCLIBC_MINOR__ == 9 && __UCLIBC_SUBLEVEL__ <= 30
-+#define NEED_VERSIONSORT
-+#endif
-+#include "ucm_local.h"
-
- /** The name of the environment variable containing the UCM directory */
- #define ALSA_CONFIG_UCM_VAR "ALSA_CONFIG_UCM"
diff --git a/audio/alsa-lib/pkg-plist b/audio/alsa-lib/pkg-plist
index 3de2b726a93e..d4024886f31e 100644
--- a/audio/alsa-lib/pkg-plist
+++ b/audio/alsa-lib/pkg-plist
@@ -72,6 +72,7 @@ share/alsa/cards/EMU10K1X.conf
share/alsa/cards/ENS1370.conf
share/alsa/cards/ENS1371.conf
share/alsa/cards/ES1968.conf
+share/alsa/cards/Echo_Echo3G.conf
share/alsa/cards/FM801.conf
share/alsa/cards/FWSpeakers.conf
share/alsa/cards/FireWave.conf