aboutsummaryrefslogtreecommitdiff
path: root/audio/alsa-lib
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-07-20 03:03:56 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-07-20 03:03:56 +0000
commita28a1142b4467171d6609f3ac9176c4d58c097a2 (patch)
treec7a3e61c5c5da998dd753fb51ff00dff21e0dd68 /audio/alsa-lib
parent9061f8bc2504dc2563d8ed298ed35a5bbf52d8d6 (diff)
downloadports-a28a1142b4467171d6609f3ac9176c4d58c097a2.tar.gz
ports-a28a1142b4467171d6609f3ac9176c4d58c097a2.zip
Notes
Diffstat (limited to 'audio/alsa-lib')
-rw-r--r--audio/alsa-lib/Makefile8
-rw-r--r--audio/alsa-lib/distinfo4
-rw-r--r--audio/alsa-lib/files/patch-alsa-lib18
-rw-r--r--audio/alsa-lib/files/patch-versionsort157
-rw-r--r--audio/alsa-lib/pkg-plist6
5 files changed, 185 insertions, 8 deletions
diff --git a/audio/alsa-lib/Makefile b/audio/alsa-lib/Makefile
index dc5be0b72db7..279b697cb006 100644
--- a/audio/alsa-lib/Makefile
+++ b/audio/alsa-lib/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= alsa-lib
-PORTVERSION= 1.0.23
+PORTVERSION= 1.0.25
CATEGORIES= audio
MASTER_SITES= ftp://ftp.silug.org/pub/alsa/lib/ \
ftp://gd.tuwien.ac.at/opsys/linux/alsa/lib/ \
@@ -19,7 +19,8 @@ COMMENT= ALSA compatibility library
USE_BZIP2= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --disable-aload --disable-python
+CONFIGURE_ARGS+=--disable-aload --disable-python \
+ --with-pkgconfdir="${PREFIX}/libdata/pkgconfig"
post-patch: .SILENT
${REINPLACE_CMD} -e '/LIBS/ { s/-ldl//g; s/-lrt//g; }' \
@@ -28,9 +29,6 @@ post-patch: .SILENT
${WRKSRC}/modules/mixer/simple/Makefile.in
${REINPLACE_CMD} 's|/etc|${PREFIX}&|g' \
${WRKSRC}/src/conf/alsa.conf
- ${REINPLACE_CMD} \
- '/pkgconfigdir/s|$$(libdir)|$$(prefix)/libdata|g' \
- ${WRKSRC}/utils/Makefile.in
post-install:
${INSTALL_DATA} ${FILESDIR}/asound.conf.sample ${PREFIX}/etc
diff --git a/audio/alsa-lib/distinfo b/audio/alsa-lib/distinfo
index 008291660ecf..958672220651 100644
--- a/audio/alsa-lib/distinfo
+++ b/audio/alsa-lib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (alsa-lib-1.0.23.tar.bz2) = b4238ecaba5e4a1383af06180611a57ef29f9bf47bc177136dba1bb5b70ff423
-SIZE (alsa-lib-1.0.23.tar.bz2) = 808271
+SHA256 (alsa-lib-1.0.25.tar.bz2) = 5a1a805cf04106316d549ec650116ce6711a162e107ba8b3c551866680e286e6
+SIZE (alsa-lib-1.0.25.tar.bz2) = 838403
diff --git a/audio/alsa-lib/files/patch-alsa-lib b/audio/alsa-lib/files/patch-alsa-lib
index 79a6c46a1152..4bae5afd8627 100644
--- a/audio/alsa-lib/files/patch-alsa-lib
+++ b/audio/alsa-lib/files/patch-alsa-lib
@@ -102,7 +102,7 @@
typedef __compar_fn_t comparison_fn_t;
--- include/sound/asound.h.orig 2009-09-09 20:34:54.000000000 +0800
+++ include/sound/asound.h 2009-09-15 00:44:37.000000000 +0800
-@@ -62,6 +62,31 @@
+@@ -62,6 +62,33 @@
#include <sys/ioctl.h>
#endif
@@ -110,6 +110,8 @@
+#define ESTRPIPE 0x7a69 /* Linux PCM suspend errno, fehh?! */
+#define EBADFD EBADF
+
++typedef uint64_t __u64;
++
+#define bswap_16(x) bswap16(x)
+#define bswap_32(x) bswap32(x)
+#define bswap_64(x) bswap64(x)
@@ -182,6 +184,20 @@
#include <string.h>
#define __USE_GNU
+--- src/conf.c.orig
++++ src/conf.c
+@@ -428,7 +428,11 @@ beginning:</P>
+
+ #ifdef HAVE_LIBPTHREAD
+ static pthread_mutex_t snd_config_update_mutex =
++#ifdef PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP
+ PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP;
++#else
++ PTHREAD_MUTEX_INITIALIZER;
++#endif
+ #endif
+
+ struct _snd_config {
--- src/pcm/pcm.c.orig 2009-09-09 20:34:54.000000000 +0800
+++ src/pcm/pcm.c 2009-09-15 00:19:09.000000000 +0800
@@ -630,7 +630,9 @@
diff --git a/audio/alsa-lib/files/patch-versionsort b/audio/alsa-lib/files/patch-versionsort
new file mode 100644
index 000000000000..8009c8c117d5
--- /dev/null
+++ b/audio/alsa-lib/files/patch-versionsort
@@ -0,0 +1,157 @@
+based on https://bugs.busybox.net/show_bug.cgi?id=3529
+
+--- include/local.h.orig
++++ include/local.h
+@@ -285,4 +285,125 @@ int snd_config_search_alias_hooks(snd_co
+ const char *base, const char *key,
+ snd_config_t **result);
+
++#ifdef NEED_VERSIONSORT
++
++/* Compare strings while treating digits characters numerically.
++ Copyright (C) 1997, 2002 Free Software Foundation, Inc.
++ This file is part of the GNU C Library.
++ Contributed by Jean-François Bignolles <bignolle@ecoledoc.ibp.fr>, 1997.
++
++ The GNU C Library is free software; you can redistribute it and/or
++ modify it under the terms of the GNU Lesser General Public
++ License as published by the Free Software Foundation; either
++ version 2.1 of the License, or (at your option) any later version.
++
++ The GNU C Library is distributed in the hope that it will be useful,
++ but WITHOUT ANY WARRANTY; without even the implied warranty of
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ Lesser General Public License for more details.
++
++ You should have received a copy of the GNU Lesser General Public
++ License along with the GNU C Library; if not, write to the Free
++ Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
++ 02111-1307 USA. */
++
++#include <string.h>
++#include <ctype.h>
++
++
++/* states: S_N: normal, S_I: comparing integral part, S_F: comparing
++ fractionnal parts, S_Z: idem but with leading Zeroes only */
++#define S_N 0x0
++#define S_I 0x4
++#define S_F 0x8
++#define S_Z 0xC
++
++/* result_type: CMP: return diff; LEN: compare using len_diff/diff */
++#define CMP 2
++#define LEN 3
++
++/* Compare S1 and S2 as strings holding indices/version numbers,
++ returning less than, equal to or greater than zero if S1 is less than,
++ equal to or greater than S2 (for more info, see the texinfo doc).
++*/
++static inline
++int strverscmp (s1, s2)
++ const char *s1;
++ const char *s2;
++{
++ const unsigned char *p1 = (const unsigned char *) s1;
++ const unsigned char *p2 = (const unsigned char *) s2;
++ unsigned char c1, c2;
++ int state;
++ int diff;
++
++ /* Symbol(s) 0 [1-9] others (padding)
++ Transition (10) 0 (01) d (00) x (11) - */
++ static const unsigned int next_state[] =
++ {
++ /* state x d 0 - */
++ /* S_N */ S_N, S_I, S_Z, S_N,
++ /* S_I */ S_N, S_I, S_I, S_I,
++ /* S_F */ S_N, S_F, S_F, S_F,
++ /* S_Z */ S_N, S_F, S_Z, S_Z
++ };
++
++ static const int result_type[] =
++ {
++ /* state x/x x/d x/0 x/- d/x d/d d/0 d/-
++ 0/x 0/d 0/0 0/- -/x -/d -/0 -/- */
++
++ /* S_N */ CMP, CMP, CMP, CMP, CMP, LEN, CMP, CMP,
++ CMP, CMP, CMP, CMP, CMP, CMP, CMP, CMP,
++ /* S_I */ CMP, -1, -1, CMP, +1, LEN, LEN, CMP,
++ +1, LEN, LEN, CMP, CMP, CMP, CMP, CMP,
++ /* S_F */ CMP, CMP, CMP, CMP, CMP, LEN, CMP, CMP,
++ CMP, CMP, CMP, CMP, CMP, CMP, CMP, CMP,
++ /* S_Z */ CMP, +1, +1, CMP, -1, CMP, CMP, CMP,
++ -1, CMP, CMP, CMP
++ };
++
++ if (p1 == p2)
++ return 0;
++
++ c1 = *p1++;
++ c2 = *p2++;
++ /* Hint: '0' is a digit too. */
++ state = S_N | ((c1 == '0') + (isdigit (c1) != 0));
++
++ while ((diff = c1 - c2) == 0 && c1 != '\0')
++ {
++ state = next_state[state];
++ c1 = *p1++;
++ c2 = *p2++;
++ state |= (c1 == '0') + (isdigit (c1) != 0);
++ }
++
++ state = result_type[state << 2 | (((c2 == '0') + (isdigit (c2) != 0)))];
++
++ switch (state)
++ {
++ case CMP:
++ return diff;
++
++ case LEN:
++ while (isdigit (*p1++))
++ if (!isdigit (*p2++))
++ return 1;
++
++ return isdigit (*p2) ? -1 : diff;
++
++ default:
++ return state;
++ }
++}
++
++static inline
++int versionsort(const void * a, const void * b)
++{
++ return strverscmp ((*(const struct dirent **) a)->d_name,
++ (*(const struct dirent **) b)->d_name);
++}
++
++#endif
+ #endif
+--- src/conf.c.orig
++++ src/conf.c
+@@ -419,6 +419,9 @@ beginning:</P>
+ #include <sys/stat.h>
+ #include <dirent.h>
+ #include <locale.h>
++#if defined(__FreeBSD__) || __UCLIBC_MAJOR__ == 0 && __UCLIBC_MINOR__ == 9 && __UCLIBC_SUBLEVEL__ <= 30
++#define NEED_VERSIONSORT
++#endif
+ #include "local.h"
+ #ifdef HAVE_LIBPTHREAD
+ #include <pthread.h>
+--- src/ucm/parser.c.orig
++++ src/ucm/parser.c
+@@ -30,8 +30,11 @@
+ * Jaroslav Kysela <perex@perex.cz>
+ */
+
+-#include "ucm_local.h"
+ #include <dirent.h>
++#if defined(__FreeBSD__) || __UCLIBC_MAJOR__ == 0 && __UCLIBC_MINOR__ == 9 && __UCLIBC_SUBLEVEL__ <= 30
++#define NEED_VERSIONSORT
++#endif
++#include "ucm_local.h"
+
+ /** The name of the environment variable containing the UCM directory */
+ #define ALSA_CONFIG_UCM_VAR "ALSA_CONFIG_UCM"
diff --git a/audio/alsa-lib/pkg-plist b/audio/alsa-lib/pkg-plist
index 1acf9a836de9..3de2b726a93e 100644
--- a/audio/alsa-lib/pkg-plist
+++ b/audio/alsa-lib/pkg-plist
@@ -28,10 +28,12 @@ include/alsa/seqmid.h
include/alsa/sound/asound_fm.h
include/alsa/sound/emu10k1.h
include/alsa/sound/hdsp.h
+include/alsa/sound/hdspm.h
include/alsa/sound/sb16_csp.h
include/alsa/sound/sscape_ioctl.h
include/alsa/sound/type_compat.h
include/alsa/timer.h
+include/alsa/use-case.h
include/alsa/version.h
include/sys/asoundlib.h
lib/alsa-lib/smixer/smixer-ac97.la
@@ -46,6 +48,7 @@ lib/libasound.so.2
libdata/pkgconfig/alsa.pc
share/aclocal/alsa.m4
share/alsa/alsa.conf
+share/alsa/alsa.conf.d/README
share/alsa/cards/AACI.conf
share/alsa/cards/ATIIXP-MODEM.conf
share/alsa/cards/ATIIXP-SPDMA.conf
@@ -70,6 +73,8 @@ share/alsa/cards/ENS1370.conf
share/alsa/cards/ENS1371.conf
share/alsa/cards/ES1968.conf
share/alsa/cards/FM801.conf
+share/alsa/cards/FWSpeakers.conf
+share/alsa/cards/FireWave.conf
share/alsa/cards/GUS.conf
share/alsa/cards/HDA-Intel.conf
share/alsa/cards/ICE1712.conf
@@ -125,6 +130,7 @@ etc/asound.conf.sample
@dirrm share/alsa/pcm
@dirrm share/alsa/cards/SI7018
@dirrm share/alsa/cards
+@dirrm share/alsa/alsa.conf.d
@dirrm share/alsa
@dirrm lib/alsa-lib/smixer
@dirrm lib/alsa-lib