aboutsummaryrefslogtreecommitdiff
path: root/audio/alsa-lib
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-11-10 22:21:08 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-11-10 22:21:08 +0000
commit55e2d7a835681f340cbfbc4bde64d0078b68394b (patch)
treede3deeadbe46b0eb8268ed42358e8956525125e1 /audio/alsa-lib
parentee42a3a263eebfcc9b9a24978cac11e6a593cc73 (diff)
downloadports-55e2d7a835681f340cbfbc4bde64d0078b68394b.tar.gz
ports-55e2d7a835681f340cbfbc4bde64d0078b68394b.zip
Notes
Diffstat (limited to 'audio/alsa-lib')
-rw-r--r--audio/alsa-lib/Makefile4
-rw-r--r--audio/alsa-lib/distinfo4
-rw-r--r--audio/alsa-lib/files/linux/types.h8
-rw-r--r--audio/alsa-lib/files/patch-src_topology_parser.c10
-rw-r--r--audio/alsa-lib/pkg-plist6
5 files changed, 28 insertions, 4 deletions
diff --git a/audio/alsa-lib/Makefile b/audio/alsa-lib/Makefile
index 8d09e4cf299b..63ec52313555 100644
--- a/audio/alsa-lib/Makefile
+++ b/audio/alsa-lib/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= alsa-lib
-PORTVERSION= 1.0.29
+PORTVERSION= 1.1.0
CATEGORIES= audio
MASTER_SITES= ALSA/lib \
GENTOO
@@ -33,6 +33,8 @@ post-patch: .SILENT
-e '/pythonlibs/s/--libs/--ldflags/' \
-e '/-D_GNU_SOURCE/d' \
-e '/lt_cv_dlopen/s/-ldl//g' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e '/if.*_GNU_SOURCE/,/endif/d' \
+ ${WRKSRC}/include/config.h.in
${REINPLACE_CMD} '/LIBADD/s/-ldl//g' \
${WRKSRC}/modules/mixer/simple/Makefile.in
${REINPLACE_CMD} 's|/etc|${PREFIX}&|g' \
diff --git a/audio/alsa-lib/distinfo b/audio/alsa-lib/distinfo
index 81bb4bad69ae..9c08cc676bef 100644
--- a/audio/alsa-lib/distinfo
+++ b/audio/alsa-lib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (alsa-lib-1.0.29.tar.bz2) = 73043c35eb9636be0f4af6a240235c213f12a25feb1f04aeeac8cb7e30fcbdd0
-SIZE (alsa-lib-1.0.29.tar.bz2) = 905417
+SHA256 (alsa-lib-1.1.0.tar.bz2) = dfde65d11e82b68f82e562ab6228c1fb7c78854345d3c57e2c68a9dd3dae1f15
+SIZE (alsa-lib-1.1.0.tar.bz2) = 929874
diff --git a/audio/alsa-lib/files/linux/types.h b/audio/alsa-lib/files/linux/types.h
index 3fb397037f72..e6167fc3d1f2 100644
--- a/audio/alsa-lib/files/linux/types.h
+++ b/audio/alsa-lib/files/linux/types.h
@@ -1,11 +1,17 @@
#ifndef _LINUX_TYPES_H
#define _LINUX_TYPES_H
+#include <sys/types.h>
+
#define __bitwise
+#define __le16 __u16
+#define __le32 __u32
+#define __le64 __u64
-typedef int __kernel_pid_t;
+typedef pid_t __kernel_pid_t;
typedef off_t __kernel_off_t;
+typedef uint16_t __u16;
typedef uint32_t __u32;
typedef uint64_t __u64;
#endif /* _LINUX_TYPES_H */
diff --git a/audio/alsa-lib/files/patch-src_topology_parser.c b/audio/alsa-lib/files/patch-src_topology_parser.c
new file mode 100644
index 000000000000..30338b65d30f
--- /dev/null
+++ b/audio/alsa-lib/files/patch-src_topology_parser.c
@@ -0,0 +1,10 @@
+--- src/topology/parser.c.orig 2015-11-09 07:39:18 UTC
++++ src/topology/parser.c
+@@ -18,6 +18,7 @@
+
+ #include "list.h"
+ #include "tplg_local.h"
++#include <sys/stat.h>
+
+ /*
+ * Parse compound
diff --git a/audio/alsa-lib/pkg-plist b/audio/alsa-lib/pkg-plist
index fe824c9c4887..bcc41e7a8f00 100644
--- a/audio/alsa-lib/pkg-plist
+++ b/audio/alsa-lib/pkg-plist
@@ -25,14 +25,17 @@ include/alsa/seq.h
include/alsa/seq_event.h
include/alsa/seq_midi_event.h
include/alsa/seqmid.h
+include/alsa/sound/asoc.h
include/alsa/sound/asound_fm.h
include/alsa/sound/emu10k1.h
include/alsa/sound/hdsp.h
include/alsa/sound/hdspm.h
include/alsa/sound/sb16_csp.h
include/alsa/sound/sscape_ioctl.h
+include/alsa/sound/tlv.h
include/alsa/sound/type_compat.h
include/alsa/timer.h
+include/alsa/topology.h
include/alsa/use-case.h
include/alsa/version.h
include/sys/asoundlib.h
@@ -130,6 +133,7 @@ share/alsa/pcm/surround51.conf
share/alsa/pcm/surround71.conf
share/alsa/smixer.conf
share/alsa/sndo-mixer.alisp
+share/alsa/topology/broadwell/broadwell.conf
share/alsa/ucm/DAISY-I2S/DAISY-I2S.conf
share/alsa/ucm/DAISY-I2S/HiFi.conf
share/alsa/ucm/GoogleNyan/GoogleNyan.conf
@@ -158,5 +162,7 @@ share/alsa/ucm/SDP4430/hifiLP
share/alsa/ucm/SDP4430/record
share/alsa/ucm/SDP4430/voice
share/alsa/ucm/SDP4430/voiceCall
+share/alsa/ucm/broadwell-rt286/HiFi
+share/alsa/ucm/broadwell-rt286/broadwell-rt286.conf
share/alsa/ucm/tegraalc5632/tegraalc5632.conf
@sample etc/asound.conf.sample