aboutsummaryrefslogtreecommitdiff
path: root/audio/alsa-plugins
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-09 15:20:35 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-09 15:20:35 +0000
commit46b7762a82cdc0c94eeafd3a686bad427433ccb4 (patch)
treee69277546fcd8c9ef3f433ee70374b1ae0d9db62 /audio/alsa-plugins
parentc9c0fba3555ebe2bc14b5a4b9a85b7922a1c5083 (diff)
audio/alsa-(lib|plugins|utils): Upgrade version 1.0.27.2 => 1.0.28
Also switch maintainership to submitter with blessing of former maintainer. Other changes include: * fix for bug 191190 * Use new options syntax * Proper detection of PYTHON and FFMPEG * fix leftovers * strip libraries to satisfy stage-qa * conf: alias surround stuff to pcm.default * lib: split patches and refactor * utils: rename XMLTO to MANPAGES PR: 191524 Submitted by: Jan Beich Approved by: former maintainer (Aragon Gouveia)
Notes
Notes: svn path=/head/; revision=364447
Diffstat (limited to 'audio/alsa-plugins')
-rw-r--r--audio/alsa-plugins/Makefile79
-rw-r--r--audio/alsa-plugins/distinfo4
-rw-r--r--audio/alsa-plugins/files/alsa-plugins.patch9
-rw-r--r--audio/alsa-plugins/files/patch-ffmpeg-version13
-rw-r--r--audio/alsa-plugins/files/patch-jack-pcm_jack.c12
-rw-r--r--audio/alsa-plugins/files/patch-usb_stream-pcm_usb_stream.c14
-rw-r--r--audio/alsa-plugins/pkg-plist3
7 files changed, 36 insertions, 98 deletions
diff --git a/audio/alsa-plugins/Makefile b/audio/alsa-plugins/Makefile
index 613aab2c828f..807cad449d66 100644
--- a/audio/alsa-plugins/Makefile
+++ b/audio/alsa-plugins/Makefile
@@ -2,86 +2,63 @@
# $FreeBSD$
PORTNAME= alsa-plugins
-PORTVERSION= 1.0.27
-PORTREVISION= 3
+PORTVERSION= 1.0.28
CATEGORIES= audio
MASTER_SITES= ALSA/plugins \
GENTOO/distfiles
-MAINTAINER= aragon@phat.za.net
+MAINTAINER= jbeich@vfemail.net
COMMENT= ALSA compatibility library plugins
+LICENSE= LGPL21 # or any later version
+
LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
GNU_CONFIGURE= yes
USES= tar:bzip2 pkgconfig libtool:keepla
-LDFLAGS+= -L${LOCALBASE}/lib
EXTRA_PATCHES+= ${FILESDIR}/alsa-plugins.patch
+INSTALL_TARGET= install-strip
+CPPFLAGS+= -I${.CURDIR}/../alsa-lib/files
+LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFAULT=BUFSZ_P2 IO_PTR
OPTIONS_DEFINE= JACK FFMPEG PULSEAUDIO SAMPLERATE SPEEX
-OPTIONS_SUB= ${OPTIONS_DEFINE}
+OPTIONS_SUB= yes
OPTIONS_GROUP= OSS
OPTIONS_GROUP_OSS=IO_PTR BLKCNT_P2 BUFSZ_P2 VERBOSE
IO_PTR_DESC= Precise playback/recording pointer
BLKCNT_P2_DESC= Restrict number of fragments to ^2 aligned
-BUFSZ_P2_DESC= Restrict buffer size to ^2 aligned (breaks aplay)
+BUFSZ_P2_DESC= Restrict buffer size to ^2 aligned
VERBOSE_DESC= Print debugging messages
-.include <bsd.port.options.mk>
+IO_PTR_CFLAGS= -DFREEBSD_OSS_USE_IO_PTR
+BLKCNT_P2_CFLAGS=-DFREEBSD_OSS_BLKCNT_P2
+BUFSZ_P2_CFLAGS=-DFREEBSD_OSS_BUFSZ_P2
+VERBOSE_CFLAGS= -DFREEBSD_OSS_DEBUG_VERBOSE
-.if ${PORT_OPTIONS:MIO_PTR}
-CFLAGS+= -DFREEBSD_OSS_USE_IO_PTR
-.endif
-
-.if ${PORT_OPTIONS:MBLKCNT_P2}
-CFLAGS+= -DFREEBSD_OSS_BLKCNT_P2
-.endif
-
-.if ${PORT_OPTIONS:MBUFSZ_P2}
-CFLAGS+= -DFREEBSD_OSS_BUFSZ_P2
-.endif
+JACK_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack
+JACK_CONFIGURE_ENABLE= jack
-.if ${PORT_OPTIONS:MVERBOSE}
-CFLAGS+= -DFREEBSD_OSS_DEBUG_VERBOSE
-.endif
+FFMPEG_LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
+FFMPEG_CONFIGURE_ENABLE=avcodec
+FFMPEG_CPPFLAGS= -I${LOCALBASE}/include
-.if ${PORT_OPTIONS:MJACK}
-.if empty(PORT_OPTIONS:MSAMPLERATE)
-IGNORE= JACK audio support requires SAMPLERATE
-.endif
-LIB_DEPENDS+= libjack.so:${PORTSDIR}/audio/jack
-.else
-CONFIGURE_ARGS+= --disable-jack
-.endif
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
+PULSEAUDIO_CONFIGURE_ENABLE=pulseaudio
-.if ${PORT_OPTIONS:MFFMPEG}
-CONFIGURE_ARGS+= --enable-avcodec
-CFLAGS+= -I${LOCALBASE}/include
-LIB_DEPENDS+= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
-.else
-CONFIGURE_ARGS+= --disable-avcodec
-.endif
+SAMPLERATE_LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
+SAMPLERATE_CONFIGURE_ENABLE=samplerate
-.if ${PORT_OPTIONS:MPULSEAUDIO}
-LIB_DEPENDS+= libpulse.so:${PORTSDIR}/audio/pulseaudio
-.else
-CONFIGURE_ARGS+= --disable-pulseaudio
-.endif
+SPEEX_LIB_DEPENDS= libspeex.so:${PORTSDIR}/audio/speex
+SPEEX_CONFIGURE_ON= --with-speex=lib
+SPEEX_CONFIGURE_OFF= --without-speex
-.if ${PORT_OPTIONS:MSAMPLERATE}
-LIB_DEPENDS+= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
-.else
-CONFIGURE_ARGS+= --disable-samplerate
-.endif
+.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MSPEEX}
-CONFIGURE_ARGS+= --with-speex=lib
-LIB_DEPENDS+= libspeex.so:${PORTSDIR}/audio/speex
-.else
-CONFIGURE_ARGS+= --without-speex
+.if ${PORT_OPTIONS:MJACK} && empty(PORT_OPTIONS:MSAMPLERATE)
+IGNORE= JACK audio support requires SAMPLERATE
.endif
post-patch: .SILENT
diff --git a/audio/alsa-plugins/distinfo b/audio/alsa-plugins/distinfo
index ca8889a1cd48..afa467fb8906 100644
--- a/audio/alsa-plugins/distinfo
+++ b/audio/alsa-plugins/distinfo
@@ -1,2 +1,2 @@
-SHA256 (alsa-plugins-1.0.27.tar.bz2) = 0bbd0c37c2dd7baf16363afb2e58169ffb0f9c0a70031b3b6235594630f3ab35
-SIZE (alsa-plugins-1.0.27.tar.bz2) = 363593
+SHA256 (alsa-plugins-1.0.28.tar.bz2) = 426f8af1a07ee9d8c06449524d1f0bd59a06e0331a51aa3d59d343a7c6d03120
+SIZE (alsa-plugins-1.0.28.tar.bz2) = 366023
diff --git a/audio/alsa-plugins/files/alsa-plugins.patch b/audio/alsa-plugins/files/alsa-plugins.patch
index 0e3c21e2dca4..227ca5a0c43e 100644
--- a/audio/alsa-plugins/files/alsa-plugins.patch
+++ b/audio/alsa-plugins/files/alsa-plugins.patch
@@ -42,14 +42,11 @@
oss->ext.private_data = oss;
--- oss/pcm_oss.c.orig 2009-08-31 21:09:41.000000000 +0800
+++ oss/pcm_oss.c 2009-09-28 14:54:12.000000000 +0800
-@@ -22,17 +22,48 @@
+@@ -22,17 +22,41 @@
#include <sys/ioctl.h>
#include <alsa/asoundlib.h>
#include <alsa/pcm_external.h>
#include <linux/soundcard.h>
-+#ifdef __FreeBSD__
-+#include <sys/param.h>
-+#endif
+
+#define ARRAY_SIZE(x) (sizeof(x) / sizeof(*(x)))
+
@@ -58,11 +55,7 @@
+#define FREEBSD_OSS_RATE_MAX 384000
+
+#define FREEBSD_OSS_CHANNELS_MIN 1
-+#ifndef __DragonFly__
+#define FREEBSD_OSS_CHANNELS_MAX 8
-+#else
-+#define FREEBSD_OSS_CHANNELS_MAX 2
-+#endif
+
+#define FREEBSD_OSS_BUFSZ_MAX 131072
+#define FREEBSD_OSS_BLKCNT_MIN 2
diff --git a/audio/alsa-plugins/files/patch-ffmpeg-version b/audio/alsa-plugins/files/patch-ffmpeg-version
deleted file mode 100644
index f8cdb292280a..000000000000
--- a/audio/alsa-plugins/files/patch-ffmpeg-version
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: a52/pcm_a52.c
-===================================================================
---- a52/pcm_a52.c
-+++ a52/pcm_a52.c
-@@ -27,7 +27,7 @@
- #include <alsa/pcm_plugin.h>
- #include AVCODEC_HEADER
-
--#if LIBAVCODEC_VERSION_MAJOR >= 53 && LIBAVCODEC_VERSION_MINOR >= 34
-+#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(53,34,0)
- #include <libavutil/audioconvert.h>
- #include <libavutil/mem.h>
- #define USE_AVCODEC_FRAME
diff --git a/audio/alsa-plugins/files/patch-jack-pcm_jack.c b/audio/alsa-plugins/files/patch-jack-pcm_jack.c
deleted file mode 100644
index 643954784152..000000000000
--- a/audio/alsa-plugins/files/patch-jack-pcm_jack.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- jack/pcm_jack.c.orig 2009-09-16 04:33:36.000000000 +0800
-+++ jack/pcm_jack.c 2009-09-16 04:33:55.000000000 +0800
-@@ -20,7 +20,9 @@
- *
- */
-
-+#ifndef __FreeBSD__
- #include <byteswap.h>
-+#endif
- #include <sys/shm.h>
- #include <sys/types.h>
- #include <sys/socket.h>
diff --git a/audio/alsa-plugins/files/patch-usb_stream-pcm_usb_stream.c b/audio/alsa-plugins/files/patch-usb_stream-pcm_usb_stream.c
index 57f7f13f525d..5dd11f5555ce 100644
--- a/audio/alsa-plugins/files/patch-usb_stream-pcm_usb_stream.c
+++ b/audio/alsa-plugins/files/patch-usb_stream-pcm_usb_stream.c
@@ -2,21 +2,11 @@ based on https://github.com/dankamongmen/libdank/blob/master/libdank/compat-Free
--- usb_stream/pcm_usb_stream.c.orig
+++ usb_stream/pcm_usb_stream.c
-@@ -19,7 +19,9 @@
- */
-
- #define _GNU_SOURCE
-+#ifndef __FreeBSD__
- #include <byteswap.h>
-+#endif
- #include <sys/mman.h>
- #include <sys/shm.h>
- #include <sys/ioctl.h>
@@ -79,6 +81,69 @@ typedef struct {
static struct user_usb_stream *uus;
static pthread_mutex_t uus_mutex = PTHREAD_MUTEX_INITIALIZER;
-+#ifdef __FreeBSD__
++#ifndef __linux__
+/*
+ * Copyright (c) 2000-2011, Nick Black et al
+ * All rights reserved.
@@ -86,7 +76,7 @@ based on https://github.com/dankamongmen/libdank/blob/master/libdank/compat-Free
}
-+#ifndef __FreeBSD__
++#ifdef __linux__
uus->s = mremap(uus->s, sizeof(struct usb_stream), uus->s->read_size, MREMAP_MAYMOVE);
+#else
+ uus->s = mremap_compat(us->pfd.fd, uus->s, sizeof(struct usb_stream), uus->s->read_size, PROT_READ, MAP_SHARED);
diff --git a/audio/alsa-plugins/pkg-plist b/audio/alsa-plugins/pkg-plist
index a7a8b1d3dbdb..2902c173a459 100644
--- a/audio/alsa-plugins/pkg-plist
+++ b/audio/alsa-plugins/pkg-plist
@@ -40,3 +40,6 @@ lib/alsa-lib/libasound_module_pcm_vdownmix.so
%%SPEEX%%lib/alsa-lib/libasound_module_rate_speexrate_medium.so
%%PULSEAUDIO%%share/alsa/alsa.conf.d/50-pulseaudio.conf
%%PULSEAUDIO%%share/alsa/alsa.conf.d/99-pulseaudio-default.conf.example
+%%PULSEAUDIO%%@dirrmtry share/alsa/alsa.conf.d
+%%PULSEAUDIO%%@dirrmtry share/alsa
+@dirrmtry lib/alsa-lib