aboutsummaryrefslogtreecommitdiff
path: root/audio/alsa-utils
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-06-06 00:29:32 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-06-06 00:29:32 +0000
commit5622904a468db67fef30118b5148228c3946dbb9 (patch)
tree34ff9b4334cf2194649554199a063378c0f8aead /audio/alsa-utils
parent28ff9f46261467da9408e3089d223a9644b70d0c (diff)
downloadports-5622904a468db67fef30118b5148228c3946dbb9.tar.gz
ports-5622904a468db67fef30118b5148228c3946dbb9.zip
Notes
Diffstat (limited to 'audio/alsa-utils')
-rw-r--r--audio/alsa-utils/Makefile39
-rw-r--r--audio/alsa-utils/pkg-plist4
2 files changed, 35 insertions, 8 deletions
diff --git a/audio/alsa-utils/Makefile b/audio/alsa-utils/Makefile
index ba1dcd5cc3f4..6f2af6fb5b1d 100644
--- a/audio/alsa-utils/Makefile
+++ b/audio/alsa-utils/Makefile
@@ -7,6 +7,7 @@
PORTNAME= alsa-utils
PORTVERSION= 1.0.23
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ftp://ftp.silug.org/pub/alsa/utils/ \
ftp://gd.tuwien.ac.at/opsys/linux/alsa/utils/ \
@@ -17,24 +18,46 @@ MAINTAINER= aragon@phat.za.net
COMMENT= ALSA compatibility utils
LIB_DEPENDS= asound.2:${PORTSDIR}/audio/alsa-lib
-BUILD_DEPENDS= xmlto:${PORTSDIR}/textproc/xmlto
RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/audio/alsa-plugins
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS+= --disable-nls
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include"
MANLANG= "" fr
MAN1_EN= aconnect.1 alsactl.1 alsamixer.1 amidi.1 amixer.1 aplay.1 aplaymidi.1 \
arecordmidi.1 aseqdump.1 aseqnet.1 iecset.1 speaker-test.1
-MAN7_EN= alsactl_init.7
-MAN8_EN= alsaconf.8
-MAN8_FR= alsaconf.8
-MLINKS_EN= aplay.1 arecord.1
+MAN8= alsaconf.8
+MLINKS= aplay.1 arecord.1
+
+OPTIONS= XMLTO "Generate alsactl_init(7) man page using xmlto(1)" On
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_XMLTO)
+BUILD_DEPENDS+= xmlto:${PORTSDIR}/textproc/xmlto
+MAN7_EN+= alsactl_init.7
+.else
+CONFIGURE_ARGS+=--disable-xmlto
+.endif
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib -lintl"
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
post-patch: .SILENT
${REINPLACE_CMD} '/LIBS/s/-ldl//g' ${WRKSRC}/configure
+ ${FIND} -E ${WRKSRC} -type f -regex \
+ '.*\.([[:digit:]]|spec\.in|csv|xml)' -exec \
+ ${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' \
+ -e 's|/etc/asound\.conf|${LOCALBASE}&|g' {} +
+ ${REINPLACE_CMD} 's|/etc/asound\.state|${PREFIX}&|g' \
+ ${WRKSRC}/alsactl/alsactl.[1c]
.include <bsd.port.mk>
diff --git a/audio/alsa-utils/pkg-plist b/audio/alsa-utils/pkg-plist
index e53df4951e15..bb1e3e2d7507 100644
--- a/audio/alsa-utils/pkg-plist
+++ b/audio/alsa-utils/pkg-plist
@@ -19,6 +19,10 @@ share/alsa/init/help
share/alsa/init/info
share/alsa/init/test
share/alsa/speaker-test/sample_map.csv
+%%NLS%%share/locale/de/LC_MESSAGES/alsa-utils.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/alsa-utils.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/alsaconf.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/alsaconf.mo
share/sounds/alsa/Front_Center.wav
share/sounds/alsa/Front_Left.wav
share/sounds/alsa/Front_Right.wav