aboutsummaryrefslogtreecommitdiff
path: root/audio/amarok-fs/Makefile
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2007-07-04 20:08:47 +0000
committerDavid Thiel <lx@FreeBSD.org>2007-07-04 20:08:47 +0000
commit2d25ed8750a985bf3b6e72c5450e52cc18782385 (patch)
tree2f64ebadaadea98ac3cfb2d1082ac8effa1ec34a /audio/amarok-fs/Makefile
parent2127d129987ed574d706d4efe68a430fa3e6314c (diff)
downloadports-2d25ed8750a985bf3b6e72c5450e52cc18782385.tar.gz
ports-2d25ed8750a985bf3b6e72c5450e52cc18782385.zip
Notes
Diffstat (limited to 'audio/amarok-fs/Makefile')
-rw-r--r--audio/amarok-fs/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/audio/amarok-fs/Makefile b/audio/amarok-fs/Makefile
new file mode 100644
index 000000000000..feb72dc94d1f
--- /dev/null
+++ b/audio/amarok-fs/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: amarok-fs
+# Date created: 20 June 2007
+# Whom: Jason E. Hale <bsdkaffee@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= amarok-fs
+PORTVERSION= 0.5
+CATEGORIES= audio kde
+MASTER_SITES= http://www.kde-apps.org/CONTENT/content-files/ \
+ ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR= distfiles
+DISTNAME= 52641-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= bsdkaffee@gmail.com
+COMMENT= A full screen application for Amarok
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+RUN_DEPENDS= amarok:${PORTSDIR}/audio/amarok
+
+USE_GMAKE= yes
+USE_KDELIBS_VER=3
+INSTALLS_ICONS= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PORTDOCS= README theme-howto.txt
+
+MAKE_ENV+= QTDIR="${QT_PREFIX}" QMAKESPEC="freebsd-g++"
+
+QMAKE= ${LOCALBASE}/bin/qmake -unix -o
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ ${REINPLACE_CMD} -e 's|/usr/share/icons/amarokFS.png|amarokFS|' \
+ ${WRKSRC}/amarokFS.desktop
+ ${REINPLACE_CMD} -e 's|/usr/share/|${PREFIX}/share/|g' \
+ ${WRKSRC}/amfs-xml.cpp
+
+post-patch:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ ${QMAKE} Makefile amarokFS-xml.pro
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>