aboutsummaryrefslogtreecommitdiff
path: root/audio/amarok-fs
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2007-07-04 20:08:47 +0000
committerDavid Thiel <lx@FreeBSD.org>2007-07-04 20:08:47 +0000
commit2d25ed8750a985bf3b6e72c5450e52cc18782385 (patch)
tree2f64ebadaadea98ac3cfb2d1082ac8effa1ec34a /audio/amarok-fs
parent2127d129987ed574d706d4efe68a430fa3e6314c (diff)
downloadports-2d25ed8750a985bf3b6e72c5450e52cc18782385.tar.gz
ports-2d25ed8750a985bf3b6e72c5450e52cc18782385.zip
Notes
Diffstat (limited to 'audio/amarok-fs')
-rw-r--r--audio/amarok-fs/Makefile52
-rw-r--r--audio/amarok-fs/distinfo3
-rw-r--r--audio/amarok-fs/files/patch-amarokFS-xml.pro63
-rw-r--r--audio/amarok-fs/pkg-descr4
-rw-r--r--audio/amarok-fs/pkg-plist19
5 files changed, 141 insertions, 0 deletions
diff --git a/audio/amarok-fs/Makefile b/audio/amarok-fs/Makefile
new file mode 100644
index 000000000000..feb72dc94d1f
--- /dev/null
+++ b/audio/amarok-fs/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: amarok-fs
+# Date created: 20 June 2007
+# Whom: Jason E. Hale <bsdkaffee@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= amarok-fs
+PORTVERSION= 0.5
+CATEGORIES= audio kde
+MASTER_SITES= http://www.kde-apps.org/CONTENT/content-files/ \
+ ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR= distfiles
+DISTNAME= 52641-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= bsdkaffee@gmail.com
+COMMENT= A full screen application for Amarok
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+RUN_DEPENDS= amarok:${PORTSDIR}/audio/amarok
+
+USE_GMAKE= yes
+USE_KDELIBS_VER=3
+INSTALLS_ICONS= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PORTDOCS= README theme-howto.txt
+
+MAKE_ENV+= QTDIR="${QT_PREFIX}" QMAKESPEC="freebsd-g++"
+
+QMAKE= ${LOCALBASE}/bin/qmake -unix -o
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ ${REINPLACE_CMD} -e 's|/usr/share/icons/amarokFS.png|amarokFS|' \
+ ${WRKSRC}/amarokFS.desktop
+ ${REINPLACE_CMD} -e 's|/usr/share/|${PREFIX}/share/|g' \
+ ${WRKSRC}/amfs-xml.cpp
+
+post-patch:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ ${QMAKE} Makefile amarokFS-xml.pro
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/amarok-fs/distinfo b/audio/amarok-fs/distinfo
new file mode 100644
index 000000000000..f9c30b9e485f
--- /dev/null
+++ b/audio/amarok-fs/distinfo
@@ -0,0 +1,3 @@
+MD5 (52641-amarokFS-0.5.tar.gz) = 28b7432fa9abfb0a2211940990b3945a
+SHA256 (52641-amarokFS-0.5.tar.gz) = 52ee9b21d18b7d76999b25c1de3077d3f2ae774b18b8eca3d9605ceaf340cafc
+SIZE (52641-amarokFS-0.5.tar.gz) = 373310
diff --git a/audio/amarok-fs/files/patch-amarokFS-xml.pro b/audio/amarok-fs/files/patch-amarokFS-xml.pro
new file mode 100644
index 000000000000..38111625c719
--- /dev/null
+++ b/audio/amarok-fs/files/patch-amarokFS-xml.pro
@@ -0,0 +1,63 @@
+--- amarokFS-xml.pro.orig Mon Mar 19 08:17:58 2007
++++ amarokFS-xml.pro Wed Jun 20 17:23:39 2007
+@@ -3,13 +3,9 @@
+
+ CONFIG += qt warn_on release
+
+-INCLUDEPATH += /usr/include/kde
+-INCLUDEPATH += /usr/local/include/kde
+-INCLUDEPATH += /usr/include
+-INCLUDEPATH += /opt/kde3/include
+-INCLUDEPATH += /opt/kde/include
+-INCLUDEPATH += /usr/kde/3.5/include
+-
++INCLUDEPATH += /usr/include/
++INCLUDEPATH += ${LOCALBASE}/include/
++INCLUDEPATH += ${LOCALBASE}/include/X11
+
+ HEADERS = amfs-xml.h \
+ cb.h \
+@@ -25,36 +21,27 @@
+ label-pixmap.cpp
+
+ LIBS += -lkdecore
+-LIBS += -L/opt/kde3/lib
+-LIBS += -L/usr/local/kde3/lib
+-LIBS += -L/usr/lib/qt3
+-LIBS += -L/opt/kde/lib
+-LIBS += -L/usr/kde/3.5/lib
++LIBS += -L${LOCALBASE}/lib
++LIBS += -L${LOCALBASE}/lib/X11
+ LIBS += -lkio
+
+-images.path = /usr/share/amarokFS/images
++images.path = ${PREFIX}/share/amarokFS/images
+ images.files = images/*
+
+-defaultTheme.path = /usr/share/amarokFS
++defaultTheme.path = ${PREFIX}/share/amarokFS
+ defaultTheme.files = theme.xml
+
+-target.path = /usr/local/bin
++target.path = ${PREFIX}/bin
+
+ icon.files = amarokFS.png
+-icon.path = /usr/share/icons/
++icon.path = ${PREFIX}/share/icons/hicolor/128x128/apps/
+
+ desktop.files = amarokFS.desktop
+-desktop.path = /usr/share/applications/
++desktop.path = ${PREFIX}/share/applications/
+
+-docs.files = README
+-docs.files += theme-howto.txt
+-docs.path = /usr/share/doc/amarokFS
+-
+-
+ INSTALLS += target
+ INSTALLS += images
+ INSTALLS += desktop
+ INSTALLS += icon
+ INSTALLS += defaultTheme
+-INSTALLS += docs
+
diff --git a/audio/amarok-fs/pkg-descr b/audio/amarok-fs/pkg-descr
new file mode 100644
index 000000000000..2dec403b48b4
--- /dev/null
+++ b/audio/amarok-fs/pkg-descr
@@ -0,0 +1,4 @@
+amarokFS is a full screen front end for Amarok. It displays the current song
+status and provides basic controls.
+
+WWW: http://www.kde-apps.org/content/show.php?content=52641
diff --git a/audio/amarok-fs/pkg-plist b/audio/amarok-fs/pkg-plist
new file mode 100644
index 000000000000..6d253cd0ea5c
--- /dev/null
+++ b/audio/amarok-fs/pkg-plist
@@ -0,0 +1,19 @@
+bin/amarokFS
+%%DATADIR%%/images/gradient.png
+%%DATADIR%%/images/logo.png
+%%DATADIR%%/images/logoB.png
+%%DATADIR%%/images/player_end.png
+%%DATADIR%%/images/player_end2.png
+%%DATADIR%%/images/player_pause.png
+%%DATADIR%%/images/player_pause2.png
+%%DATADIR%%/images/player_play.png
+%%DATADIR%%/images/player_play2.png
+%%DATADIR%%/images/player_start.png
+%%DATADIR%%/images/player_start2.png
+%%DATADIR%%/images/player_stop.png
+%%DATADIR%%/images/player_stop2.png
+%%DATADIR%%/theme.xml
+share/applications/amarokFS.desktop
+share/icons/hicolor/128x128/apps/amarokFS.png
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%