aboutsummaryrefslogtreecommitdiff
path: root/audio/amarok-kde4/Makefile
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2006-08-02 12:09:59 +0000
committerMichael Landin <mich@FreeBSD.org>2006-08-02 12:09:59 +0000
commit332d5a2feff9b0be0b4abb198ea252b8f148d968 (patch)
treed1e5738f1f7e2261515eed4e31120d08f7a0a45e /audio/amarok-kde4/Makefile
parente804ccce92cd25511ec484c789bf1135d8a5c28b (diff)
- update to -> 1.4.1
- remove libvisual support, as only libvis-0.4 is supported - add extra patch for 4.x build
Notes
Notes: svn path=/head/; revision=169465
Diffstat (limited to 'audio/amarok-kde4/Makefile')
-rw-r--r--audio/amarok-kde4/Makefile23
1 files changed, 9 insertions, 14 deletions
diff --git a/audio/amarok-kde4/Makefile b/audio/amarok-kde4/Makefile
index 6cff56cfbe5e..3309fde08503 100644
--- a/audio/amarok-kde4/Makefile
+++ b/audio/amarok-kde4/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= amarok
-PORTVERSION= 1.4.0a
+PORTVERSION= 1.4.1
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,11 +14,11 @@ MAINTAINER= mich@FreeBSD.org
COMMENT= Media player for KDE
LIB_DEPENDS= tag.5:${PORTSDIR}/audio/taglib \
- tunepimp:${PORTSDIR}/audio/libtunepimp \
+ tunepimp.3:${PORTSDIR}/audio/libtunepimp-old \
mp4v2:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2 \
xine.15:${PORTSDIR}/multimedia/libxine
-MIN_OPTIONS_VER= ${PORTNAME}-1.4.0a
+MIN_OPTIONS_VER= ${PORTNAME}-1.4.1
USE_BZIP2= yes
USE_KDEBASE_VER=3
@@ -26,11 +26,9 @@ USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
USE_SDL= sdl
USE_RUBY= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-1.4.0
OPTIONS= GPOD "iPod support" on \
XMMS "XMMS visualizations" off \
- LIBVISUAL "libvisual support" off \
OPENGL "OpenGL support" on \
AMAZON "Amazon cover fetching support" on \
MYSQL "Use MySQL as collection backend" off \
@@ -38,9 +36,14 @@ OPTIONS= GPOD "iPod support" on \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES+= ${PATCHDIR}/extra-amarok_src_expression.h
+.endif
+
CONFIGURE_ARGS+=--without-exscalibar \
--with-mp4v2 \
- --with-mp4v2-dir=${PREFIX}
+ --with-mp4v2-dir=${PREFIX} \
+ --without-libvisual
.if !defined(WITH_GPOD)
PLIST_SUB+= GPOD="@comment "
@@ -59,14 +62,6 @@ LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
PLIST_SUB+= XMMS=""
.endif
-.if !defined(WITH_LIBVISUAL)
-PLIST_SUB+= LIBVISUAL="@comment "
-CONFIGURE_ARGS+=--without-libvisual
-.else
-LIB_DEPENDS+= visual.0:${PORTSDIR}/graphics/libvisual
-PLIST_SUB+= LIBVISUAL=""
-.endif
-
.if defined(WITHOUT_OPENGL)
CONFIGURE_ARGS+=--without-opengl
.endif