aboutsummaryrefslogtreecommitdiff
path: root/audio/amarok/Makefile
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2007-02-12 17:02:44 +0000
committerMichael Landin <mich@FreeBSD.org>2007-02-12 17:02:44 +0000
commit195e77a5c54300c4348067d23f463e3549291450 (patch)
treeeea18253ba3ff7499e01fc9d2b9a64c5f35ba699 /audio/amarok/Makefile
parent59cff98008a352586379b8d1f7530aafeecb38a9 (diff)
- update to -> 1.4.5
Changelog: http://amarok.kde.org/content/view/10/66/ PR: ports/108711 Submitted by: Alex<goo@t72.ru>
Notes
Notes: svn path=/head/; revision=185018
Diffstat (limited to 'audio/amarok/Makefile')
-rw-r--r--audio/amarok/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/audio/amarok/Makefile b/audio/amarok/Makefile
index 1fb62eb0173e..e530c6002fbc 100644
--- a/audio/amarok/Makefile
+++ b/audio/amarok/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= amarok
-PORTVERSION= 1.4.4
-PORTREVISION= 2
+PORTVERSION= 1.4.5
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}/${PORTVERSION}/src
@@ -32,7 +31,6 @@ USE_LDCONFIG= yes
OPTIONS= GPOD "iPod support" on \
NJB "Creative Nomad and Dell support" on \
MTP "MTP device support" on \
- XMMS "XMMS visualizations" off \
OPENGL "OpenGL support" on \
AMAZON "Amazon cover fetching support" on \
MYSQL "Use MySQL as collection backend" off \
@@ -74,15 +72,6 @@ CONFIGURE_ARGS+=--with-libmtp
PLIST_SUB+= MTP=""
.endif
-.if !defined(WITH_XMMS)
-PLIST_SUB+= XMMS="@comment "
-CONFIGURE_ARGS+=--without-xmms
-.else
-BUILD_DEPENDS+= xmms-config:${PORTSDIR}/multimedia/xmms
-LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
-PLIST_SUB+= XMMS=""
-.endif
-
.if defined(WITHOUT_OPENGL)
CONFIGURE_ARGS+=--without-opengl
.endif
@@ -101,6 +90,11 @@ USE_PGSQL= yes
CONFIGURE_ARGS+=--enable-postgresql
.endif
+.if defined(DEBUG)
+CONFIGURE_ARGS+=--enable-debug=full
+STRIP= # none
+.endif
+
pre-extract: check-options-version
post-patch: