aboutsummaryrefslogtreecommitdiff
path: root/audio/amarok/Makefile
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2019-07-06 12:27:30 +0000
committerDima Panov <fluffy@FreeBSD.org>2019-07-06 12:27:30 +0000
commitc99151c67bcb810d33fe0a63e639915264662f01 (patch)
tree470eaa64416893c0eb0201ee222bb75ec6c6cda8 /audio/amarok/Makefile
parent3f0cdea420d305192f33906d24562a6ecf6265b1 (diff)
- Update AmaroK to 2.9.70 snapshot
- Teach mysql library plugins to use SSL/Crypto libs directly - Allow to find and use mysql embedded library from MariaDB/PerconaDB
Notes
Notes: svn path=/head/; revision=505985
Diffstat (limited to 'audio/amarok/Makefile')
-rw-r--r--audio/amarok/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/audio/amarok/Makefile b/audio/amarok/Makefile
index aac2a44c3cb6..54125ab6e581 100644
--- a/audio/amarok/Makefile
+++ b/audio/amarok/Makefile
@@ -2,9 +2,9 @@
PORTNAME= amarok
DISTVERSIONPREFIX= v
-DISTVERSION= 2.9.0-277
-DISTVERSIONSUFFIX= -gd50ecc430c
-PORTREVISION= 4
+DISTVERSION= 2.9.70
+PKGVERSIONSUFFIX= -g${GH_TAGNAME}
+PORTREVISION= 0
CATEGORIES= audio kde
MAINTAINER= kde@FreeBSD.org
@@ -30,7 +30,7 @@ USE_QT= core concurrent declarative dbus gui location network phonon4 \
webkit widgets xml \
buildtools_build qmake_build
-USE_KDE= archive auth attica bookmarks codecs config configwidgets \
+USE_KDE= archive auth attica bookmarks codecs config configwidgets \
completion coreaddons crash dbusaddons dnssd globalaccel \
guiaddons i18n iconthemes itemviews jobwidgets kdeclarative \
kcmutils kio kirigami2 newstuff notifications notifyconfig \
@@ -42,6 +42,7 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= kde
+GH_TAGNAME= 0aa6ae0c77
SHEBANG_FILES= src/kconf_update/amarok-2.4.1-tokens_syntax_update.pl
CMAKE_ARGS= -DOPENSSL_ROOT_DIR=${OPENSSLBASE}
@@ -67,6 +68,7 @@ IPOD_CMAKE_BOOL= WITH_IPOD
MP3TUNES_DESC= MP3tunes support
MP3TUNES_LIB_DEPENDS= libloudmouth-1.so:net-im/loudmouth \
libcurl.so:ftp/curl
+MP3TUNES_LIB_DEPENDS_OFF= libgcrypt.so:security/libgcrypt
MP3TUNES_USE= GNOME=glib20,libxml2
MP3TUNES_USES= gnome ssl