aboutsummaryrefslogtreecommitdiff
path: root/audio/aqualung
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-04 23:07:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-04 23:07:36 +0000
commit53e60f4b39e2cf80bcb3823125a1d1a1aa87341f (patch)
tree3721b4a1fc205150ab43198e45c3411eac297264 /audio/aqualung
parent3b3772cc0f55df007e465ec37cce6cc7a2b20192 (diff)
downloadports-53e60f4b39e2cf80bcb3823125a1d1a1aa87341f.tar.gz
ports-53e60f4b39e2cf80bcb3823125a1d1a1aa87341f.zip
Support stage
Specify the port uses nested function (fix build on freebsd 10 and 11) Use options helpers (this fix inverted option checking)
Notes
Notes: svn path=/head/; revision=350184
Diffstat (limited to 'audio/aqualung')
-rw-r--r--audio/aqualung/Makefile29
-rw-r--r--audio/aqualung/pkg-plist1
2 files changed, 9 insertions, 21 deletions
diff --git a/audio/aqualung/Makefile b/audio/aqualung/Makefile
index db573214b762..5227a293e76d 100644
--- a/audio/aqualung/Makefile
+++ b/audio/aqualung/Makefile
@@ -3,7 +3,7 @@
PORTNAME= aqualung
DISTVERSION= 0.9beta11
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION} \
http://wickedmachine.net/mirror/
@@ -32,33 +32,24 @@ LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
libcddb.so:${PORTSDIR}/audio/libcddb \
libstrfunc.so:${PORTSDIR}/devel/libstrfunc
-NO_STAGE= yes
-USES= gmake pkgconfig gettext
+USES= gmake pkgconfig gettext compiler:nestedfct
USE_GNOME= gtk20 libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-transform-name="" --with-alsa=no --with-ifp=no \
--with-cdda=no
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lstrfunc
-MAN1= ${PORTNAME}.1
OPTIONS_DEFINE= JACK PULSEAUDIO DOCS
-.include <bsd.port.options.mk>
+JACK_CONFIGURE_OFF= --with-jack=no
+JACK_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack
+JACK_CONFIGURE_ON= --with-jack=yes
-.if ${PORT_OPTIONS:MJACK}
-CONFIGURE_ARGS+= --with-jack=no
-.else
-LIB_DEPENDS+= libjack.so:${PORTSDIR}/audio/jack
-CONFIGURE_ARGS+= --with-jack=yes
-.endif
+PULSEAUDIO_CONFIGURE_OFF= --with-pulse=no
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
+PULSEAUDIO_CONFIGURE_ON= --with-pulse=yes
-.if ${PORT_OPTIONS:MPULSEAUDIO}
-CONFIGURE_ARGS+= --with-pulse=no
-.else
-LIB_DEPENDS+= libpulse.so:${PORTSDIR}/audio/pulseaudio
-CONFIGURE_ARGS+= --with-pulse=yes
-.endif
post-patch:
@${REINPLACE_CMD} -e '/^docdir/s!=.*!= ${DOCSDIR}!'\
${WRKSRC}/doc/Makefile.in
@@ -66,9 +57,5 @@ post-patch:
# ${WRKSRC}/configure
@${ECHO_CMD} "#include <sys/stat.h>" >> ${WRKSRC}/src/common.h
@${ECHO_CMD} "#include <sys/types.h>" >> ${WRKSRC}/src/common.h
-.if ! ${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} -e '/^install-data-am/s!install-docDATA!!'\
- ${WRKSRC}/doc/Makefile.in
-.endif
.include <bsd.port.mk>
diff --git a/audio/aqualung/pkg-plist b/audio/aqualung/pkg-plist
index 3592cf9c0c44..6c690263a8e4 100644
--- a/audio/aqualung/pkg-plist
+++ b/audio/aqualung/pkg-plist
@@ -1,4 +1,5 @@
bin/aqualung
+man/man1/aqualung.1.gz
%%DATADIR%%/appearance.png
%%DATADIR%%/cdda.png
%%DATADIR%%/cddb.png