aboutsummaryrefslogtreecommitdiff
path: root/audio/ardour/Makefile
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2009-09-05 15:38:05 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2009-09-05 15:38:05 +0000
commit0a29e3508d9a171cd32ee61fd68981a6aa8df72b (patch)
tree2bbf788574cd0efc7777e27984248ed9f469bce4 /audio/ardour/Makefile
parentef90507da6797eabcd1e72096f457c6e575dbbd2 (diff)
Notes
Diffstat (limited to 'audio/ardour/Makefile')
-rw-r--r--audio/ardour/Makefile23
1 files changed, 5 insertions, 18 deletions
diff --git a/audio/ardour/Makefile b/audio/ardour/Makefile
index 8c237f03b833..2b037a876999 100644
--- a/audio/ardour/Makefile
+++ b/audio/ardour/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= ardour
-PORTVERSION= 2.7.1
-PORTREVISION= 2
+PORTVERSION= 2.8.2
CATEGORIES= audio
-MASTER_SITES= http://releases.ardour.org/
-DISTFILES= ardour-${DISTVERSION}.tar.bz2
-EXTRACT_ONLY= ardour-${DISTVERSION}.tar.bz2
+MASTER_SITES= http://releases.ardour.org/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= trasz
-MAINTAINER= danfe@FreeBSD.org
+MAINTAINER= trasz@FreeBSD.org
COMMENT= Ardour - a digital audio workstation
LIB_DEPENDS= lrdf.2:${PORTSDIR}/textproc/liblrdf \
@@ -62,21 +61,12 @@ BROKEN= does not compile
.endif
.if defined(WITH_VST)
-# Yes, 'PlugIns' is not a typo.
-VST_DIST+= vst_sdk2_3.zip
-RESTRICTED= Redistribution of the VST PlugIns SDK is not allowed
-RESTRICTED_FILES= ${VST_DIST}
-DISTFILES+= ${VST_DIST}
SCONS_ENV+= VST=yes
BUILD_DEPENDS+= winegcc:${PORTSDIR}/emulators/wine \
unzip:${PORTSDIR}/archivers/unzip \
gsed:${PORTSDIR}/textproc/gsed
LIB_DEPENDS+= wine.1:${PORTSDIR}/emulators/wine
-.if !exists(${DISTDIR}/${VST_DIST})
-IGNORE= download the VST 2.3 SDK from Steinberg (http://www.steinberg.de/331+M52087573ab0.html) and copy ${VST_DIST} into ${DISTDIR}
-.endif
-
PLIST_SUB+= NO_VST="@comment "
PLIST_SUB+= VST=""
.else
@@ -112,9 +102,6 @@ CFLAGS:= ${CFLAGS:N-fno-strict-aliasing}
post-patch:
${REINPLACE_CMD} -e "s|%%CFLAGS%%|${CFLAGS}|g" ${WRKSRC}/SConstruct
${REINPLACE_CMD} -e "s|alsa_pcm|oss|g" ${WRKSRC}/templates/*.template
-.if defined(WITH_VST)
- ${CP} ${DISTDIR}/${VST_DIST} ${WRKSRC}/libs/fst/
-.endif
post-install:
${CHOWN} -R 0:0 ${PREFIX}/lib/ardour2/