aboutsummaryrefslogtreecommitdiff
path: root/audio/ardour
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2008-04-11 16:48:29 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2008-04-11 16:48:29 +0000
commite26b69b0b2aa9506eaf3a0c6c0be6acc8bc04b2e (patch)
tree5224b77ad008c4962d6b89e344f511725cb8e148 /audio/ardour
parentcc18c45c56f041a186ad6e25e146a678557c6b2b (diff)
downloadports-e26b69b0b2aa9506eaf3a0c6c0be6acc8bc04b2e.tar.gz
ports-e26b69b0b2aa9506eaf3a0c6c0be6acc8bc04b2e.zip
Notes
Diffstat (limited to 'audio/ardour')
-rw-r--r--audio/ardour/Makefile3
-rw-r--r--audio/ardour/distinfo6
-rw-r--r--audio/ardour/files/patch-gtk2_ardour-engine_dialog.cc24
-rw-r--r--audio/ardour/pkg-plist22
4 files changed, 34 insertions, 21 deletions
diff --git a/audio/ardour/Makefile b/audio/ardour/Makefile
index ef9f846fe1bc..e1c688c94bce 100644
--- a/audio/ardour/Makefile
+++ b/audio/ardour/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ardour
-PORTVERSION= 2.3.1
+PORTVERSION= 2.4.1
CATEGORIES= audio
MASTER_SITES= http://ardour.org/files/releases/
DISTFILES= ardour-${DISTVERSION}.tar.bz2
@@ -40,7 +40,6 @@ TEMPLATESDIR= ${PREFIX}/share/ardour2/templates
PLIST_SUB= DISTVERSION=${DISTVERSION}
OPTIONS= OPTIMIZED_CFLAGS "Builds with compiler optimizations" on \
VST "Enable VST plugins support" off
-WRKSRC= ${WRKDIR}/ardour-2.3
.include <bsd.port.pre.mk>
diff --git a/audio/ardour/distinfo b/audio/ardour/distinfo
index 6ea777ec69ce..d844ff15ecfe 100644
--- a/audio/ardour/distinfo
+++ b/audio/ardour/distinfo
@@ -1,6 +1,6 @@
-MD5 (ardour-2.3.1.tar.bz2) = 54abb231ae0c1fa3b3f2c2177c644c22
-SHA256 (ardour-2.3.1.tar.bz2) = bb93e70ec608143e5a94cbee809ae5a7fcbb5f89a2c18fe03ac9c2ad00aa6651
-SIZE (ardour-2.3.1.tar.bz2) = 4348658
+MD5 (ardour-2.4.1.tar.bz2) = f132caaf613f3cb44ca9f9dafb38fbae
+SHA256 (ardour-2.4.1.tar.bz2) = 29d6ca482e13e58058616b6118a0d036429db2141fbd95811d7ad7536690484e
+SIZE (ardour-2.4.1.tar.bz2) = 3147427
MD5 (vst_sdk2_3.zip) = c91d3be58ad4e9c695d0a90b2198be0d
SHA256 (vst_sdk2_3.zip) = 5400e0bbfeef0ab8a67b48899a9e8067db47552f43b30d8d15323ab999523226
SIZE (vst_sdk2_3.zip) = 4147357
diff --git a/audio/ardour/files/patch-gtk2_ardour-engine_dialog.cc b/audio/ardour/files/patch-gtk2_ardour-engine_dialog.cc
index cbaa5f1261d1..48de52f7dc33 100644
--- a/audio/ardour/files/patch-gtk2_ardour-engine_dialog.cc
+++ b/audio/ardour/files/patch-gtk2_ardour-engine_dialog.cc
@@ -1,5 +1,5 @@
---- gtk2_ardour/engine_dialog.cc.orig 2008-01-15 03:58:38.000000000 +0100
-+++ gtk2_ardour/engine_dialog.cc 2008-01-15 22:30:06.000000000 +0100
+--- gtk2_ardour/engine_dialog.cc.orig 2008-04-09 23:17:02.000000000 +0200
++++ gtk2_ardour/engine_dialog.cc 2008-04-10 18:53:32.000000000 +0200
@@ -12,7 +12,7 @@
#include <CoreFoundation/CFString.h>
#include <sys/param.h>
@@ -64,7 +64,7 @@
label = manage (new Label (_("Input device")));
label->set_alignment (1.0, 0.5);
device_packer.attach (*label, 0, 1, row, row+1, FILL|EXPAND, (AttachOptions) 0);
-@@ -568,7 +570,7 @@
+@@ -570,7 +572,7 @@
void
EngineControl::realtime_changed ()
{
@@ -73,7 +73,7 @@
priority_spinner.set_sensitive (realtime_button.get_active());
#endif
}
-@@ -584,8 +586,10 @@
+@@ -586,8 +588,10 @@
#endif
#ifndef __APPLE__
@@ -84,7 +84,7 @@
} else if (driver == "FFADO") {
devices[driver] = enumerate_ffado_devices ();
} else if (driver == "OSS") {
-@@ -712,6 +716,7 @@
+@@ -714,6 +718,7 @@
return devs;
}
#else
@@ -92,7 +92,7 @@
vector<string>
EngineControl::enumerate_alsa_devices ()
{
-@@ -772,6 +777,7 @@
+@@ -774,6 +779,7 @@
return devs;
}
@@ -100,7 +100,17 @@
vector<string>
EngineControl::enumerate_ffado_devices ()
-@@ -860,7 +866,7 @@
+@@ -816,7 +822,9 @@
+ vector<string>& strings = devices[driver];
+
+ if (strings.empty() && driver != "FFADO" && driver != "Dummy") {
++#if 0
+ error << string_compose (_("No devices found for driver \"%1\""), driver) << endmsg;
++#endif
+ return;
+ }
+
+@@ -862,7 +870,7 @@
EngineControl::redisplay_latency ()
{
uint32_t rate = get_rate();
diff --git a/audio/ardour/pkg-plist b/audio/ardour/pkg-plist
index dc0ff4d15aca..6ced76a74ba6 100644
--- a/audio/ardour/pkg-plist
+++ b/audio/ardour/pkg-plist
@@ -4,7 +4,7 @@ lib/ardour2/libsndfile-ardour.so
lib/ardour2/libpbd.so
lib/ardour2/libmidi++.so
lib/ardour2/libardour.so
-%%NO_VST%%lib/ardour2/ardour-2.3
+%%NO_VST%%lib/ardour2/ardour-%%DISTVERSION%%
%%VST%%lib/ardour2/ardour_vst.exe.so
%%VST%%lib/ardour2/libardourgtk.so
lib/ardour2/libgtkmm2ext.so
@@ -23,14 +23,14 @@ lib/ardour2/vamp/libardourvampplugins.so
@dirrm lib/ardour2/vamp
@dirrm lib/ardour2
etc/ardour2/ardour.menus
-etc/ardour2/ardour.bindings
etc/ardour2/ardour_system.rc
etc/ardour2/ardour2_ui_dark.rc
etc/ardour2/ardour2_ui_light.rc
etc/ardour2/ardour2_ui_default.conf
etc/ardour2/ardour-sae.menus
-etc/ardour2/ardour-sae-ansi.bindings
-etc/ardour2/ardour-sae-de.bindings
+etc/ardour2/ergonomic-us.bindings
+etc/ardour2/mnemonic-us.bindings
+etc/ardour2/SAE-de.bindings
@dirrmtry etc/ardour2
share/ardour2/splash.png
share/ardour2/pixmaps/hslider00.xpm
@@ -112,12 +112,14 @@ share/ardour2/icons/ardour_icon_48px.png
share/ardour2/icons/ardour_icon_32px.png
share/ardour2/icons/ardour_icon_16px.png
share/ardour2/icons/saelogo.png
-share/ardour2/icons/saebig.png
-share/ardour2/icons/saelogo2.png
-share/ardour2/icons/saeoldlogo.png
share/ardour2/icons/sae.png
-share/ardour2/icons/ferret_01.png
share/ardour2/icons/ferret_02.png
+share/ardour2/icons/grabber_edit_point.png
+share/ardour2/icons/application-x-ardour_22px.png
+share/ardour2/icons/fader_belt_h.png
+share/ardour2/icons/application-x-ardour_32px.png
+share/ardour2/icons/application-x-ardour_48px.png
+share/ardour2/icons/application-x-ardour_16px.png
@dirrm share/ardour2/icons
share/ardour2/templates/16 Tracks.template
share/ardour2/templates/2 Track.template
@@ -132,6 +134,7 @@ share/locale/el_GR/LC_MESSAGES/gtk2_ardour.mo
share/locale/ru_RU/LC_MESSAGES/libgtkmm2ext.mo
share/locale/ru_RU/LC_MESSAGES/libardour2.mo
share/locale/ru_RU/LC_MESSAGES/gtk2_ardour.mo
+share/locale/po_PO/LC_MESSAGES/gtk2_ardour.mo
share/locale/pt_BR/LC_MESSAGES/libgtkmm2ext.mo
share/locale/pt_BR/LC_MESSAGES/gtk2_ardour.mo
share/locale/pt_PT/LC_MESSAGES/gtk2_ardour.mo
@@ -143,7 +146,6 @@ share/locale/it_IT/LC_MESSAGES/gtk2_ardour.mo
share/locale/sv_SE/LC_MESSAGES/libardour2.mo
share/locale/sv_SE/LC_MESSAGES/gtk2_ardour.mo
share/locale/de_DE/LC_MESSAGES/gtk2_ardour.mo
-share/locale/de_DE/LC_MESSAGES/libardour2.mo
@dirrmtry share/locale/it_IT/LC_MESSAGES
@dirrmtry share/locale/it_IT
@dirrmtry share/locale/sv_SE/LC_MESSAGES
@@ -154,3 +156,5 @@ share/locale/de_DE/LC_MESSAGES/libardour2.mo
@dirrmtry share/locale/ru_RU
@dirrmtry share/locale/de_DE/LC_MESSAGES
@dirrmtry share/locale/de_DE
+@dirrmtry share/locale/po_PO/LC_MESSAGES
+@dirrmtry share/locale/po_PO