aboutsummaryrefslogtreecommitdiff
path: root/audio/ardour
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2009-09-05 15:38:05 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2009-09-05 15:38:05 +0000
commit0a29e3508d9a171cd32ee61fd68981a6aa8df72b (patch)
tree2bbf788574cd0efc7777e27984248ed9f469bce4 /audio/ardour
parentef90507da6797eabcd1e72096f457c6e575dbbd2 (diff)
downloadports-0a29e3508d9a171cd32ee61fd68981a6aa8df72b.tar.gz
ports-0a29e3508d9a171cd32ee61fd68981a6aa8df72b.zip
Notes
Diffstat (limited to 'audio/ardour')
-rw-r--r--audio/ardour/Makefile23
-rw-r--r--audio/ardour/distinfo6
-rw-r--r--audio/ardour/files/patch-SConstruct9
-rw-r--r--audio/ardour/files/patch-libs-fst-SConscript11
-rw-r--r--audio/ardour/pkg-plist45
5 files changed, 36 insertions, 58 deletions
diff --git a/audio/ardour/Makefile b/audio/ardour/Makefile
index 8c237f03b833..2b037a876999 100644
--- a/audio/ardour/Makefile
+++ b/audio/ardour/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= ardour
-PORTVERSION= 2.7.1
-PORTREVISION= 2
+PORTVERSION= 2.8.2
CATEGORIES= audio
-MASTER_SITES= http://releases.ardour.org/
-DISTFILES= ardour-${DISTVERSION}.tar.bz2
-EXTRACT_ONLY= ardour-${DISTVERSION}.tar.bz2
+MASTER_SITES= http://releases.ardour.org/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= trasz
-MAINTAINER= danfe@FreeBSD.org
+MAINTAINER= trasz@FreeBSD.org
COMMENT= Ardour - a digital audio workstation
LIB_DEPENDS= lrdf.2:${PORTSDIR}/textproc/liblrdf \
@@ -62,21 +61,12 @@ BROKEN= does not compile
.endif
.if defined(WITH_VST)
-# Yes, 'PlugIns' is not a typo.
-VST_DIST+= vst_sdk2_3.zip
-RESTRICTED= Redistribution of the VST PlugIns SDK is not allowed
-RESTRICTED_FILES= ${VST_DIST}
-DISTFILES+= ${VST_DIST}
SCONS_ENV+= VST=yes
BUILD_DEPENDS+= winegcc:${PORTSDIR}/emulators/wine \
unzip:${PORTSDIR}/archivers/unzip \
gsed:${PORTSDIR}/textproc/gsed
LIB_DEPENDS+= wine.1:${PORTSDIR}/emulators/wine
-.if !exists(${DISTDIR}/${VST_DIST})
-IGNORE= download the VST 2.3 SDK from Steinberg (http://www.steinberg.de/331+M52087573ab0.html) and copy ${VST_DIST} into ${DISTDIR}
-.endif
-
PLIST_SUB+= NO_VST="@comment "
PLIST_SUB+= VST=""
.else
@@ -112,9 +102,6 @@ CFLAGS:= ${CFLAGS:N-fno-strict-aliasing}
post-patch:
${REINPLACE_CMD} -e "s|%%CFLAGS%%|${CFLAGS}|g" ${WRKSRC}/SConstruct
${REINPLACE_CMD} -e "s|alsa_pcm|oss|g" ${WRKSRC}/templates/*.template
-.if defined(WITH_VST)
- ${CP} ${DISTDIR}/${VST_DIST} ${WRKSRC}/libs/fst/
-.endif
post-install:
${CHOWN} -R 0:0 ${PREFIX}/lib/ardour2/
diff --git a/audio/ardour/distinfo b/audio/ardour/distinfo
index 38b3bf78b171..409b2444281b 100644
--- a/audio/ardour/distinfo
+++ b/audio/ardour/distinfo
@@ -1,3 +1,3 @@
-MD5 (ardour-2.7.1.tar.bz2) = 0fd4b1a600c75447d633b796bad321e1
-SHA256 (ardour-2.7.1.tar.bz2) = 102b99716ea99bbe66ad57abd1a1bf39d904068e76cb222d68f7acb78c63c864
-SIZE (ardour-2.7.1.tar.bz2) = 3313029
+MD5 (ardour-2.8.2.tar.bz2) = 054640c746e806be81857754fc72c02e
+SHA256 (ardour-2.8.2.tar.bz2) = 659c4a50a2d045bdfd9b93ab7966726438a555f14d6122986acbd36c72d8fcc5
+SIZE (ardour-2.8.2.tar.bz2) = 3430971
diff --git a/audio/ardour/files/patch-SConstruct b/audio/ardour/files/patch-SConstruct
index c2aa3685a38a..3b66e07a1fb3 100644
--- a/audio/ardour/files/patch-SConstruct
+++ b/audio/ardour/files/patch-SConstruct
@@ -9,15 +9,6 @@
BoolOption('SURFACES', 'Build support for control surfaces', 1),
BoolOption('WIIMOTE', 'Build the wiimote control surface', 0),
BoolOption('SYSLIBS', 'USE AT YOUR OWN RISK: CANCELS ALL SUPPORT FROM ARDOUR AUTHORS: Use existing system versions of various libraries instead of internal ones', 0),
-@@ -398,7 +398,7 @@
- # Make sure they know what they are doing
- #
-
--if env['VST']:
-+if False:
- if os.path.isfile('.personal_use_only'):
- print "Enabling VST support. Note that distributing a VST-enabled ardour\nis a violation of several different licences.\nBuild with VST=false if you intend to distribute ardour to others."
- else:
@@ -702,9 +702,9 @@
opt_flags.extend (["-mhard-float", "-mpowerpc-gfxopt"])
opt_flags.extend (["-Os"])
diff --git a/audio/ardour/files/patch-libs-fst-SConscript b/audio/ardour/files/patch-libs-fst-SConscript
deleted file mode 100644
index ec3006fb3c23..000000000000
--- a/audio/ardour/files/patch-libs-fst-SConscript
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/fst/SConscript.orig Fri Dec 1 04:24:47 2006
-+++ libs/fst/SConscript Sun Mar 18 19:02:10 2007
-@@ -38,7 +38,7 @@
- "unzip -qq -d ${SOURCE.dir} -o $SOURCE",
- Delete ('$TARGET.dir'),
- Copy ('${TARGET.dir}', 'libs/fst/vstsdk2.3/source/common'),
-- "sed -i '/struct VstFileType\|struct VstFileSelect/,/};/d' $TARGET"
-+ "gsed -i '/struct VstFileType\|struct VstFileSelect/,/};/d' $TARGET"
- ])
-
- a = fst.Object ('fst', 'fst.c')
diff --git a/audio/ardour/pkg-plist b/audio/ardour/pkg-plist
index c9e79fcc60d0..9d3e0127b3bd 100644
--- a/audio/ardour/pkg-plist
+++ b/audio/ardour/pkg-plist
@@ -76,23 +76,12 @@ share/ardour2/pixmaps/hslider01.xpm
share/ardour2/pixmaps/vslider00.xpm
share/ardour2/pixmaps/zoom_in.xpm
@dirrm share/ardour2/pixmaps
-share/ardour2/icons/crossfade_out_dipped.png
-share/ardour2/icons/crossfade_in_transition.png
share/ardour2/icons/tool_stretch.png
-share/ardour2/icons/crossfade_in_constant.png
share/ardour2/icons/zoom_full.png
-share/ardour2/icons/crossfade_in_dipped.png
share/ardour2/icons/tool_object.png
share/ardour2/icons/transport_play.png
share/ardour2/icons/fader_belt.png
-share/ardour2/icons/crossfade_in_fast-cut.png
-share/ardour2/icons/crossfade_out_fast-cut.png
share/ardour2/icons/record_normal_red.png
-share/ardour2/icons/crossfade_out_transition.png
-share/ardour2/icons/crossfade_out_slow-cut.png
-share/ardour2/icons/crossfade_in_slow-cut.png
-share/ardour2/icons/crossfade_in_default.png
-share/ardour2/icons/crossfade_out_default.png
share/ardour2/icons/transport_loop.png
share/ardour2/icons/tool_audition.png
share/ardour2/icons/transport_end.png
@@ -102,15 +91,12 @@ share/ardour2/icons/tool_zoom.png
share/ardour2/icons/transport_range.png
share/ardour2/icons/zoom_out.png
share/ardour2/icons/zoom_in.png
-share/ardour2/icons/crossfade_out_constant.png
share/ardour2/icons/tool_gain.png
-share/ardour2/icons/crossfade_in_slow-fade.png
share/ardour2/icons/strip_width.png
share/ardour2/icons/transport_start.png
share/ardour2/icons/transport_stop.png
share/ardour2/icons/nudge_left.png
share/ardour2/icons/transport_record.png
-share/ardour2/icons/crossfade_out_slow-fade.png
share/ardour2/icons/nudge_right.png
share/ardour2/icons/ardour_icon_22px.png
share/ardour2/icons/ardour_icon_48px.png
@@ -126,10 +112,23 @@ share/ardour2/icons/application-x-ardour_32px.png
share/ardour2/icons/application-x-ardour_48px.png
share/ardour2/icons/application-x-ardour_16px.png
share/ardour2/icons/computer_keyboard.png
-share/ardour2/icons/poweron.png
share/ardour2/icons/computer_keyboard_active.png
-share/ardour2/icons/poweroff.png
-share/ardour2/icons/ardour-sae.png
+share/ardour2/icons/crossfade-out-linear.png
+share/ardour2/icons/crossfade-out-long-cut.png
+share/ardour2/icons/crossfade-in-S2.png
+share/ardour2/icons/crossfade-out-short-cut.png
+share/ardour2/icons/crossfade-in-long-cut.png
+share/ardour2/icons/crossfade-out-slow-cut.png
+share/ardour2/icons/crossfade-in-fast-cut.png
+share/ardour2/icons/crossfade-in-linear.png
+share/ardour2/icons/crossfade-in-short-cut.png
+share/ardour2/icons/crossfade-out-S1.png
+share/ardour2/icons/crossfade-in-S1.png
+share/ardour2/icons/crossfade-out-constant-power.png
+share/ardour2/icons/crossfade-in-constant-power.png
+share/ardour2/icons/crossfade-in-slow-cut.png
+share/ardour2/icons/crossfade-out-S2.png
+share/ardour2/icons/crossfade-out-fast-cut.png
@dirrm share/ardour2/icons
share/ardour2/templates/16 Tracks.template
share/ardour2/templates/2 Track.template
@@ -158,6 +157,10 @@ share/locale/de_DE/LC_MESSAGES/gtk2_ardour.mo
share/locale/pl_PL/LC_MESSAGES/libardour2.mo
share/locale/pl_PL/LC_MESSAGES/libgtkmm2ext.mo
share/locale/pl_PL/LC_MESSAGES/gtk2_ardour.mo
+share/locale/es_ES/LC_MESSAGES/libardour2.mo
+share/locale/fr_FR/LC_MESSAGES/libardour2.mo
+share/locale/cs_CZ/LC_MESSAGES/gtk2_ardour.mo
+share/locale/nn_NO/LC_MESSAGES/gtk2_ardour.mo
@dirrmtry share/locale/pl_PL/LC_MESSAGES
@dirrmtry share/locale/pl_PL
@dirrmtry share/locale/it_IT/LC_MESSAGES
@@ -170,3 +173,11 @@ share/locale/pl_PL/LC_MESSAGES/gtk2_ardour.mo
@dirrmtry share/locale/ru_RU
@dirrmtry share/locale/de_DE/LC_MESSAGES
@dirrmtry share/locale/de_DE
+@dirrmtry share/locale/es_ES/LC_MESSAGES
+@dirrmtry share/locale/es_ES
+@dirrmtry share/locale/fr_FR/LC_MESSAGES
+@dirrmtry share/locale/fr_FR
+@dirrmtry share/locale/cs_CZ/LC_MESSAGES
+@dirrmtry share/locale/cs_CZ
+@dirrmtry share/locale/nn_NO/LC_MESSAGES
+@dirrmtry share/locale/nn_NO