aboutsummaryrefslogtreecommitdiff
path: root/audio/ardour
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2007-10-25 15:16:35 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2007-10-25 15:16:35 +0000
commit23c012d6637304f6ad169fea1f7e67b69a807679 (patch)
tree3030ab74e862dfeaba8bd506c923877e8dd6c887 /audio/ardour
parentc22dc0dc0f3e0431c219628272d0bcc684d4a633 (diff)
downloadports-23c012d6637304f6ad169fea1f7e67b69a807679.tar.gz
ports-23c012d6637304f6ad169fea1f7e67b69a807679.zip
Notes
Diffstat (limited to 'audio/ardour')
-rw-r--r--audio/ardour/files/patch-gtk2_ardour-editor_mouse.cc4
-rw-r--r--audio/ardour/pkg-plist6
2 files changed, 2 insertions, 8 deletions
diff --git a/audio/ardour/files/patch-gtk2_ardour-editor_mouse.cc b/audio/ardour/files/patch-gtk2_ardour-editor_mouse.cc
index 2b54c7551c99..0afc91f5408f 100644
--- a/audio/ardour/files/patch-gtk2_ardour-editor_mouse.cc
+++ b/audio/ardour/files/patch-gtk2_ardour-editor_mouse.cc
@@ -6,8 +6,8 @@
- bool x_threshold_passed = (abs ((nframes64_t) (drag_info.current_pointer_x - drag_info.grab_x)) > 4LL);
- bool y_threshold_passed = (abs ((nframes64_t) (drag_info.current_pointer_y - drag_info.grab_y)) > 4LL);
-+ bool x_threshold_passed = (abs ((long long) (drag_info.current_pointer_x - drag_info.grab_x)) > 4LL);
-+ bool y_threshold_passed = (abs ((long long) (drag_info.current_pointer_y - drag_info.grab_y)) > 4LL);
++ bool x_threshold_passed = (::llabs ((nframes64_t) (drag_info.current_pointer_x - drag_info.grab_x)) > 4LL);
++ bool y_threshold_passed = (::llabs ((nframes64_t) (drag_info.current_pointer_y - drag_info.grab_y)) > 4LL);
drag_info.move_threshold_passed = (x_threshold_passed || y_threshold_passed);
diff --git a/audio/ardour/pkg-plist b/audio/ardour/pkg-plist
index 2dab535bd3b2..a467b94d75dd 100644
--- a/audio/ardour/pkg-plist
+++ b/audio/ardour/pkg-plist
@@ -138,9 +138,3 @@ share/locale/de_DE/LC_MESSAGES/gtk2_ardour.mo
@dirrmtry share/locale/ru_RU
@dirrmtry share/locale/de_DE/LC_MESSAGES
@dirrmtry share/locale/de_DE
-@dirrmtry share/locale/pt_PT/LC_MESSAGES
-@dirrmtry share/locale/pt_PT
-@dirrmtry share/locale/es_ES/LC_MESSAGES
-@dirrmtry share/locale/es_ES
-@dirrmtry share/locale/fr_FR/LC_MESSAGES
-@dirrmtry share/locale/fr_FR