aboutsummaryrefslogtreecommitdiff
path: root/audio/ardour
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-18 20:50:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-18 20:50:37 +0000
commit90d33ab0801a91ad32fc785660ff0a461eaf9227 (patch)
tree1b37963ecdf257ae90925debc725295bfe5c8c72 /audio/ardour
parentdc0c1ef671a96f5f23cff3df8eb6685cd41b3e21 (diff)
downloadports-90d33ab0801a91ad32fc785660ff0a461eaf9227.tar.gz
ports-90d33ab0801a91ad32fc785660ff0a461eaf9227.zip
Notes
Diffstat (limited to 'audio/ardour')
-rw-r--r--audio/ardour/Makefile7
-rw-r--r--audio/ardour/distinfo6
-rw-r--r--audio/ardour/files/patch-SConstruct17
-rw-r--r--audio/ardour/pkg-plist2
4 files changed, 17 insertions, 15 deletions
diff --git a/audio/ardour/Makefile b/audio/ardour/Makefile
index 444fde28597f..aaeb2bfa9382 100644
--- a/audio/ardour/Makefile
+++ b/audio/ardour/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ardour
-DISTVERSION= 2.0beta10
+DISTVERSION= 2.0beta11.1
CATEGORIES= audio
MASTER_SITES= http://ardour.org/files/releases/
@@ -25,18 +25,19 @@ LIB_DEPENDS= lrdf.2:${PORTSDIR}/textproc/liblrdf \
BUILD_DEPENDS= ${LOCALBASE}/lib/libSoundTouch.a:${PORTSDIR}/audio/soundtouch
USE_SCONS= yes
-SCONS_ENV+= SYSLIBS=yes PREFIX=${PREFIX} NLS=yes
+SCONS_ENV+= SYSLIBS=yes PREFIX=${PREFIX} NLS=yes FPU_OPTIMIZATION=0
USE_BZIP2= yes
USE_GNOME= gtk20 libxslt libgnomecanvas intltool
USE_GETTEXT= yes
USE_LDCONFIG= ${PREFIX}/lib/ardour2 ${PREFIX}/lib/ardour2/surfaces
TEMPLATESDIR= ${PREFIX}/share/ardour2/templates
+PLIST_SUB= DISTVERSION=${DISTVERSION}
.include <bsd.port.pre.mk>
# Upstream uses these flags by default.
.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
-CFLAGS+= -O3 -fomit-frame-pointer -ffast-math -fstrength-reduce
+CFLAGS+= -O3 -fomit-frame-pointer -ffast-math -fstrength-reduce -fno-strict-aliasing
.endif
.if ${OSVERSION} < 600000
diff --git a/audio/ardour/distinfo b/audio/ardour/distinfo
index e23e998f6f69..9d468ca505d0 100644
--- a/audio/ardour/distinfo
+++ b/audio/ardour/distinfo
@@ -1,3 +1,3 @@
-MD5 (ardour-2.0beta10.tar.bz2) = 47ea107f04233f82d16c368bcec75915
-SHA256 (ardour-2.0beta10.tar.bz2) = 8683aa9f0e7e90d90e5156e68040c728e71bff82f00819d7a07be37fd32fdafa
-SIZE (ardour-2.0beta10.tar.bz2) = 2676171
+MD5 (ardour-2.0beta11.1.tar.bz2) = f1df82de972e0dab5eef03155de7f523
+SHA256 (ardour-2.0beta11.1.tar.bz2) = 6d2ca6a3e003942f95e826d6a001365d98b536b0db999a591a3bb1c30317bb70
+SIZE (ardour-2.0beta11.1.tar.bz2) = 2681611
diff --git a/audio/ardour/files/patch-SConstruct b/audio/ardour/files/patch-SConstruct
index 2f1bd84efc2c..0d6e40912e10 100644
--- a/audio/ardour/files/patch-SConstruct
+++ b/audio/ardour/files/patch-SConstruct
@@ -1,5 +1,5 @@
---- SConstruct.orig Wed Jan 3 20:17:56 2007
-+++ SConstruct Thu Jan 4 22:26:17 2007
+--- SConstruct.orig Wed Jan 17 22:13:21 2007
++++ SConstruct Wed Jan 17 22:55:30 2007
@@ -38,7 +38,7 @@
BoolOption('FPU_OPTIMIZATION', 'Build runtime checked assembler code', 1),
BoolOption('LIBLO', 'Compile with support for liblo library', 1),
@@ -9,7 +9,7 @@
BoolOption('SURFACES', 'Build support for control surfaces', 1),
BoolOption('SYSLIBS', 'USE AT YOUR OWN RISK: CANCELS ALL SUPPORT FROM ARDOUR AUTHORS: Use existing system versions of various libraries instead of internal ones', 0),
BoolOption('VERSIONED', 'Add revision information to ardour/gtk executable name inside the build directory', 0),
-@@ -655,12 +655,7 @@
+@@ -655,13 +655,7 @@
# prepend boiler plate optimization flags
#
@@ -17,13 +17,14 @@
- "-O3",
- "-fomit-frame-pointer",
- "-ffast-math",
-- "-fstrength-reduce"
+- "-fstrength-reduce",
+- "-fno-strict-aliasing"
- ]
+opt_flags[:0] = [ "%%CFLAGS%%" ];
if env['DEBUG'] == 1:
env.Append(CCFLAGS=" ".join (debug_flags))
-@@ -741,9 +736,9 @@
+@@ -742,9 +736,9 @@
prep_libcheck(env, libraries['lo'])
conf = Configure (libraries['lo'])
@@ -36,7 +37,7 @@
libraries['lo'] = conf.Finish ()
-@@ -783,8 +778,10 @@
+@@ -784,8 +778,10 @@
subst_dict['%MIDITAG%'] = "ardour"
subst_dict['%MIDITYPE%'] = "coremidi"
else:
@@ -49,7 +50,7 @@
env = conf.Finish()
-@@ -1003,33 +1000,33 @@
+@@ -1006,33 +1002,33 @@
# i18n support
#
@@ -110,7 +111,7 @@
if env['NLS'] == 1:
env.Append(CCFLAGS="-DENABLE_NLS")
-@@ -1046,8 +1043,8 @@
+@@ -1049,8 +1045,8 @@
subst_dict['%JACK_INPUT%'] = "coreaudio:Built-in Audio:in"
subst_dict['%JACK_OUTPUT%'] = "coreaudio:Built-in Audio:out"
else:
diff --git a/audio/ardour/pkg-plist b/audio/ardour/pkg-plist
index a09c79b38be7..d62621c2917e 100644
--- a/audio/ardour/pkg-plist
+++ b/audio/ardour/pkg-plist
@@ -4,7 +4,7 @@ lib/ardour2/libpbd.so
lib/ardour2/libmidi++.so
lib/ardour2/libardour.so
lib/ardour2/libgtkmm2ext.so
-lib/ardour2/ardour.bin
+lib/ardour2/ardour-%%DISTVERSION%%
lib/ardour2/libardour_cp.so
lib/ardour2/surfaces/libardour_genericmidi.so
@dirrm lib/ardour2/surfaces