aboutsummaryrefslogtreecommitdiff
path: root/audio/arts/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2005-03-20 18:17:55 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2005-03-20 18:17:55 +0000
commitd57e6a82578ae8c5008de9b8a118e7286b5ac8bd (patch)
tree3242aa4d74a61f6856c81b2ca2de2e77f3bdfe80 /audio/arts/Makefile
parent6d03af1e2cf23cd31fdb26de95a70d7cfaa23986 (diff)
downloadports-d57e6a82578ae8c5008de9b8a118e7286b5ac8bd.tar.gz
ports-d57e6a82578ae8c5008de9b8a118e7286b5ac8bd.zip
Notes
Diffstat (limited to 'audio/arts/Makefile')
-rw-r--r--audio/arts/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/audio/arts/Makefile b/audio/arts/Makefile
index b7c22bbc3c60..f1e34fe40382 100644
--- a/audio/arts/Makefile
+++ b/audio/arts/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= arts
-PORTVERSION= 1.3.2
-PORTREVISION= 1
+PORTVERSION= 1.4.0
PORTEPOCH= 1
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_KDE}
@@ -33,7 +32,6 @@ INSTALLS_SHLIB= yes
QTCPPFLAGS+= -L${LOCALBASE}/lib
USE_REINPLACE= yes
DO_NOT_COMPILE+=gmcop
-_NO_KDE_CLOSURE=yes
_NO_KDE_FINAL= yes
CFLAGS+= -DHAVE_VASPRINTF
@@ -48,6 +46,10 @@ OPTIONS= ESD "Enable esound support" off \
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
+.if (${OSVERSION} < 500000 ) || (${OSVERSION} > 502102 )
+LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
+.endif
+
.if defined(WITH_ESD)
USE_GNOME+= esound
.endif
@@ -74,4 +76,8 @@ pre-configure:
${WRKSRC}/configure
.endif
+post-configure:
+ ${TOUCH} ${WRKSRC}/mcop/arts_export.h.in
+ ${TOUCH} ${WRKSRC}/artsc/artsc_export.h.in
+
.include <bsd.port.post.mk>