aboutsummaryrefslogtreecommitdiff
path: root/audio/arts/files/patch-soundserver-Makefile.in
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-06-01 15:33:15 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-06-01 15:33:15 +0000
commit6a30df2fc03a166601c98d61b115bea7a3f2ddb9 (patch)
tree395e578d332980400cba2fb97455ddc7c2252f98 /audio/arts/files/patch-soundserver-Makefile.in
parentdf211446482a16baa9ecea570a621eaa61b402ee (diff)
Notes
Diffstat (limited to 'audio/arts/files/patch-soundserver-Makefile.in')
-rw-r--r--audio/arts/files/patch-soundserver-Makefile.in28
1 files changed, 28 insertions, 0 deletions
diff --git a/audio/arts/files/patch-soundserver-Makefile.in b/audio/arts/files/patch-soundserver-Makefile.in
index 8d37c4fa644f..1cce355e4457 100644
--- a/audio/arts/files/patch-soundserver-Makefile.in
+++ b/audio/arts/files/patch-soundserver-Makefile.in
@@ -64,3 +64,31 @@
mostlyclean-compile:
-rm -f *.$(OBJEXT)
+--- soundserver/Makefile.in.orig Tue Jun 1 16:36:34 2004
++++ soundserver/Makefile.in Tue Jun 1 16:45:08 2004
+@@ -545,20 +545,20 @@
+ libartsgslplayobject_la_LDFLAGS = -no-undefined $(KDE_NO_UNDEFINED) -module $(all_libraries)
+ libartsgslplayobject_la_COMPILE_FIRST = soundserver.h ../flow/artsflow.h
+ artsd_LDADD = libsoundserver_idl.la $(FLOWLIBS) \
+- $(top_builddir)/mcop_mt/libmcop_mt.la $(USE_THREADS)
++ $(top_builddir)/mcop_mt/libmcop_mt.la $(USE_THREADS) $(LIBPTHREAD)
+
+ artsd_SOURCES = soundserverv2_impl.cc soundserver_impl.cc simplesoundserver_impl.cc artsd.cc cpuusage.cc samplestorage_impl.cc crashhandler.cc soundserverstartup_impl.cc
+ artsd_COMPILE_FIRST = soundserver.h artsversion.h
+-artscat_LDADD = libsoundserver_idl.la $(FLOWLIBS) $(USE_THREADS)
++artscat_LDADD = libsoundserver_idl.la $(FLOWLIBS) $(USE_THREADS) $(LIBPTHREAD)
+ artscat_SOURCES = artscat.cc
+ artscat_COMPILE_FIRST = soundserver.h artsversion.h
+-artsrec_LDADD = libsoundserver_idl.la $(FLOWLIBS) $(USE_THREADS)
++artsrec_LDADD = libsoundserver_idl.la $(FLOWLIBS) $(USE_THREADS) $(LIBPTHREAD)
+ artsrec_SOURCES = artsrec.cc
+ artsrec_COMPILE_FIRST = soundserver.h artsversion.h
+-artsplay_LDADD = libsoundserver_idl.la $(USE_THREADS)
++artsplay_LDADD = libsoundserver_idl.la $(USE_THREADS) $(LIBPTHREAD)
+ artsplay_SOURCES = artsplay.cc
+ artsplay_COMPILE_FIRST = soundserver.h artsversion.h
+-artsshell_LDADD = libsoundserver_idl.la $(USE_THREADS)
++artsshell_LDADD = libsoundserver_idl.la $(USE_THREADS) $(LIBPTHREAD)
+ artsshell_SOURCES = artsshell.cc tradercheck.cc
+ artsshell_COMPILE_FIRST = soundserver.h artsversion.h
+ DISTCLEANFILES = soundserver.cc soundserver.h soundserver.mcopclass \