aboutsummaryrefslogtreecommitdiff
path: root/audio/arts/files
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2006-01-08 19:32:36 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2006-01-08 19:32:36 +0000
commit7710b55bc3f0d213f6344fa1a608919c44a344b5 (patch)
tree55eace3b8e7907f8b07ed3c7b0695add019fe3b0 /audio/arts/files
parent27f7ce2fe2b84f6569fce9b395c31ff011d9ae1a (diff)
downloadports-7710b55bc3f0d213f6344fa1a608919c44a344b5.tar.gz
ports-7710b55bc3f0d213f6344fa1a608919c44a344b5.zip
Notes
Diffstat (limited to 'audio/arts/files')
-rw-r--r--audio/arts/files/patch-mcop-mcoputils.cc10
-rw-r--r--audio/arts/files/patch-soundserver-Makefile.in16
2 files changed, 19 insertions, 7 deletions
diff --git a/audio/arts/files/patch-mcop-mcoputils.cc b/audio/arts/files/patch-mcop-mcoputils.cc
new file mode 100644
index 000000000000..6b3db7470c03
--- /dev/null
+++ b/audio/arts/files/patch-mcop-mcoputils.cc
@@ -0,0 +1,10 @@
+--- mcop/mcoputils.cc.orig Wed Nov 30 18:34:17 2005
++++ mcop/mcoputils.cc Wed Nov 30 18:35:02 2005
+@@ -32,6 +32,7 @@
+ #include <errno.h>
+ #include <config.h>
+ #include <ctype.h>
++#include <stdio.h>
+ #include <map>
+
+ using namespace std;
diff --git a/audio/arts/files/patch-soundserver-Makefile.in b/audio/arts/files/patch-soundserver-Makefile.in
index d4a5af6e938e..f61dd7124b3b 100644
--- a/audio/arts/files/patch-soundserver-Makefile.in
+++ b/audio/arts/files/patch-soundserver-Makefile.in
@@ -1,6 +1,6 @@
---- soundserver/Makefile.in.orig Fri Mar 4 10:58:22 2005
-+++ soundserver/Makefile.in Wed Mar 16 04:32:04 2005
-@@ -46,7 +46,7 @@
+--- soundserver/Makefile.in.orig Sun Nov 20 20:55:24 2005
++++ soundserver/Makefile.in Wed Nov 30 01:33:05 2005
+@@ -44,7 +44,7 @@
host_triplet = @host@
target_triplet = @target@
bin_PROGRAMS = artsd$(EXEEXT) artsplay$(EXEEXT) artscat$(EXEEXT) \
@@ -9,7 +9,7 @@
subdir = soundserver
DIST_COMMON = $(artsinclude_HEADERS) $(srcdir)/Makefile.am \
$(srcdir)/Makefile.in $(srcdir)/artsversion-new.h.in
-@@ -192,12 +192,12 @@
+@@ -190,12 +190,12 @@
$(libartswavplayobject_la_SOURCES) $(libkmedia2_la_SOURCES) \
$(libkmedia2_idl_la_SOURCES) $(libsoundserver_idl_la_SOURCES) \
$(artscat_SOURCES) $(artsd_SOURCES) $(artsplay_SOURCES) \
@@ -24,17 +24,19 @@
mcopclassDATA_INSTALL = $(INSTALL_DATA)
mcoptypeDATA_INSTALL = $(INSTALL_DATA)
DATA = $(mcopclass_DATA) $(mcoptype_DATA)
-@@ -539,9 +539,6 @@
+@@ -540,11 +540,6 @@
artsplay_LDFLAGS = $(USE_THREADS)
artsplay_SOURCES = artsplay.cc
artsplay_COMPILE_FIRST = soundserver.h artsversion.h
-artswrapper_SOURCES = artswrapper.c
+-artswrapper_CFLAGS = $(KDE_USE_FPIE)
-artswrapper_INCLUDES = -I$(top_builddir) -DEXECUTE=\"$(artsdpath)\"
-artswrapper_LDADD = $(LIBPOSIX4)
+-artswrapper_LDFLAGS = $(KDE_USE_PIE)
artsshell_LDADD = libsoundserver_idl.la $(LIBPTHREAD)
artsshell_LDFLAGS = $(USE_THREADS)
artsshell_SOURCES = artsshell.cc tradercheck.cc
-@@ -553,10 +550,6 @@
+@@ -556,10 +551,6 @@
mcopclassdir = $(libdir)/mcop/Arts
mcopclass_DATA = FileInputStream.mcopclass $(WAV_MCOPCLASS) GSLPlayObject.mcopclass
@@ -45,7 +47,7 @@
######## install idl typeinfo files
mcoptypedir = $(libdir)/mcop
mcoptype_DATA = soundserver.mcoptype soundserver.mcopclass \
-@@ -707,9 +700,6 @@
+@@ -710,9 +701,6 @@
artsshell$(EXEEXT): $(artsshell_OBJECTS) $(artsshell_DEPENDENCIES)
@rm -f artsshell$(EXEEXT)
$(CXXLINK) $(artsshell_LDFLAGS) $(artsshell_OBJECTS) $(artsshell_LDADD) $(LIBS)