aboutsummaryrefslogtreecommitdiff
path: root/audio/asmix
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2005-03-13 09:17:06 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2005-03-13 09:17:06 +0000
commit703ee967fd21c511c9351a1cda1edb35c956429b (patch)
tree0b4a692f325d174207084310a74d2a43eda2632f /audio/asmix
parentc2901a97c7d09cfcfafe9ab3532cb012d3c3a2d1 (diff)
downloadports-703ee967fd21c511c9351a1cda1edb35c956429b.tar.gz
ports-703ee967fd21c511c9351a1cda1edb35c956429b.zip
Notes
Diffstat (limited to 'audio/asmix')
-rw-r--r--audio/asmix/Makefile17
-rw-r--r--audio/asmix/distinfo4
-rw-r--r--audio/asmix/files/patch-asmix.c13
3 files changed, 13 insertions, 21 deletions
diff --git a/audio/asmix/Makefile b/audio/asmix/Makefile
index fe7235f05ad5..7428ab150262 100644
--- a/audio/asmix/Makefile
+++ b/audio/asmix/Makefile
@@ -6,20 +6,25 @@
#
PORTNAME= asmix
-PORTVERSION= 1.4
+PORTVERSION= 1.5
CATEGORIES= audio afterstep
MASTER_SITES= http://www.tigr.net/afterstep/download/asmix/
-MASTER_SITE_SUBDIR= apps/asmix
MAINTAINER= ports@FreeBSD.org
COMMENT= Volume control dock-app for the AfterStep Window Manager
+USE_X_PREFIX= yes
+USE_XPM= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+
MAN1= ${PORTNAME}.1x
PLIST_FILES= bin/asmix
-USE_X_PREFIX= yes
-USE_XPM= yes
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS+= --prefix=${PREFIX}
+post-patch:
+.for file in asmix.c configure autoconf/config.h.in
+ @${REINPLACE_CMD} -e 's|machine/soundcard|sys/soundcard|g ; \
+ s|MACHINE_SOUNDCARD|SYS_SOUNDCARD|g' ${WRKSRC}/${file}
+.endfor
.include <bsd.port.mk>
diff --git a/audio/asmix/distinfo b/audio/asmix/distinfo
index 4d26512a5471..8454e60aa725 100644
--- a/audio/asmix/distinfo
+++ b/audio/asmix/distinfo
@@ -1,2 +1,2 @@
-MD5 (asmix-1.4.tar.gz) = a1836666d0662f7b80774a9aaee377d4
-SIZE (asmix-1.4.tar.gz) = 36383
+MD5 (asmix-1.5.tar.gz) = de731150e2e57bf3d809b141ffdc8969
+SIZE (asmix-1.5.tar.gz) = 35765
diff --git a/audio/asmix/files/patch-asmix.c b/audio/asmix/files/patch-asmix.c
deleted file mode 100644
index 0f51f73a137f..000000000000
--- a/audio/asmix/files/patch-asmix.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- asmix.c.orig Sun Aug 31 15:18:35 2003
-+++ asmix.c Sun Aug 31 15:19:04 2003
-@@ -22,9 +22,7 @@
- #include <sys/errno.h>
- #include <sys/ioctl.h>
- #include <fcntl.h>
--#ifdef HAVE_MACHINE_SOUNDCARD_H
--# include <machine/soundcard.h>
--#endif
-+#include <sys/soundcard.h>
- #ifdef HAVE_LINUX_SOUNDCARD_H
- # include <linux/soundcard.h>
- #endif