aboutsummaryrefslogtreecommitdiff
path: root/audio/asunder/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-07-03 17:15:23 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-07-03 17:15:23 +0000
commit5f5ffa58c3ee7f8923716a4448fe0c0f569e7f91 (patch)
tree857c54c040bd2a44d4e99763cb2568b3f9ffc23c /audio/asunder/Makefile
parent7a5af7b75c982476cb7034fa28822d79597863ad (diff)
downloadports-5f5ffa58c3ee7f8923716a4448fe0c0f569e7f91.tar.gz
ports-5f5ffa58c3ee7f8923716a4448fe0c0f569e7f91.zip
Notes
Diffstat (limited to 'audio/asunder/Makefile')
-rw-r--r--audio/asunder/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/audio/asunder/Makefile b/audio/asunder/Makefile
index a681c1e04c8c..a53d8ff14e42 100644
--- a/audio/asunder/Makefile
+++ b/audio/asunder/Makefile
@@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= asunder
-PORTVERSION= 2.2
-PORTREVISION= 1
+PORTVERSION= 2.3
CATEGORIES= audio
MASTER_SITES= http://littlesvr.ca/asunder/releases/
MAINTAINER= frase@frase.id.au
-COMMENT= A lightweight GTK+ CD ripper
+COMMENT= Lightweight GTK+ CD ripper
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -16,7 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= cddb:${PORTSDIR}/audio/libcddb
RUN_DEPENDS= ${LOCALBASE}/bin/cdparanoia:${PORTSDIR}/audio/cdparanoia
-OPTIONS_DEFINE= LAME OGG FLAC WAVPACK APE WINDOWS_CHARS NLS DOCS
+OPTIONS_DEFINE= LAME OGG FLAC OPUS WAVPACK APE WINDOWS_CHARS NLS DOCS
+OPUS_DESC= OPUS support
OPTIONS_DEFAULT= LAME OGG FLAC
WINDOWS_CHARS_DESC= Allow Windows special chars in filenames
@@ -43,6 +43,10 @@ RUN_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
.endif
+.if ${PORT_OPTIONS:MOPUS}
+RUN_DEPENDS+= opusenc:${PORTSDIR}/audio/opus-tools
+.endif
+
.if ${PORT_OPTIONS:MWAVPACK}
RUN_DEPENDS+= wavpack:${PORTSDIR}/audio/wavpack
.endif