aboutsummaryrefslogtreecommitdiff
path: root/audio/aubio/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-08-19 09:42:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-08-19 09:42:08 +0000
commitbdcd83ed185939d402e637cab866dd5ebeda3b50 (patch)
tree903e3f498974721cbadc17029b1190622e60759a /audio/aubio/Makefile
parent4014b4a403ba619d9ddc630292d2cb18a3bfa321 (diff)
- Correct dependencies: math/fftw3 is only needed for build (as provider of
`fftw3.h' header file); actual linking is against math/fftw3-float) - Cleanup Makefile: utilize CPPFLAGS, drop ABI versions in LIB_DEPENDS, wrap overly long lines, standardize header - Bump port revision due to updated dependencies - Reformat port description and sort pkg-plist while here
Notes
Notes: svn path=/head/; revision=302755
Diffstat (limited to 'audio/aubio/Makefile')
-rw-r--r--audio/aubio/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/audio/aubio/Makefile b/audio/aubio/Makefile
index 82d8b2eaff76..b10a183b9f33 100644
--- a/audio/aubio/Makefile
+++ b/audio/aubio/Makefile
@@ -1,32 +1,32 @@
# New ports collection makefile for: aubio
-# Date created: 2008-07-21
-# Whom: Edward Tomasz Napierala <trasz@FreeBSD.org>
+# Date created: 2008-07-21
+# Whom: Edward Tomasz Napierala <trasz@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= aubio
PORTVERSION= 0.3.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= audio
MASTER_SITES= http://aubio.org/pub/
MAINTAINER= ports@FreeBSD.org
COMMENT= Library for audio labelling
-LIB_DEPENDS= samplerate.1:${PORTSDIR}/audio/libsamplerate \
- sndfile.1:${PORTSDIR}/audio/libsndfile \
- jack.0:${PORTSDIR}/audio/jack \
- fftw3:${PORTSDIR}/math/fftw3 \
+BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
+LIB_DEPENDS= samplerate:${PORTSDIR}/audio/libsamplerate \
+ sndfile:${PORTSDIR}/audio/libsndfile \
+ jack:${PORTSDIR}/audio/jack \
fftw3f:${PORTSDIR}/math/fftw3-float \
- lash.2:${PORTSDIR}/audio/lash
+ lash:${PORTSDIR}/audio/lash
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gnomehack
USE_LDCONFIG= yes
-# --disable-complex, because it won't compile otherwise
-# due to missing carg(3) et al.
-CONFIGURE_ARGS= "CFLAGS=${CFLAGS} -I${LOCALBASE}/include" --disable-complex
+CPPFLAGS+= -I${LOCALBASE}/include
+# --disable-complex: does not compile due to missing carg(3) et al.
+CONFIGURE_ARGS= --disable-complex
.include <bsd.port.mk>