aboutsummaryrefslogtreecommitdiff
path: root/audio/aubio/Makefile
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2008-08-24 18:04:07 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2008-08-24 18:04:07 +0000
commit77a232816efc7e4b19d5fd9be54a48dc6dacd036 (patch)
treeb9e218d4c0b852014e032cb16664923a3c22ef56 /audio/aubio/Makefile
parent6ca8e284952d0926fb6262586915db8ac7ec1438 (diff)
downloadports-77a232816efc7e4b19d5fd9be54a48dc6dacd036.tar.gz
ports-77a232816efc7e4b19d5fd9be54a48dc6dacd036.zip
Notes
Diffstat (limited to 'audio/aubio/Makefile')
-rw-r--r--audio/aubio/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/aubio/Makefile b/audio/aubio/Makefile
new file mode 100644
index 000000000000..aad878c3cd69
--- /dev/null
+++ b/audio/aubio/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: aubio
+# Date created: 2008-07-21
+# Whom: Edward Tomasz Napierala <trasz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aubio
+PORTVERSION= 0.3.2
+CATEGORIES= audio
+MASTER_SITES= http://aubio.org/pub/
+
+MAINTAINER= trasz@FreeBSD.org
+COMMENT= Library for audio labelling
+
+LIB_DEPENDS= samplerate.1:${PORTSDIR}/audio/libsamplerate \
+ sndfile.1:${PORTSDIR}/audio/libsndfile \
+ jack.0:${PORTSDIR}/audio/jack \
+ fftw3f:${PORTSDIR}/math/fftw3-float \
+ lash.2:${PORTSDIR}/audio/lash
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
+# --disable-complex, because it won't compile otherwise
+# due to missing carg(3) et al.
+CONFIGURE_ARGS= "CFLAGS=${CFLAGS} -I${LOCALBASE}/include" --disable-complex
+
+.include <bsd.port.mk>