aboutsummaryrefslogtreecommitdiff
path: root/audio/aubio
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2008-08-24 18:04:07 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2008-08-24 18:04:07 +0000
commit77a232816efc7e4b19d5fd9be54a48dc6dacd036 (patch)
treeb9e218d4c0b852014e032cb16664923a3c22ef56 /audio/aubio
parent6ca8e284952d0926fb6262586915db8ac7ec1438 (diff)
downloadports-77a232816efc7e4b19d5fd9be54a48dc6dacd036.tar.gz
ports-77a232816efc7e4b19d5fd9be54a48dc6dacd036.zip
Notes
Diffstat (limited to 'audio/aubio')
-rw-r--r--audio/aubio/Makefile30
-rw-r--r--audio/aubio/distinfo3
-rw-r--r--audio/aubio/pkg-descr12
-rw-r--r--audio/aubio/pkg-plist53
4 files changed, 98 insertions, 0 deletions
diff --git a/audio/aubio/Makefile b/audio/aubio/Makefile
new file mode 100644
index 000000000000..aad878c3cd69
--- /dev/null
+++ b/audio/aubio/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: aubio
+# Date created: 2008-07-21
+# Whom: Edward Tomasz Napierala <trasz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aubio
+PORTVERSION= 0.3.2
+CATEGORIES= audio
+MASTER_SITES= http://aubio.org/pub/
+
+MAINTAINER= trasz@FreeBSD.org
+COMMENT= Library for audio labelling
+
+LIB_DEPENDS= samplerate.1:${PORTSDIR}/audio/libsamplerate \
+ sndfile.1:${PORTSDIR}/audio/libsndfile \
+ jack.0:${PORTSDIR}/audio/jack \
+ fftw3f:${PORTSDIR}/math/fftw3-float \
+ lash.2:${PORTSDIR}/audio/lash
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
+# --disable-complex, because it won't compile otherwise
+# due to missing carg(3) et al.
+CONFIGURE_ARGS= "CFLAGS=${CFLAGS} -I${LOCALBASE}/include" --disable-complex
+
+.include <bsd.port.mk>
diff --git a/audio/aubio/distinfo b/audio/aubio/distinfo
new file mode 100644
index 000000000000..65e197138fea
--- /dev/null
+++ b/audio/aubio/distinfo
@@ -0,0 +1,3 @@
+MD5 (aubio-0.3.2.tar.gz) = ffc3e5e4880fec67064f043252263a44
+SHA256 (aubio-0.3.2.tar.gz) = dc1387b048610a6141f523c27314b7a60bd299c3d6789c372445ddc6511512cd
+SIZE (aubio-0.3.2.tar.gz) = 609006
diff --git a/audio/aubio/pkg-descr b/audio/aubio/pkg-descr
new file mode 100644
index 000000000000..961fadf211e4
--- /dev/null
+++ b/audio/aubio/pkg-descr
@@ -0,0 +1,12 @@
+aubio is a library for audio labelling. Its features include
+segmenting a sound file before each of its attacks, performing pitch
+detection, tapping the beat and producing midi streams from live
+audio. The name aubio comes from 'audio' with a typo: several
+transcription errors are likely to be found in the results too.
+
+The aim of this project is to provide these automatic labelling
+features to other audio softwares. Functions can be used offline
+in sound editors and software samplers, or online in audio effects
+and virtual instruments.
+
+WWW: http://aubio.org/
diff --git a/audio/aubio/pkg-plist b/audio/aubio/pkg-plist
new file mode 100644
index 000000000000..bc2cdfafa11c
--- /dev/null
+++ b/audio/aubio/pkg-plist
@@ -0,0 +1,53 @@
+bin/aubioonset
+bin/aubiotrack
+bin/aubionotes
+include/aubio/config.h
+include/aubio/aubio.h
+include/aubio/types.h
+include/aubio/phasevoc.h
+include/aubio/mathutils.h
+include/aubio/fft.h
+include/aubio/sample.h
+include/aubio/hist.h
+include/aubio/scale.h
+include/aubio/resample.h
+include/aubio/onsetdetection.h
+include/aubio/tss.h
+include/aubio/peakpick.h
+include/aubio/biquad.h
+include/aubio/pitchdetection.h
+include/aubio/pitchmcomb.h
+include/aubio/pitchyin.h
+include/aubio/pitchschmitt.h
+include/aubio/pitchfcomb.h
+include/aubio/pitchyinfft.h
+include/aubio/beattracking.h
+include/aubio/onset.h
+include/aubio/tempo.h
+include/aubio/filter.h
+include/aubio/aubioext.h
+include/aubio/jackio.h
+include/aubio/sndfileio.h
+include/aubio/midi/midi.h
+include/aubio/midi/list.h
+include/aubio/midi/timer.h
+include/aubio/midi/midi_file.h
+include/aubio/midi/midi_driver.h
+include/aubio/midi/midi_event.h
+include/aubio/midi/midi_track.h
+include/aubio/midi/midi_player.h
+include/aubio/midi/midi_parser.h
+@dirrm include/aubio/midi
+@dirrm include/aubio
+lib/libaubio.so.3
+lib/libaubio.so
+lib/libaubio.la
+lib/libaubio.a
+lib/libaubioext.so.3
+lib/libaubioext.so
+lib/libaubioext.la
+lib/libaubioext.a
+libdata/pkgconfig/aubio.pc
+share/sounds/aubio/woodblock.aiff
+@dirrm share/sounds/aubio
+@dirrm share/sounds