aboutsummaryrefslogtreecommitdiff
path: root/audio/audacity-devel
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-05-04 17:44:09 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-05-04 17:44:09 +0000
commitc2d4f523942b86ebcbf351b97693c544934e6fe6 (patch)
tree2fc006fc20fe3aec3d593129d078905ca07eff7b /audio/audacity-devel
parent63680caae08a410fba2a1133e37cd9d3baaef851 (diff)
downloadports-c2d4f523942b86ebcbf351b97693c544934e6fe6.tar.gz
ports-c2d4f523942b86ebcbf351b97693c544934e6fe6.zip
Notes
Diffstat (limited to 'audio/audacity-devel')
-rw-r--r--audio/audacity-devel/Makefile29
-rw-r--r--audio/audacity-devel/distinfo4
-rw-r--r--audio/audacity-devel/files/patch-Makefile.in1
-rw-r--r--audio/audacity-devel/files/patch-lib-src__libnyquist__nyquist__nyqstk__include__FileRead.h10
-rw-r--r--audio/audacity-devel/pkg-plist69
5 files changed, 72 insertions, 41 deletions
diff --git a/audio/audacity-devel/Makefile b/audio/audacity-devel/Makefile
index 2ec42712fa58..2a0f52ee6aec 100644
--- a/audio/audacity-devel/Makefile
+++ b/audio/audacity-devel/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= audacity
-PORTVERSION= 1.3.12
-PORTREVISION= 4
+PORTVERSION= 1.3.13
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
SF/${PORTNAME}/${PORTNAME}-unstable/${PORTVERSION}
@@ -25,33 +24,33 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION}-beta
USE_AUTOTOOLS= aclocal autoconf
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GCC= 4.2+
+USE_GCC= 4.6+
USE_GETTEXT= yes
USE_BZIP2= yes
-USE_WX= 2.8
+USE_WX= 2.8+
WX_COMPS= wx
MAKE_JOBS_SAFE= yes
PORTDOCS= README.txt LICENSE.txt
MAN1= audacity.1
MANCOMPRESSED= yes
-OPTIONS= DEBUG "enable debug support" off \
+OPTIONS= DEBUG "Debug support" off \
FFMPEG "Use ffmpeg for import and export support" on \
FLAC "Use libFLAC for FLAC support" on \
ID3TAG "Use libid3tag for mp3 id3 tag support" on \
- LADSPA "enable LADSPA plug-in support" on \
+ LADSPA "LADSPA plug-in support" on \
MAD "Use libmad for mp2/3 decoding support" on \
MIDI "Use portSMF for Midi support" on \
- NYQUIST "enable Nyquist plug-in support" on \
- PORTMIXER "compile with PortMixer" on \
+ NYQUIST "Nyquist plug-in support" on \
+ PORTMIXER "Compile with PortMixer" on \
SAMPLERATE "Use libresample for sample rate conversion" on \
SBSMS "Use libsbsms for pitch and tempo changing" on \
SOUNDTOUCH "Use libSoundTouch for pitch and tempo changing" on\
- TAGLIB "use TagLib for metadata support" on \
+ TAGLIB "Use TagLib for metadata support" on \
TWOLAME "Use libtwolame for MP2 export support" on \
- UNICODE "enable unicode support" on \
+ UNICODE "Unicode support" on \
VORBIS "Use libvorbis for Ogg Vorbis support" on \
- VAMP "use libvamp for Vamp plug-in support" on
+ VAMP "Use libvamp for Vamp plug-in support" on
.include <bsd.port.pre.mk>
@@ -76,8 +75,10 @@ CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" \
MAKE_ENV= DOC=yes
.endif
+CONFIGURE_ARGS+= --with-lib-preference="local system"
+CONFIGURE_ARGS+= --with-portaudio
.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --with-debug
+CONFIGURE_ARGS+= --enable-debug
.endif
.if defined(WITH_FFMPEG)
@@ -93,7 +94,7 @@ CONFIGURE_ARGS+= --with-libid3tag
.endif
.if defined(WITH_LADSPA)
-CONFIGURE_ARGS+= --with-ladspa
+CONFIGURE_ARGS+= --enable-ladspa
.endif
.if defined(WITH_MAD)
@@ -105,7 +106,7 @@ CONFIGURE_ARGS+= --with-midi
.endif
.if defined(WITH_NYQUIST)
-CONFIGURE_ARGS+= --with-nyquist
+CONFIGURE_ARGS+= --enable-nyquist
.endif
.if defined(WITH_PORTMIXER)
diff --git a/audio/audacity-devel/distinfo b/audio/audacity-devel/distinfo
index 171aed6fd4fd..d7facce353ca 100644
--- a/audio/audacity-devel/distinfo
+++ b/audio/audacity-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (audacity-minsrc-1.3.12-beta.tar.bz2) = f0f55839ca3013d2e43e5114c73d195bc34503685aeab683eafca4d1bbf3b768
-SIZE (audacity-minsrc-1.3.12-beta.tar.bz2) = 6087920
+SHA256 (audacity-minsrc-1.3.13-beta.tar.bz2) = 4c2eda638e16e16dfddd202e86ccbe1d170b04c26cfb2c12ffcba0b79e7e1e83
+SIZE (audacity-minsrc-1.3.13-beta.tar.bz2) = 6450901
diff --git a/audio/audacity-devel/files/patch-Makefile.in b/audio/audacity-devel/files/patch-Makefile.in
index 095ebee8bbb9..5d907cc28585 100644
--- a/audio/audacity-devel/files/patch-Makefile.in
+++ b/audio/audacity-devel/files/patch-Makefile.in
@@ -5,7 +5,6 @@
# install docs
+ifeq ($(DOC),yes)
- $(INSTALL) -d $(DESTDIR)$(DATADIR)/$(AUDACITY_NAME)
$(INSTALL) -d $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)
$(INSTALL) -m 644 README.txt $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)/README.txt
$(INSTALL) -m 644 LICENSE.txt $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)/LICENSE.txt
diff --git a/audio/audacity-devel/files/patch-lib-src__libnyquist__nyquist__nyqstk__include__FileRead.h b/audio/audacity-devel/files/patch-lib-src__libnyquist__nyquist__nyqstk__include__FileRead.h
new file mode 100644
index 000000000000..0e3b2e97887c
--- /dev/null
+++ b/audio/audacity-devel/files/patch-lib-src__libnyquist__nyquist__nyqstk__include__FileRead.h
@@ -0,0 +1,10 @@
+--- ./lib-src/libnyquist/nyquist/nyqstk/include/FileRead.h.orig 2011-05-04 17:18:48.000000000 +0200
++++ ./lib-src/libnyquist/nyquist/nyqstk/include/FileRead.h 2011-05-04 17:19:13.000000000 +0200
+@@ -33,6 +33,7 @@
+ #define STK_FILEREAD_H
+
+ #include "Stk.h"
++#include <stdio.h>
+
+ namespace Nyq
+ {
diff --git a/audio/audacity-devel/pkg-plist b/audio/audacity-devel/pkg-plist
index f70ef2268341..ea0a4d3bbcb2 100644
--- a/audio/audacity-devel/pkg-plist
+++ b/audio/audacity-devel/pkg-plist
@@ -1,5 +1,7 @@
bin/audacity
+man/man1/audacity.1.gz
share/applications/audacity.desktop
+%%DATADIR%%/EQDefaultCurves.xml
%%DATADIR%%/nyquist/bug.lsp
%%DATADIR%%/nyquist/dspprims.lsp
%%DATADIR%%/nyquist/envelopes.lsp
@@ -11,9 +13,25 @@ share/applications/audacity.desktop
%%DATADIR%%/nyquist/misc.lsp
%%DATADIR%%/nyquist/nyinit.lsp
%%DATADIR%%/nyquist/nyqmisc.lsp
+%%DATADIR%%/nyquist/nyquist-plot.txt
%%DATADIR%%/nyquist/nyquist.lsp
%%DATADIR%%/nyquist/printrec.lsp
%%DATADIR%%/nyquist/profile.lsp
+%%DATADIR%%/nyquist/rawwaves/mand1.raw
+%%DATADIR%%/nyquist/rawwaves/mand10.raw
+%%DATADIR%%/nyquist/rawwaves/mand11.raw
+%%DATADIR%%/nyquist/rawwaves/mand12.raw
+%%DATADIR%%/nyquist/rawwaves/mand2.raw
+%%DATADIR%%/nyquist/rawwaves/mand3.raw
+%%DATADIR%%/nyquist/rawwaves/mand4.raw
+%%DATADIR%%/nyquist/rawwaves/mand5.raw
+%%DATADIR%%/nyquist/rawwaves/mand6.raw
+%%DATADIR%%/nyquist/rawwaves/mand7.raw
+%%DATADIR%%/nyquist/rawwaves/mand8.raw
+%%DATADIR%%/nyquist/rawwaves/mand9.raw
+%%DATADIR%%/nyquist/rawwaves/mandpluk.raw
+%%DATADIR%%/nyquist/rawwaves/marmstk1.raw
+%%DATADIR%%/nyquist/rawwaves/sinewave.raw
%%DATADIR%%/nyquist/sal-parse.lsp
%%DATADIR%%/nyquist/sal.lsp
%%DATADIR%%/nyquist/seq.lsp
@@ -35,6 +53,7 @@ share/applications/audacity.desktop
%%DATADIR%%/plug-ins/equalabel.ny
%%DATADIR%%/plug-ins/highpass.ny
%%DATADIR%%/plug-ins/lowpass.ny
+%%DATADIR%%/plug-ins/notch.ny
%%DATADIR%%/plug-ins/pluck.ny
%%DATADIR%%/plug-ins/rissetdrum.ny
%%DATADIR%%/plug-ins/tremolo.ny
@@ -48,6 +67,7 @@ share/icons/hicolor/48x48/apps/audacity.png
share/icons/hicolor/scalable/apps/audacity.svg
share/locale/af/LC_MESSAGES/audacity.mo
share/locale/ar/LC_MESSAGES/audacity.mo
+share/locale/be/LC_MESSAGES/audacity.mo
share/locale/bg/LC_MESSAGES/audacity.mo
share/locale/bn/LC_MESSAGES/audacity.mo
share/locale/bs/LC_MESSAGES/audacity.mo
@@ -99,31 +119,32 @@ share/pixmaps/audacity.xpm
share/pixmaps/audacity16.xpm
share/pixmaps/audacity32.xpm
share/pixmaps/gnome-mime-application-x-audacity-project.xpm
-@dirrmtry share/mime/packages
-@dirrmtry share/mime
-@dirrmtry share/locale/oc/LC_MESSAGES
-@dirrmtry share/locale/oc
-@dirrmtry share/locale/my/LC_MESSAGES
-@dirrmtry share/locale/my
-@dirrmtry share/locale/km/LC_MESSAGES
-@dirrmtry share/locale/km
-@dirrmtry share/locale/ca@valencia/LC_MESSAGES
-@dirrmtry share/locale/ca@valencia
-@dirrmtry share/icons/hicolor/scalable/apps
-@dirrmtry share/icons/hicolor/scalable
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor/24x24/apps
-@dirrmtry share/icons/hicolor/24x24
-@dirrmtry share/icons/hicolor/22x22/apps
-@dirrmtry share/icons/hicolor/22x22
-@dirrmtry share/icons/hicolor/16x16/apps
-@dirrmtry share/icons/hicolor/16x16
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
+@dirrm share/mime/packages
+@dirrm share/mime
+@dirrm share/locale/oc/LC_MESSAGES
+@dirrm share/locale/oc
+@dirrm share/locale/my/LC_MESSAGES
+@dirrm share/locale/my
+@dirrm share/locale/km/LC_MESSAGES
+@dirrm share/locale/km
+@dirrm share/locale/ca@valencia/LC_MESSAGES
+@dirrm share/locale/ca@valencia
+@dirrm share/icons/hicolor/scalable/apps
+@dirrm share/icons/hicolor/scalable
+@dirrm share/icons/hicolor/48x48/apps
+@dirrm share/icons/hicolor/48x48
+@dirrm share/icons/hicolor/32x32/apps
+@dirrm share/icons/hicolor/32x32
+@dirrm share/icons/hicolor/24x24/apps
+@dirrm share/icons/hicolor/24x24
+@dirrm share/icons/hicolor/22x22/apps
+@dirrm share/icons/hicolor/22x22
+@dirrm share/icons/hicolor/16x16/apps
+@dirrm share/icons/hicolor/16x16
+@dirrm share/icons/hicolor
+@dirrm share/icons
@dirrm %%DATADIR%%/plug-ins
+@dirrm %%DATADIR%%/nyquist/rawwaves
@dirrm %%DATADIR%%/nyquist
@dirrm share/audacity
@dirrmtry share/applications