aboutsummaryrefslogtreecommitdiff
path: root/audio/audacity-devel
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
commitf76d32b8e89fed7c0e459c1a7fe7a4b57661b01c (patch)
treead29e6808ff698f84e08dab8e047f0ae72838df9 /audio/audacity-devel
parent873cae3ab41a109b6f9cf9f4149f101d6d996235 (diff)
downloadports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.tar.gz
ports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.zip
Notes
Diffstat (limited to 'audio/audacity-devel')
-rw-r--r--audio/audacity-devel/Makefile1
-rw-r--r--audio/audacity-devel/files/patch-src_AudacityApp.cpp30
2 files changed, 31 insertions, 0 deletions
diff --git a/audio/audacity-devel/Makefile b/audio/audacity-devel/Makefile
index ce04285e23ab..9968bf25a6ce 100644
--- a/audio/audacity-devel/Makefile
+++ b/audio/audacity-devel/Makefile
@@ -6,6 +6,7 @@
PORTNAME= audacity
PORTVERSION= 1.3.9
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
SF/${PORTNAME}/${PORTNAME}-unstable/${PORTVERSION}
diff --git a/audio/audacity-devel/files/patch-src_AudacityApp.cpp b/audio/audacity-devel/files/patch-src_AudacityApp.cpp
new file mode 100644
index 000000000000..8026532a212a
--- /dev/null
+++ b/audio/audacity-devel/files/patch-src_AudacityApp.cpp
@@ -0,0 +1,30 @@
+--- src/AudacityApp.cpp.orig 2009-11-27 00:27:29.000000000 +0100
++++ src/AudacityApp.cpp 2009-11-27 00:48:36.000000000 +0100
+@@ -23,6 +23,15 @@ It handles initialization and terminatio
+
+ #include "Audacity.h" // This should always be included first
+
++/*
++ * Get Gtk.h and Glib.h included and working around that glib got
++ * a GSocket class now
++ */
++#include <dlfcn.h>
++#define GSocket GlibGSocket
++#include <gtk/gtk.h>
++#undef GSocket
++
+ #include <wx/defs.h>
+ #include <wx/app.h>
+ #include <wx/docview.h>
+@@ -328,8 +337,11 @@ void QuitAudacity()
+ // Most of this was taken from nsNativeAppSupportUnix.cpp from Mozilla.
+ ///////////////////////////////////////////////////////////////////////////////
+
++/* moved up so it doesn't undefs GSocket from wxgtk */
++/*
+ #include <dlfcn.h>
+ #include <gtk/gtk.h>
++*/
+
+ typedef struct _GnomeProgram GnomeProgram;
+ typedef struct _GnomeModuleInfo GnomeModuleInfo;