aboutsummaryrefslogtreecommitdiff
path: root/audio/audacity/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /audio/audacity/Makefile
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'audio/audacity/Makefile')
-rw-r--r--audio/audacity/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 1ca7f8f0d1cd..57c87d54d364 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -37,9 +37,9 @@ OPTIONS= ID3TAG "ID3 tag support" off \
SSE_CFLAGS= -mno-sse -mno-sse2
.endif
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}" \
- CFLAGS="${CFLAGS} -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}"
+CFLAGS+= -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.if !defined(NOPORTDOCS)
MAKE_ENV= DOC=yes