aboutsummaryrefslogtreecommitdiff
path: root/audio/audacity/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-12-01 07:39:02 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-12-01 07:39:02 +0000
commitd750615763ee2d3250de2115295079f66d813d1f (patch)
tree05b94e79be3ac272b9b617e50fc723ea52c6cf34 /audio/audacity/Makefile
parent767bcfc72cf9c3574739d745cff6620fa75b0e74 (diff)
downloadports-d750615763ee2d3250de2115295079f66d813d1f.tar.gz
ports-d750615763ee2d3250de2115295079f66d813d1f.zip
Notes
Diffstat (limited to 'audio/audacity/Makefile')
-rw-r--r--audio/audacity/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 908cd6d9723e..bd930904d371 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= craig@yekse.gank.org
COMMENT= Audacity is a GUI editor for digital audio waveforms
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
-LIB_DEPENDS= wx_gtk2_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26
CONFLICTS= audacity-devel-[0-9]*
@@ -24,6 +23,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GETTEXT= yes
+USE_WX= 2.6
MAN1= audacity.1
MANCOMPRESSED= yes
@@ -40,8 +40,7 @@ SSE_CFLAGS= -mno-sse -mno-sse2
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}" \
- CFLAGS="${CFLAGS} -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}" \
- WX_CONFIG=${X11BASE}/bin/wxgtk2-2.6-config
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}"
.if !defined(NOPORTDOCS)
MAKE_ENV= DOC=yes