aboutsummaryrefslogtreecommitdiff
path: root/audio/audacity
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2016-02-02 23:13:07 +0000
committerThomas Zander <riggs@FreeBSD.org>2016-02-02 23:13:07 +0000
commit330ca71a8b04c836fc38e938c465a20cbf60da0b (patch)
treeedf49691e84bdf99421f2de73e2503884702d8fb /audio/audacity
parent903ce0b83bd5d3b93f074d9f3c1992160c3be639 (diff)
downloadports-330ca71a8b04c836fc38e938c465a20cbf60da0b.tar.gz
ports-330ca71a8b04c836fc38e938c465a20cbf60da0b.zip
Notes
Diffstat (limited to 'audio/audacity')
-rw-r--r--audio/audacity/Makefile24
-rw-r--r--audio/audacity/files/patch-lib-src__libsoxr__configure9
-rw-r--r--audio/audacity/files/patch-lib-src__lv2__Makefile10
-rw-r--r--audio/audacity/files/patch-lib-src_lv2_configure10
-rw-r--r--audio/audacity/files/patch-src_effects_vamp_LoadVamp.cpp11
-rw-r--r--audio/audacity/files/patch-src_import_ImportFLAC.cpp20
6 files changed, 57 insertions, 27 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 6bc5f40f63ce..0935feb0b81b 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -24,7 +24,7 @@ BUILD_DEPENDS+= autogen:${PORTSDIR}/devel/autogen \
WRKSRC= ${WRKDIR}/${PORTNAME}-Audacity-${PORTVERSION}
GNU_CONFIGURE= yes
-USES= compiler:c11 cpe desktop-file-utils gmake pkgconfig shared-mime-info shebangfix dos2unix
+USES= compiler:c++11-lib cpe desktop-file-utils gmake pkgconfig shared-mime-info shebangfix dos2unix
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
OPTIONS_SUB= yes
@@ -32,12 +32,12 @@ USE_WX= 3.0+
WX_COMPS= wx
INSTALLS_ICONS= yes
PORTDOCS= README.txt
-INSTALL_TARGET= install-strip
DOS2UNIX_GLOB= Makefile.* *.c* *.h
+SHEBANG_FILES= lib-src/lv2/build
-OPTIONS_DEFINE= NLS DEBUG DOCS FFMPEG FLAC ID3TAG LADSPA LAME MAD MIDI \
+OPTIONS_DEFINE= NLS DEBUG DOCS FFMPEG FLAC ID3TAG LADSPA LAME LV2 MAD \
SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
-OPTIONS_DEFAULT= FLAC ID3TAG LADSPA MAD MIDI \
+OPTIONS_DEFAULT= FLAC ID3TAG LADSPA MAD \
SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
OPTIONS_DEFINE_amd64= SSE
@@ -47,6 +47,7 @@ OPTIONS_DEFAULT_i386= ${MACHINE_CPU:tu:MSSE}
DEBUG_DESC= Enable debug support
LAME_DESC= Use lame for import and export support
+LV2_DESC= Add LV2 plug-in support
MAD_DESC= Use libmad for mp2/3 decoding support
MIDI_DESC= Use portSMF for Midi support
SBSMS_DESC= Use libsbsms for pitch and tempo changing
@@ -58,7 +59,7 @@ VST_DESC= VST plug-in support
CONFIGURE_ENV+= WX_CONFIG="${WX_CONFIG}"
-CONFIGURE_ARGS+= --with-lib-preference="local system" --without-lv2 \
+CONFIGURE_ARGS+= --with-lib-preference="local system" \
--enable-portaudio --enable-unicode --with-libsoxr
CONFIGURE_SHELL?=${LOCALBASE}/bin/bash
@@ -85,11 +86,11 @@ LADSPA_RUN_DEPENDS= listplugins:${PORTSDIR}/audio/ladspa
MAD_CONFIGURE_WITH= libmad
MAD_LIB_DEPENDS= libmad.so:${PORTSDIR}/audio/libmad
-MIDI_CONFIGURE_WITH= midi
-
LAME_CONFIGURE_WITH= lame
LAME_LIB_DEPENDS= libmp3lame.so:${PORTSDIR}/audio/lame
+LV2_CONFIGURE_WITH= lv2
+
SBSMS_CONFIGURE_WITH= sbsms
SOUNDTOUCH_CONFIGURE_WITH= soundtouch
@@ -114,8 +115,15 @@ CFLAGS+= -I${WRKSRC}/lib-src/portsmf \
-I${WRKSRC}/lib-src/portaudio-v19/include \
-I${WRKSRC}/lib-src/lame -I${LOCALBASE}/include
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc
+CXXFLAGS+= -std=c++11
+.endif
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/audacity/files/patch-lib-src__libsoxr__configure b/audio/audacity/files/patch-lib-src__libsoxr__configure
deleted file mode 100644
index a29d32c90305..000000000000
--- a/audio/audacity/files/patch-lib-src__libsoxr__configure
+++ /dev/null
@@ -1,9 +0,0 @@
---- lib-src/libsoxr/configure.orig 2015-07-11 10:02:22 UTC
-+++ lib-src/libsoxr/configure
-@@ -12,6 +12,5 @@
-
- srcdir="$@"
- srcdir="${srcdir#*--srcdir=}"
--srcdir="./${srcdir/ */}"
-
- cmake -DBUILD_SHARED_LIBS=OFF -DWITH_OPENMP=OFF "${srcdir}"
diff --git a/audio/audacity/files/patch-lib-src__lv2__Makefile b/audio/audacity/files/patch-lib-src__lv2__Makefile
deleted file mode 100644
index 9bee8cb8c588..000000000000
--- a/audio/audacity/files/patch-lib-src__lv2__Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib-src/lv2/Makefile.orig 2015-07-11 10:02:22 UTC
-+++ lib-src/lv2/Makefile
-@@ -1,7 +1,6 @@
- include srcdir.mk
-
- all:
-- ./build --srcdir=$(srcdir)
-
- check:
-
diff --git a/audio/audacity/files/patch-lib-src_lv2_configure b/audio/audacity/files/patch-lib-src_lv2_configure
new file mode 100644
index 000000000000..899f8c49567f
--- /dev/null
+++ b/audio/audacity/files/patch-lib-src_lv2_configure
@@ -0,0 +1,10 @@
+--- lib-src/lv2/configure 2016-01-08 14:05:48.000000000 -0800
++++ lib-src/lv2/configure 2016-01-27 17:18:31.280753000 -0800
+@@ -54,7 +54,7 @@
+ Name: ${pkg}
+ Version: ${version}
+ Description: Temporary fake config file
+-Libs: -L\${libdir} ${lib} -ldl -lm
++Libs: -L\${libdir} ${lib} -lm
+ Cflags: -I\${includedir}/${pkg}${major}
+ EOF
diff --git a/audio/audacity/files/patch-src_effects_vamp_LoadVamp.cpp b/audio/audacity/files/patch-src_effects_vamp_LoadVamp.cpp
new file mode 100644
index 000000000000..ed0c5d124687
--- /dev/null
+++ b/audio/audacity/files/patch-src_effects_vamp_LoadVamp.cpp
@@ -0,0 +1,11 @@
+--- src/effects/vamp/LoadVamp.cpp.orig 2016-01-08 22:05:48 UTC
++++ src/effects/vamp/LoadVamp.cpp
+@@ -266,7 +266,7 @@ Plugin *VampEffectsModule::FindPlugin(co
+ Plugin *vp = PluginLoader::getInstance()->loadPlugin(key, 48000); // rate doesn't matter here
+ if (!vp)
+ {
+- return false;
++ return NULL;
+ }
+
+ // We limit the listed plugin outputs to those whose results can
diff --git a/audio/audacity/files/patch-src_import_ImportFLAC.cpp b/audio/audacity/files/patch-src_import_ImportFLAC.cpp
new file mode 100644
index 000000000000..0673e1e61f54
--- /dev/null
+++ b/audio/audacity/files/patch-src_import_ImportFLAC.cpp
@@ -0,0 +1,20 @@
+--- src/import/ImportFLAC.cpp.orig 2016-01-08 22:05:48 UTC
++++ src/import/ImportFLAC.cpp
+@@ -296,7 +296,7 @@ ImportFileHandle *FLACImportPlugin::Open
+ int cnt;
+ wxFile binaryFile;
+ if (!binaryFile.Open(filename)) {
+- return false; // File not found
++ return NULL; // File not found
+ }
+
+ #ifdef USE_LIBID3TAG
+@@ -313,7 +313,7 @@ ImportFileHandle *FLACImportPlugin::Open
+
+ if (cnt == wxInvalidOffset || strncmp(buf, FLAC_HEADER, 4) != 0) {
+ // File is not a FLAC file
+- return false;
++ return NULL;
+ }
+
+ // Open the file for import