aboutsummaryrefslogtreecommitdiff
path: root/audio/audacity
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-04-05 06:58:00 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-04-05 06:58:00 +0000
commitb87bee14c37f3645434172737e914518c42c052f (patch)
treeca9290ae7e4e19f8340644d321ae951b68097160 /audio/audacity
parent5bd0631ba907ff37aa6bdf79bf8798ee1693f99a (diff)
downloadports-b87bee14c37f3645434172737e914518c42c052f.tar.gz
ports-b87bee14c37f3645434172737e914518c42c052f.zip
Notes
Diffstat (limited to 'audio/audacity')
-rw-r--r--audio/audacity/Makefile24
-rw-r--r--audio/audacity/distinfo4
-rw-r--r--audio/audacity/files/patch-lib-src__libvamp__Makefile.in10
-rw-r--r--audio/audacity/files/patch-src__Makefile.in2
-rw-r--r--audio/audacity/files/patch-src_effects_VST_VSTEffect.cpp11
-rw-r--r--audio/audacity/pkg-plist12
6 files changed, 36 insertions, 27 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index a590dd78cfd6..bd6d5078ed20 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= audacity
-PORTVERSION= 2.0.6
-PORTREVISION= 2
+PORTVERSION= 2.1.0
CATEGORIES= audio
MASTER_SITES= GOOGLE_CODE \
SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
@@ -16,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
-WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-minsrc-${PORTVERSION}
GNU_CONFIGURE= yes
USES= desktop-file-utils gettext gmake pkgconfig shared-mime-info \
@@ -28,11 +27,11 @@ INSTALLS_ICONS= yes
PORTDOCS= README.txt
OPTIONS_DEFINE= DEBUG DOCS FFMPEG FLAC ID3TAG LADSPA LAME MAD MIDI NYQUIST \
- PORTMIXER SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS
+ PORTMIXER SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
OPTIONS_SINGLE= SAMPLERATED
-OPTIONS_SINGLE_SAMPLERATED= SAMPLERATE SOXR
+OPTIONS_SINGLE_SAMPLERATED= SAMPLERATE #SOXR
OPTIONS_DEFAULT= FFMPEG FLAC ID3TAG LADSPA MAD MIDI NYQUIST \
- PORTMIXER SBSMS SOUNDTOUCH SOXR TWOLAME VAMP VORBIS
+ PORTMIXER SBSMS SOUNDTOUCH SAMPLERATE TWOLAME VAMP VORBIS VST
DEBUG_DESC= Enable debug support
LAME_DESC= Use lame for import and export support
@@ -44,17 +43,16 @@ SAMPLERATED_DESC= Default sample rate conversion support
PORTMIXER_DESC= Compile with PortMixer support
SBSMS_DESC= Use libsbsms for pitch and tempo changing
SOUNDTOUCH_DESC= Use libSoundTouch for pitch and tempo changing
-SOXR_DESC= Use libsoxr for sample rate conversion
+#SOXR_DESC= Use libsoxr for sample rate conversion
TAGLIB_DESC= Use TagLib for metadata support
TWOLAME_DESC= Use libtwolame for MP2 export support
VAMP_DESC= Vamp plug-in support
-
+VST_DESC= VST plug-in support
CONFIGURE_ENV+= WX_CONFIG="${WX_CONFIG}"
CONFIGURE_ARGS+= --with-lib-preference="local system" \
- --enable-portaudio --enable-unicode --without-lv2
-
+ --enable-portaudio --enable-unicode
.if ${MACHINE_CPU:Msse}
CONFIGURE_ARGS+= --enable-sse
.else
@@ -100,8 +98,8 @@ SBSMS_CONFIGURE_WITH= sbsms
SOUNDTOUCH_CONFIGURE_WITH= soundtouch
SOUNDTOUCH_LIB_DEPENDS= libSoundTouch.so:${PORTSDIR}/audio/soundtouch
-SOXR_CONFIGURE_WITH= libsoxr
-SOXR_BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
+#SOXR_CONFIGURE_WITH= libsoxr
+#SOXR_BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
TWOLAME_CONFIGURE_WITH= libtwolame
TWOLAME_LIB_DEPENDS= libtwolame.so:${PORTSDIR}/audio/twolame
@@ -111,6 +109,8 @@ VAMP_CONFIGURE_WITH= libvamp
VORBIS_CONFIGURE_WITH= libvorbis
VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
+VST_CONFIGURE_ENABLE= vst
+
.include <bsd.port.pre.mk>
LDFLAGS+= -lpthread -L${LOCALBASE}/lib
diff --git a/audio/audacity/distinfo b/audio/audacity/distinfo
index d3bb01e1b405..d34445b725c9 100644
--- a/audio/audacity/distinfo
+++ b/audio/audacity/distinfo
@@ -1,2 +1,2 @@
-SHA256 (audacity-minsrc-2.0.6.tar.xz) = 3080c190e678e0d682961a36c6e990c572dacd6b5ce499e5cec7362e9fa37d7b
-SIZE (audacity-minsrc-2.0.6.tar.xz) = 7380460
+SHA256 (audacity-minsrc-2.1.0.tar.xz) = b0d98d89b38be233e88af81e1add649732484b6f8feec95dc5977accdde042b3
+SIZE (audacity-minsrc-2.1.0.tar.xz) = 5104924
diff --git a/audio/audacity/files/patch-lib-src__libvamp__Makefile.in b/audio/audacity/files/patch-lib-src__libvamp__Makefile.in
deleted file mode 100644
index 622e22193066..000000000000
--- a/audio/audacity/files/patch-lib-src__libvamp__Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib-src/libvamp/Makefile.in.orig 2014-09-22 20:38:14 UTC
-+++ lib-src/libvamp/Makefile.in
-@@ -39,6 +39,7 @@
- # Compile flags
- #
- CC = @CC@
-+CFLAGS = -I. @CXXFLAGS@ @SNDFILE_CFLAGS@
- CXX = @CXX@
- CXXFLAGS = -I. @CXXFLAGS@ @SNDFILE_CFLAGS@
-
diff --git a/audio/audacity/files/patch-src__Makefile.in b/audio/audacity/files/patch-src__Makefile.in
index 8ab7be9512d6..6e817c83a4d9 100644
--- a/audio/audacity/files/patch-src__Makefile.in
+++ b/audio/audacity/files/patch-src__Makefile.in
@@ -1,6 +1,6 @@
--- src/Makefile.in.orig 2014-09-22 20:38:13 UTC
+++ src/Makefile.in
-@@ -1131,8 +1131,7 @@
+@@ -1055,8 +1055,7 @@
# /usr/local/include/wx-2.8/wx/buffer.h:289:9: note: in expansion of macro 'wxCHECK_RET'
# wxCHECK_RET( m_bufdata->m_data, wxT("invalid wxMemoryBuffer") );
# ^
diff --git a/audio/audacity/files/patch-src_effects_VST_VSTEffect.cpp b/audio/audacity/files/patch-src_effects_VST_VSTEffect.cpp
new file mode 100644
index 000000000000..26363d9d4077
--- /dev/null
+++ b/audio/audacity/files/patch-src_effects_VST_VSTEffect.cpp
@@ -0,0 +1,11 @@
+--- src/effects/VST/VSTEffect.cpp 2015-03-31 23:03:30.000000000 -0700
++++ src/effects/VST/VSTEffect.cpp 2015-03-01 17:06:58.000000000 -0800
+@@ -2609,7 +2609,7 @@
+ // symbols.
+ //
+ // Once we define a proper external API, the flags can be removed.
+- void *lib = dlopen((const char *)wxString(realPath).ToUTF8(), RTLD_NOW | RTLD_LOCAL | RTLD_DEEPBIND);
++ void *lib = dlopen((const char *)wxString(realPath).ToUTF8(), RTLD_NOW | RTLD_LOCAL);
+ if (!lib)
+ {
+ return false;
diff --git a/audio/audacity/pkg-plist b/audio/audacity/pkg-plist
index dd6953c99bfa..ba760273f5b5 100644
--- a/audio/audacity/pkg-plist
+++ b/audio/audacity/pkg-plist
@@ -3,6 +3,14 @@ man/man1/audacity.1.gz
share/appdata/audacity.appdata.xml
share/applications/audacity.desktop
%%DATADIR%%/EQDefaultCurves.xml
+%%DATADIR%%/include/audacity/ConfigInterface.h
+%%DATADIR%%/include/audacity/EffectAutomationParameters.h
+%%DATADIR%%/include/audacity/EffectInterface.h
+%%DATADIR%%/include/audacity/IdentInterface.h
+%%DATADIR%%/include/audacity/ImporterInterface.h
+%%DATADIR%%/include/audacity/ModuleInterface.h
+%%DATADIR%%/include/audacity/PluginInterface.h
+%%DATADIR%%/include/audacity/Types.h
%%DATADIR%%/nyquist/bug.lsp
%%DATADIR%%/nyquist/dspprims.lsp
%%DATADIR%%/nyquist/envelopes.lsp
@@ -50,8 +58,7 @@ share/applications/audacity.desktop
%%DATADIR%%/plug-ins/beat.ny
%%DATADIR%%/plug-ins/clicktrack.ny
%%DATADIR%%/plug-ins/clipfix.ny
-%%DATADIR%%/plug-ins/crossfadein.ny
-%%DATADIR%%/plug-ins/crossfadeout.ny
+%%DATADIR%%/plug-ins/crossfadetracks.ny
%%DATADIR%%/plug-ins/delay.ny
%%DATADIR%%/plug-ins/equalabel.ny
%%DATADIR%%/plug-ins/highpass.ny
@@ -94,6 +101,7 @@ share/locale/he/LC_MESSAGES/audacity.mo
share/locale/hi/LC_MESSAGES/audacity.mo
share/locale/hr/LC_MESSAGES/audacity.mo
share/locale/hu/LC_MESSAGES/audacity.mo
+share/locale/hy/LC_MESSAGES/audacity.mo
share/locale/id/LC_MESSAGES/audacity.mo
share/locale/it/LC_MESSAGES/audacity.mo
share/locale/ja/LC_MESSAGES/audacity.mo