aboutsummaryrefslogtreecommitdiff
path: root/audio/audacity
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-25 21:37:39 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-25 21:37:39 +0000
commit112f62e6b9a1ec43ddc94a4694095f410e4b643e (patch)
tree277ac2758fc47caca6c3e00663bc52d197085558 /audio/audacity
parent33ac97e0314d5998c3111bd87d8bcece3e1978b2 (diff)
downloadports-112f62e6b9a1ec43ddc94a4694095f410e4b643e.tar.gz
ports-112f62e6b9a1ec43ddc94a4694095f410e4b643e.zip
Notes
Diffstat (limited to 'audio/audacity')
-rw-r--r--audio/audacity/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 36d6e11d43d8..a590dd78cfd6 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -113,10 +113,12 @@ VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
.include <bsd.port.pre.mk>
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-CPPFLAGS+= -I${WRKSRC}/lib-src/portsmf ${PTHREAD_CFLAGS}
-CXXFLAGS+= -I${WRKSRC}/lib-src/portsmf ${PTHREAD_CFLAGS}
-CFLAGS+= -I${WRKSRC}/lib-src/portsmf -I${WRKSRC}/lib-src/portaudio-v19/include -I${WRKSRC}/lib-src/lame -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -lpthread -L${LOCALBASE}/lib
+CPPFLAGS+= -I${WRKSRC}/lib-src/portsmf
+CXXFLAGS+= -I${WRKSRC}/lib-src/portsmf
+CFLAGS+= -I${WRKSRC}/lib-src/portsmf \
+ -I${WRKSRC}/lib-src/portaudio-v19/include \
+ -I${WRKSRC}/lib-src/lame -I${LOCALBASE}/include
post-patch:
.if ! ${PORT_OPTIONS:MPORTMIXER}