aboutsummaryrefslogtreecommitdiff
path: root/audio/audacity
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2014-10-30 21:10:49 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2014-10-30 21:10:49 +0000
commit11aa297fd82e1f44088d8a55e816d9e08920f350 (patch)
treeaa33fbb6f9b9f3aaeecb252d34d88e2146a345f3 /audio/audacity
parent864ca4c6c9c5275c42601159b9e2f1f7b74bc8a6 (diff)
downloadports-11aa297fd82e1f44088d8a55e816d9e08920f350.tar.gz
ports-11aa297fd82e1f44088d8a55e816d9e08920f350.zip
Notes
Diffstat (limited to 'audio/audacity')
-rw-r--r--audio/audacity/Makefile42
-rw-r--r--audio/audacity/distinfo4
-rw-r--r--audio/audacity/files/patch-Makefile.in14
-rw-r--r--audio/audacity/files/patch-lib-src__libvamp__Makefile.in10
-rw-r--r--audio/audacity/files/patch-portaudio.h48
-rw-r--r--audio/audacity/files/patch-src__Makefile.in12
-rw-r--r--audio/audacity/pkg-plist3
7 files changed, 89 insertions, 44 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 5da9f5a586cd..236b45eaf94b 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= audacity
-PORTVERSION= 2.0.5
-PORTREVISION= 3
+PORTVERSION= 2.0.6
CATEGORIES= audio
MASTER_SITES= GOOGLE_CODE \
SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
@@ -18,9 +17,9 @@ LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION}
-USE_AUTOTOOLS= aclocal autoconf
GNU_CONFIGURE= yes
-USES= tar:xz desktop-file-utils gmake gettext pkgconfig shared-mime-info
+USES= desktop-file-utils gettext gmake pkgconfig shared-mime-info \
+ tar:xz
USE_WX= 2.8
WX_UNICODE= yes
WX_COMPS= wx
@@ -30,7 +29,7 @@ PORTDOCS= README.txt
OPTIONS_DEFINE= DEBUG DOCS FFMPEG FLAC ID3TAG LADSPA LAME MAD MIDI NYQUIST \
PORTMIXER SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS
OPTIONS_RADIO= SAMPLERATED
-OPTIONS_RADIO_SAMPLERATED= RESAMPLE SAMPLERATE SOXR
+OPTIONS_RADIO_SAMPLERATED= SAMPLERATE SOXR
OPTIONS_DEFAULT= FFMPEG FLAC ID3TAG LADSPA MAD MIDI NYQUIST \
PORTMIXER SBSMS SOUNDTOUCH SOXR TWOLAME VAMP VORBIS
@@ -39,7 +38,6 @@ LAME_DESC= Use lame for import and export support
MAD_DESC= Use libmad for mp2/3 decoding support
MIDI_DESC= Use portSMF for Midi support
NYQUIST_DESC= Nyquist plug-in support
-RESAMPLE_DESC= Use libresample for sample rate conversion
SAMPLERATE_DESC= Use libsamplerate for sample rate conversion
SAMPLERATED_DESC= Default sample rate conversion support
PORTMIXER_DESC= Compile with PortMixer support
@@ -50,15 +48,11 @@ TAGLIB_DESC= Use TagLib for metadata support
TWOLAME_DESC= Use libtwolame for MP2 export support
VAMP_DESC= Vamp plug-in support
-ACLOCAL_ARGS+= -I ${WRKSRC}/m4
-AUTOCONF_ARGS+= -I ${WRKSRC}/m4
-
-CONFIGURE_ARG+= --destdir=/
CONFIGURE_ENV+= WX_CONFIG="${WX_CONFIG}"
CONFIGURE_ARGS+= --with-lib-preference="local system" \
- --with-portaudio --enable-unicode
+ --enable-portaudio --enable-unicode --without-lv2
.if ${MACHINE_CPU:Msse}
CONFIGURE_ARGS+= --enable-sse
@@ -69,11 +63,10 @@ CONFIGURE_ARGS+= --disable-sse
DEBUG_CONFIGURE_WITH= debug
FFMPEG_CONFIGURE_WITH= ffmpeg
-FFMPEG_RUN_DEPENDS= ffmpeg0:${PORTSDIR}/multimedia/ffmpeg0
-FFMPEG_BUILD_DEPENDS= ffmpeg0>=0:${PORTSDIR}/multimedia/ffmpeg0
-FFMPEG_CFLAGS= -I${LOCALBASE}/include/ffmpeg0
-FFMPEG_CPPFLAGS= -I${LOCALBASE}/include/ffmpeg0
-FFMPEG_CXXFLAGS= -I${LOCALBASE}/include/ffmpeg0
+FFMPEG_RUN_DEPENDS= ${LOCALBASE}/bin/ffmpeg:${PORTSDIR}/multimedia/ffmpeg
+FFMPEG_CFLAGS= -I${LOCALBASE}/include/ffmpeg
+FFMPEG_CPPFLAGS= -I${LOCALBASE}/include/ffmpeg
+FFMPEG_CXXFLAGS= -I${LOCALBASE}/include/ffmpeg
FLAC_CONFIGURE_WITH= libflac
FLAC_LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac
@@ -98,8 +91,6 @@ NYQUIST_CONFIGURE_ENABLE= nyquist
PORTMIXER_CONFIGURE_WITH= portmixer
-RESAMPLE_CONFIGURE_WITH= libresample
-
SAMPLERATE_CONFIGURE_WITH= libsamplerate
SAMPLERATE_LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
@@ -122,19 +113,14 @@ VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
.include <bsd.port.pre.mk>
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-CPPFLAGS+= -I${WRKSRC}/lib-src/portsmf -I${WRKSRC}/lib-src/portaudio-v19/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-CXXFLAGS+= -I${WRKSRC}/lib-src/portsmf -I${WRKSRC}/lib-src/portaudio-v19/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-CFLAGS+= -I${WRKSRC}/lib-src/portsmf -I${WRKSRC}/lib-src/portaudio-v19/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${WRKSRC}/lib-src/portsmf ${PTHREAD_CFLAGS}
+CXXFLAGS+= -I${WRKSRC}/lib-src/portsmf ${PTHREAD_CFLAGS}
+CFLAGS+= -I${WRKSRC}/lib-src/portsmf -I${WRKSRC}/lib-src/portaudio-v19/include -I${WRKSRC}/lib-src/lame -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
post-patch:
-#audacity links to some dependencies if present, even if explicitly disabled.
-#these must be patched out for the case when they are installed but
-#option-disabled to avoid unrecorded dependencies.
-
-.if empty(PORT_OPTIONS:MSAMPLERATE)
- @${REINPLACE_CMD} -e 's|libresample.a -lsamplerate $(LIBS)|libresample.a $(LIBS)|' ${WRKSRC}/lib-src/libresample/Makefile.in
+.if ! ${PORT_OPTIONS:MPORTMIXER}
+ @${REINPLACE_CMD} -e 's/ portmixer / /' ${WRKSRC}/lib-src/Makefile.in
.endif
-
@${REINPLACE_CMD} -e 's|inline void|static inline void|' ${WRKSRC}/lib-src/libnyquist/nyquist/ffts/src/fftlib.c
post-install:
diff --git a/audio/audacity/distinfo b/audio/audacity/distinfo
index a7c5d8a9aa11..d3bb01e1b405 100644
--- a/audio/audacity/distinfo
+++ b/audio/audacity/distinfo
@@ -1,2 +1,2 @@
-SHA256 (audacity-minsrc-2.0.5.tar.xz) = e287541dd017f523fd9a06d5140b8f72fe9a0450709de7c398baffa106db2b79
-SIZE (audacity-minsrc-2.0.5.tar.xz) = 5314060
+SHA256 (audacity-minsrc-2.0.6.tar.xz) = 3080c190e678e0d682961a36c6e990c572dacd6b5ce499e5cec7362e9fa37d7b
+SIZE (audacity-minsrc-2.0.6.tar.xz) = 7380460
diff --git a/audio/audacity/files/patch-Makefile.in b/audio/audacity/files/patch-Makefile.in
deleted file mode 100644
index d76f1029dab1..000000000000
--- a/audio/audacity/files/patch-Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./Makefile.in.orig 2013-01-18 19:50:47.000000000 +0400
-+++ ./Makefile.in 2013-01-27 22:38:11.000000000 +0400
-@@ -31,11 +31,6 @@
- $(INSTALL) -d $(DESTDIR)$(BINDIR)
- $(INSTALL) -m 755 audacity $(DESTDIR)$(BINDIR)/$(AUDACITY_NAME)
-
-- # install docs
-- $(INSTALL) -d $(DESTDIR)$(DOCDIR)/
-- $(INSTALL) -m 644 README.txt $(DESTDIR)$(DOCDIR)/README.txt
-- $(INSTALL) -m 644 LICENSE.txt $(DESTDIR)$(DOCDIR)/LICENSE.txt
--
- # install manpage
- $(INSTALL) -d $(DESTDIR)$(MANDIR)/man1
- -test -f help/audacity.1.gz && \
diff --git a/audio/audacity/files/patch-lib-src__libvamp__Makefile.in b/audio/audacity/files/patch-lib-src__libvamp__Makefile.in
new file mode 100644
index 000000000000..622e22193066
--- /dev/null
+++ b/audio/audacity/files/patch-lib-src__libvamp__Makefile.in
@@ -0,0 +1,10 @@
+--- lib-src/libvamp/Makefile.in.orig 2014-09-22 20:38:14 UTC
++++ lib-src/libvamp/Makefile.in
+@@ -39,6 +39,7 @@
+ # Compile flags
+ #
+ CC = @CC@
++CFLAGS = -I. @CXXFLAGS@ @SNDFILE_CFLAGS@
+ CXX = @CXX@
+ CXXFLAGS = -I. @CXXFLAGS@ @SNDFILE_CFLAGS@
+
diff --git a/audio/audacity/files/patch-portaudio.h b/audio/audacity/files/patch-portaudio.h
new file mode 100644
index 000000000000..5300e62adcab
--- /dev/null
+++ b/audio/audacity/files/patch-portaudio.h
@@ -0,0 +1,48 @@
+diff -ur lib-src/portmixer/include/portmixer.h lib-src/portmixer/include/portmixer.h
+--- lib-src/portmixer/include/portmixer.h 2014-09-22 13:38:13.000000000 -0700
++++ lib-src/portmixer/include/portmixer.h 2014-10-01 19:49:06.000000000 -0700
+@@ -45,7 +45,7 @@
+ *
+ */
+
+-#include "portaudio.h"
++#include "../../portaudio-v19/include/portaudio.h"
+
+ typedef void PxMixer;
+
+diff -ur src/AudioIO.h src/AudioIO.h
+--- src/AudioIO.h 2014-09-22 13:38:13.000000000 -0700
++++ src/AudioIO.h 2014-10-01 19:48:46.000000000 -0700
+@@ -13,7 +13,7 @@
+ #ifndef __AUDACITY_AUDIO_IO__
+ #define __AUDACITY_AUDIO_IO__
+
+-#include "portaudio.h"
++#include "../lib-src/portaudio-v19/include/portaudio.h"
+ #include "Audacity.h"
+ #include "Experimental.h"
+
+diff -ur src/DeviceManager.cpp src/DeviceManager.cpp
+--- src/DeviceManager.cpp 2014-09-22 13:38:13.000000000 -0700
++++ src/DeviceManager.cpp 2014-10-01 19:48:52.000000000 -0700
+@@ -6,7 +6,7 @@
+
+ ******************************************************************/
+
+-#include "portaudio.h"
++#include "../lib-src/portaudio-v19/include/portaudio.h"
+ #ifdef __WXMSW__
+ #include "pa_win_wasapi.h"
+ #endif
+diff -ur src/prefs/DevicePrefs.cpp src/prefs/DevicePrefs.cpp
+--- src/prefs/DevicePrefs.cpp 2014-09-22 13:38:13.000000000 -0700
++++ src/prefs/DevicePrefs.cpp 2014-10-01 19:48:39.000000000 -0700
+@@ -30,7 +30,7 @@
+ #include <wx/intl.h>
+ #include <wx/log.h>
+
+-#include "portaudio.h"
++#include "../../lib-src/portaudio-v19/include/portaudio.h"
+
+ #include "../AudioIO.h"
+ #include "../Internat.h"
diff --git a/audio/audacity/files/patch-src__Makefile.in b/audio/audacity/files/patch-src__Makefile.in
new file mode 100644
index 000000000000..8ab7be9512d6
--- /dev/null
+++ b/audio/audacity/files/patch-src__Makefile.in
@@ -0,0 +1,12 @@
+--- src/Makefile.in.orig 2014-09-22 20:38:13 UTC
++++ src/Makefile.in
+@@ -1131,8 +1131,7 @@
+ # /usr/local/include/wx-2.8/wx/buffer.h:289:9: note: in expansion of macro 'wxCHECK_RET'
+ # wxCHECK_RET( m_bufdata->m_data, wxT("invalid wxMemoryBuffer") );
+ # ^
+-audacity_CXXFLAGS = \
+- -Wno-unused-local-typedefs
++audacity_CXXFLAGS =
+
+ audacity_LDFLAGS = -rdynamic
+ audacity_LDADD = $(EXPAT_LIBS) $(FILEDIALOG_LIBS) $(PORTAUDIO_LIBS) \
diff --git a/audio/audacity/pkg-plist b/audio/audacity/pkg-plist
index b6c88f6237bb..dd6953c99bfa 100644
--- a/audio/audacity/pkg-plist
+++ b/audio/audacity/pkg-plist
@@ -1,5 +1,6 @@
bin/audacity
man/man1/audacity.1.gz
+share/appdata/audacity.appdata.xml
share/applications/audacity.desktop
%%DATADIR%%/EQDefaultCurves.xml
%%DATADIR%%/nyquist/bug.lsp
@@ -62,6 +63,7 @@ share/applications/audacity.desktop
%%DATADIR%%/plug-ins/tremolo.ny
%%DATADIR%%/plug-ins/vocalremover.ny
%%DATADIR%%/plug-ins/vocoder.ny
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
share/icons/hicolor/16x16/apps/audacity.png
share/icons/hicolor/22x22/apps/audacity.png
share/icons/hicolor/24x24/apps/audacity.png
@@ -114,6 +116,7 @@ share/locale/sl/LC_MESSAGES/audacity.mo
share/locale/sr_RS/LC_MESSAGES/audacity.mo
share/locale/sr_RS@latin/LC_MESSAGES/audacity.mo
share/locale/sv/LC_MESSAGES/audacity.mo
+share/locale/ta/LC_MESSAGES/audacity.mo
share/locale/tg/LC_MESSAGES/audacity.mo
share/locale/tr/LC_MESSAGES/audacity.mo
share/locale/uk/LC_MESSAGES/audacity.mo