aboutsummaryrefslogtreecommitdiff
path: root/audio/audex
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2013-10-09 06:55:59 +0000
committerJason E. Hale <jhale@FreeBSD.org>2013-10-09 06:55:59 +0000
commit3b40187e416f1403c1deb5f2ffe4ef3d691c95dc (patch)
tree5d83c01a6ec85a71d96302928e78c7628f8d7a22 /audio/audex
parentfccb51504076c4ba495961dd9984a211543b397f (diff)
downloadports-3b40187e416f1403c1deb5f2ffe4ef3d691c95dc.tar.gz
ports-3b40187e416f1403c1deb5f2ffe4ef3d691c95dc.zip
Notes
Diffstat (limited to 'audio/audex')
-rw-r--r--audio/audex/Makefile38
1 files changed, 10 insertions, 28 deletions
diff --git a/audio/audex/Makefile b/audio/audex/Makefile
index 6e9c475c8873..aff78cc3f7f1 100644
--- a/audio/audex/Makefile
+++ b/audio/audex/Makefile
@@ -10,10 +10,9 @@ COMMENT= KDE4 audio CD ripping utility
LICENSE= GPLv3
-LIB_DEPENDS= cdda_paranoia:${PORTSDIR}/audio/cdparanoia
+LIB_DEPENDS= libcdda_paranoia.so:${PORTSDIR}/audio/cdparanoia
USE_XZ= yes
-NO_STAGE= yes
USES= cmake
USE_KDE4= automoc4 kdeprefix kdelibs libkcddb libkcompactdisc
USE_QT4= gui dbus network svg xml \
@@ -21,38 +20,21 @@ USE_QT4= gui dbus network svg xml \
OPTIONS_DEFINE= NLS EYED3 FAAC FLAC LAME VORBIS
OPTIONS_DEFAULT= FLAC VORBIS
+OPTIONS_SUB= yes
NO_OPTIONS_SORT= yes
-EYED3_DESC= Unicode MP3 tag support via audio/py-eyed3
-
-.include <bsd.port.options.mk>
+NLS_USES= gettext
+NLS_CMAKE_OFF= -DDISABLE_ALL_OPTIONAL_SUBDIRECTORIES=TRUE
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CMAKE_ARGS+= -DDISABLE_ALL_OPTIONAL_SUBDIRECTORIES=TRUE
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MEYED3}
-RUN_DEPENDS+= eyeD3:${PORTSDIR}/audio/py-eyed3
-.endif
+EYED3_DESC= Unicode MP3 tag support via audio/py-eyed3
+EYED3_RUN_DEPENDS= eyeD3:${PORTSDIR}/audio/py-eyed3
-.if ${PORT_OPTIONS:MFAAC}
-RUN_DEPENDS+= faac:${PORTSDIR}/audio/faac
-.endif
+FAAC_RUN_DEPENDS= faac:${PORTSDIR}/audio/faac
-.if ${PORT_OPTIONS:MFLAC}
-RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
-.endif
+FLAC_RUN_DEPENDS= flac:${PORTSDIR}/audio/flac
-.if ${PORT_OPTIONS:MLAME}
-RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
-.endif
+LAME_RUN_DEPENDS= lame:${PORTSDIR}/audio/lame
-.if ${PORT_OPTIONS:MVORBIS}
-RUN_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
-.endif
+VORBIS_RUN_DEPENDS= oggenc:${PORTSDIR}/audio/vorbis-tools
.include <bsd.port.mk>