aboutsummaryrefslogtreecommitdiff
path: root/audio/audex
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-04 15:36:28 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-04 15:36:28 +0000
commit9cf69eeb54519fdd8ff871d5ad6ea3a8a4bd204e (patch)
tree8b71277ef10961e56baf92eb8195e894a3de8821 /audio/audex
parent012a59bb0e3ab24a1d24255cdb531303dd9b7e2e (diff)
Notes
Diffstat (limited to 'audio/audex')
-rw-r--r--audio/audex/Makefile35
1 files changed, 18 insertions, 17 deletions
diff --git a/audio/audex/Makefile b/audio/audex/Makefile
index f1d3d5ed1a29..ad5c90c72dc6 100644
--- a/audio/audex/Makefile
+++ b/audio/audex/Makefile
@@ -2,37 +2,42 @@
PORTNAME= audex
DISTVERSION= 0.74b1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio kde
MASTER_SITES= http://kde.maniatek.com/${PORTNAME}/files/
MAINTAINER= jhale@FreeBSD.org
COMMENT= Audio CD ripping utility for KDE4
-LIB_DEPENDS= cdda_paranoia.0:${PORTSDIR}/audio/cdparanoia \
- kcddb.5:${PORTSDIR}/multimedia/kdemultimedia4
+LICENSE= GPLv3
+
+LIB_DEPENDS= cdda_paranoia:${PORTSDIR}/audio/cdparanoia
USE_XZ= yes
USE_CMAKE= yes
-USE_KDE4= automoc4 kdeprefix kdelibs
+USE_KDE4= automoc4 kdeprefix kdelibs libkcddb
USE_QT4= gui dbus network svg xml \
qmake_build moc_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
-LICENSE= GPLv3
+OPTIONS_DEFINE= NLS EYED3 FAAC FLAC LAME VORBIS
+OPTIONS_DEFAULT= FLAC VORBIS
+NO_OPTIONS_SORT= yes
-OPTIONS_DEFINE= FAAC FLAC LAME EYED3 OGG
-OPTIONS_DEFAULT= FLAC OGG
-EYED3_DESC= Unicode mp3 tags support
+EYED3_DESC= Unicode MP3 tag support via audio/py-eyed3
.include <bsd.port.options.mk>
-.if !${PORT_OPTIONS:MNLS}
-CMAKE_ARGS+= -DDISABLE_ALL_OPTIONAL_SUBDIRECTORIES=TRUE
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CMAKE_ARGS+= -DDISABLE_ALL_OPTIONAL_SUBDIRECTORIES=TRUE
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MEYED3}
+RUN_DEPENDS+= eyeD3:${PORTSDIR}/audio/py-eyed3
.endif
.if ${PORT_OPTIONS:MFAAC}
@@ -47,11 +52,7 @@ RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
.endif
-.if ${PORT_OPTIONS:MEYED3}
-RUN_DEPENDS+= eyeD3:${PORTSDIR}/audio/py-eyed3
-.endif
-
-.if ${PORT_OPTIONS:MOGG}
+.if ${PORT_OPTIONS:MVORBIS}
RUN_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
.endif