aboutsummaryrefslogtreecommitdiff
path: root/audio/autocd/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2003-07-24 21:12:42 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2003-07-24 21:12:42 +0000
commitbbdf8aff2b549d7b11c74d8dd0d1bd5e5c50d44e (patch)
treeaf4fd49c0ce2ed980185087b130238362f59475e /audio/autocd/Makefile
parent965932ea5656184b21fd0b9398daf76e2de29ffd (diff)
downloadports-bbdf8aff2b549d7b11c74d8dd0d1bd5e5c50d44e.tar.gz
ports-bbdf8aff2b549d7b11c74d8dd0d1bd5e5c50d44e.zip
Notes
Diffstat (limited to 'audio/autocd/Makefile')
-rw-r--r--audio/autocd/Makefile27
1 files changed, 13 insertions, 14 deletions
diff --git a/audio/autocd/Makefile b/audio/autocd/Makefile
index e83450f135d1..40eb0a313490 100644
--- a/audio/autocd/Makefile
+++ b/audio/autocd/Makefile
@@ -6,30 +6,29 @@
#
PORTNAME= autocd
-PORTVERSION= 3.01.02a
+PORTVERSION= 3.02.03a
CATEGORIES= audio sysutils
MASTER_SITES= ftp://kot.spb.ru/pub/src/projects/autocd/
MAINTAINER= KOT@MATPOCKuH.Ru
COMMENT= Compact disc control utility
-USE_REINPLACE= yes
-MAN1= autocd.1 cdctl.1
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+MAN1= cdctl.1 acdplay.1
+MAN8= autocd.8
+MLINKS= cdctl.1 eject.1 cdctl.1 pause.1
-post-patch:
-.for file in Makefile
- @${REINPLACE_CMD} -e \
- 's|/usr/local|${PREFIX}|g ; \
- s|CFLAGS=-Wall -O2 -pipe|CFLAGS?=${CFLAGS}|g' \
- ${WRKSRC}/${file}
-.endfor
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400010
+LIB_DEPENDS= ncurses.5:${PORTSDIR}/devel/ncurses
+.endif
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
-.for i in README.rus.html
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${WRKSRC}/README.rus.html ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>