aboutsummaryrefslogtreecommitdiff
path: root/audio/autocd/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-06-04 08:07:24 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-06-04 08:07:24 +0000
commit99cf3a43a563a66b225a78653d3c5f962a58c036 (patch)
tree549dc6160946f3ac3579a52d37067830811ed6bd /audio/autocd/Makefile
parentffde7be3754a9d13eab8bd4a6849d9998e4cdce2 (diff)
downloadports-99cf3a43a563a66b225a78653d3c5f962a58c036.tar.gz
ports-99cf3a43a563a66b225a78653d3c5f962a58c036.zip
Notes
Diffstat (limited to 'audio/autocd/Makefile')
-rw-r--r--audio/autocd/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/audio/autocd/Makefile b/audio/autocd/Makefile
index b8dee1779048..e83450f135d1 100644
--- a/audio/autocd/Makefile
+++ b/audio/autocd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= autocd
-PORTVERSION= 3.00.02a
+PORTVERSION= 3.01.02a
CATEGORIES= audio sysutils
MASTER_SITES= ftp://kot.spb.ru/pub/src/projects/autocd/
@@ -14,10 +14,22 @@ MAINTAINER= KOT@MATPOCKuH.Ru
COMMENT= Compact disc control utility
USE_REINPLACE= yes
+MAN1= autocd.1 cdctl.1
post-patch:
- @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/Makefile
+.for file in Makefile
+ @${REINPLACE_CMD} -e \
+ 's|/usr/local|${PREFIX}|g ; \
+ s|CFLAGS=-Wall -O2 -pipe|CFLAGS?=${CFLAGS}|g' \
+ ${WRKSRC}/${file}
+.endfor
-MAN1= autocd.1 cdctl.1
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README.rus.html
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>