aboutsummaryrefslogtreecommitdiff
path: root/audio/beast/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-06-24 15:41:52 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-06-24 15:41:52 +0000
commit4cf32c89e78f8bb92141b79eec905d3b802f1a1e (patch)
tree8251f4d5bdacf58e68e0a8ecbd5e64b3e5837b5d /audio/beast/Makefile
parenta357bfdebd86bb6d5c8418a85dc7a29efaf27185 (diff)
downloadports-4cf32c89e78f8bb92141b79eec905d3b802f1a1e.tar.gz
ports-4cf32c89e78f8bb92141b79eec905d3b802f1a1e.zip
Notes
Diffstat (limited to 'audio/beast/Makefile')
-rw-r--r--audio/beast/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/audio/beast/Makefile b/audio/beast/Makefile
new file mode 100644
index 000000000000..411e31d82436
--- /dev/null
+++ b/audio/beast/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: BEAST
+# Date created: 23 Jun 2004
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= beast
+PORTVERSION= 0.6.1
+CATEGORIES= audio
+MASTER_SITES= ftp://beast.gtk.org/pub/beast/v0.6/ \
+ http://beast.gtk.org/beast-ftp/v0.6/
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= A powerful music composition and modular synthesis application
+
+LIB_DEPENDS= vorbisfile:${PORTSDIR}/audio/libvorbis \
+ mad:${PORTSDIR}/audio/libmad \
+ guile:${PORTSDIR}/lang/guile
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GCC= 3.3
+USE_REINPLACE= yes
+USE_GNOME= gnomehack gnomeprefix intlhack libgnomecanvas
+USE_LIBTOOL_VER= 15
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --disable-debug \
+ --enable-osspcm=/dev/dsp \
+ --enable-ossmidi=/dev/midi
+
+MAN1= beast.1 bsesh.1 sfidl.1
+MAN3= beast-gxk.3 bse-procs.3 bse-structs.3 bse.3 sfi.3
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's|(bseladspapath=)\$${libdir}/ladspa|\1"${LOCALBASE}/lib/ladspa"|' \
+ -e 's/(FLAGS) (-g.*|-pipe|-O2|-f.*)"/\1"/g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|-DG_DISABLE_DEPRECATED||g' \
+ ${WRKSRC}/bse/Makefile.in \
+ ${WRKSRC}/bse/zintern/Makefile.in
+
+.include <bsd.port.mk>