aboutsummaryrefslogtreecommitdiff
path: root/audio/beast/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-03-21 09:58:46 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-03-21 09:58:46 +0000
commit8de883fdc2d9161bee322fc500e664e108084d66 (patch)
treeed37459eb8aaf2d63e468ef955e32a8acb2a31c8 /audio/beast/Makefile
parent0451982200b026907a5523df7bf31233acdae5de (diff)
downloadports-8de883fdc2d9161bee322fc500e664e108084d66.tar.gz
ports-8de883fdc2d9161bee322fc500e664e108084d66.zip
Notes
Diffstat (limited to 'audio/beast/Makefile')
-rw-r--r--audio/beast/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/audio/beast/Makefile b/audio/beast/Makefile
index 9892c9b53313..1601f2b3362f 100644
--- a/audio/beast/Makefile
+++ b/audio/beast/Makefile
@@ -31,6 +31,15 @@ CONFIGURE_ARGS= --disable-debug \
--enable-ossmidi=/dev/midi
MAKE_JOBS_UNSAFE= yes
+.include <bsd.port.pre.mk>
+
+# Assume i386 and amd64 support SSE
+.if ${ARCH} == "i386" || ${ARCH} == "amd64"
+PLIST_SUB+= SSE=""
+.else
+PLIST_SUB+= SSE="@comment "
+.endif
+
PLIST_SUB+= PORTVERSION=${PORTVERSION}
MAN1= beast.1 bsescm.1 bsewavetool.1 sfidl.1
@@ -45,4 +54,4 @@ post-patch:
${WRKSRC}/bse/Makefile.in \
${WRKSRC}/bse/zintern/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>