aboutsummaryrefslogtreecommitdiff
path: root/audio/beast
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-04-08 14:20:45 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-04-08 14:20:45 +0000
commitca814504cc3ff6cc3c0c44f93d5e137d5e2987ea (patch)
treebd38c2fe400e463eca561cdef5aeda5aeabac070 /audio/beast
parentaf5c26d2e56c4d336ec15f83b99265205d124766 (diff)
Notes
Diffstat (limited to 'audio/beast')
-rw-r--r--audio/beast/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/audio/beast/Makefile b/audio/beast/Makefile
index 1601f2b3362f..9423b4404ead 100644
--- a/audio/beast/Makefile
+++ b/audio/beast/Makefile
@@ -24,8 +24,8 @@ USE_BZIP2= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GETTEXT= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DENODATA=255" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include -DENODATA=255
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-debug \
--enable-osspcm=/dev/dsp \
--enable-ossmidi=/dev/midi
@@ -33,8 +33,7 @@ MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
-# Assume i386 and amd64 support SSE
-.if ${ARCH} == "i386" || ${ARCH} == "amd64"
+.if ${MACHINE_CPU:Msse}
PLIST_SUB+= SSE=""
.else
PLIST_SUB+= SSE="@comment "