aboutsummaryrefslogtreecommitdiff
path: root/audio/blop/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-21 06:01:33 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-21 06:01:33 +0000
commitcd734abda273910f486146824cf9febedfe87f6a (patch)
treecb434c8d62c85b685e9cf72c8aa0a6b277ef9655 /audio/blop/Makefile
parent91942e3d7d0bbade2bbd31b592df5f4b847f2667 (diff)
downloadports-cd734abda273910f486146824cf9febedfe87f6a.tar.gz
ports-cd734abda273910f486146824cf9febedfe87f6a.zip
Notes
Diffstat (limited to 'audio/blop/Makefile')
-rw-r--r--audio/blop/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/blop/Makefile b/audio/blop/Makefile
new file mode 100644
index 000000000000..006dfe539c5b
--- /dev/null
+++ b/audio/blop/Makefile
@@ -0,0 +1,30 @@
+# New ports collection Makefile for: blop
+# Date created: 15 May 2002
+# Whom: Tilman Linneweh <freebsdports@arved.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= blop
+PORTVERSION= 0.1.0
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= freebsdports@arved.de
+
+BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+PLUGINS= sawtooth.so \
+ square.so \
+ pulse.so \
+ triangle.so
+PLUGIN_DIR= ${LOCALBASE}/lib/ladspa
+
+do-install:
+.for file in ${PLUGINS}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${PLUGIN_DIR}
+.endfor
+
+.include <bsd.port.mk>