aboutsummaryrefslogtreecommitdiff
path: root/audio/blop/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-30 07:22:00 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-30 07:22:00 +0000
commitcedda53ff2d0aa26d70aab7b580f51ab0916ac31 (patch)
tree57109d63599723351f1c76510f89eb8d5c5f908f /audio/blop/Makefile
parente555c4c0d3ca84ae4d8c72dede852292e039f0b5 (diff)
downloadports-cedda53ff2d0aa26d70aab7b580f51ab0916ac31.tar.gz
ports-cedda53ff2d0aa26d70aab7b580f51ab0916ac31.zip
Notes
Diffstat (limited to 'audio/blop/Makefile')
-rw-r--r--audio/blop/Makefile26
1 files changed, 19 insertions, 7 deletions
diff --git a/audio/blop/Makefile b/audio/blop/Makefile
index d5a3b1e939f1..f261cdaf87cc 100644
--- a/audio/blop/Makefile
+++ b/audio/blop/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= blop
-PORTVERSION= 0.2.7
-PORTREVISION= 1
+PORTVERSION= 0.2.8
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,14 +20,27 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-ladspa-prefix="${LOCALBASE}"
+OPTIONS= NLS "Native language support" on
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|\$$(LIBS)|\$$(LIBS) \$$(LDFLAGS)|g ; \
+ 's|$$(LIBS)$$|$$(LIBS) $$(LDFLAGS)|g ; \
s|-lc | |g'
-pre-build:
- cd ${WRKSRC}/src; ${GMAKE} sawtooth_data.h square_data.h parabola_data.h
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>