aboutsummaryrefslogtreecommitdiff
path: root/audio/bmp-faad
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-10-14 00:18:12 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-10-14 00:18:12 +0000
commit37f2451c9a8eaf957979686c139d3463d64080c9 (patch)
treeace2ba20e0b23c425daa275042d117e765b88c8b /audio/bmp-faad
parent0dd1fb9151f586a947fc1e6ffaa8035d0aa5c599 (diff)
downloadports-37f2451c9a8eaf957979686c139d3463d64080c9.tar.gz
ports-37f2451c9a8eaf957979686c139d3463d64080c9.zip
[NEW PORT] audio/bmp-faad2: Beep Media Player (BMP) plugin for faad
FAAD 2 - Freeware Advanced Audio Decoder 2 - BMP plugin PR: ports/71304 Submitted by: Michael Johnson <ahze@ahze.net>
Notes
Notes: svn path=/head/; revision=119343
Diffstat (limited to 'audio/bmp-faad')
-rw-r--r--audio/bmp-faad/Makefile70
-rw-r--r--audio/bmp-faad/files/patch-configure13
-rw-r--r--audio/bmp-faad/files/patch-xmms-Makefile.am21
3 files changed, 104 insertions, 0 deletions
diff --git a/audio/bmp-faad/Makefile b/audio/bmp-faad/Makefile
new file mode 100644
index 000000000000..12596aa8413d
--- /dev/null
+++ b/audio/bmp-faad/Makefile
@@ -0,0 +1,70 @@
+# New ports collection makefile for: bmp-faad
+# Date created: 2 Sep, 2004
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= faad2
+PORTVERSION= 2.0
+PORTREVISION= 1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= faac
+PKGNAMEPREFIX= bmp-
+
+MAINTAINER= ahze@ahze.net
+COMMENT= Beep Media Player (BMP) plugin for faad
+
+LIB_DEPENDS= id3-3.8.3:${PORTSDIR}/audio/id3lib \
+ faad.0:${PORTSDIR}/audio/faad \
+ beep.2:${PORTSDIR}/multimedia/beep-media-player
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_AUTOMAKE_VER= 15
+USE_AUTOCONF_VER= 253
+USE_AUTOHEADER_VER= 253
+USE_INC_LIBTOOL_VER= 13
+AUTOMAKE_ARGS= --add-missing
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+USE_REINPLACE= yes
+
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-xmms --with-mp4v2
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+
+DESCR= ${PORTSDIR}/audio/faad/pkg-descr
+MD5_FILE= ${PORTSDIR}/audio/faad/distinfo
+PLIST_FILES= lib/bmp/Input/libmp4.so
+
+.include <bsd.port.pre.mk>
+
+pre-patch: build-depends
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/plugins/xmms/src/Makefile.am
+# make sure everything is prepared prior to configure stage
+# pre-configure will not work since *AUTO* tools happen in-between
+ @cd ${WRKSRC}; ${ACLOCAL} -I ${ACLOCAL_DIR} -I .; \
+ ${SETENV} ${SCRIPTS_ENV} ${LIBTOOLIZE} --automake
+ @${REINPLACE_CMD} -e 's|$$lt_target|$$host|' \
+ ${WRKSRC}/aclocal.m4
+# CFLAGS safeness
+ @${FIND} ${WRKSRC} -type f -name Makefile.am | \
+ ${XARGS} -n 5 -x \
+ ${REINPLACE_CMD} -e \
+ 's|-O2|${CFLAGS}|'
+
+do-build:
+ @cd ${WRKSRC}/libfaad && ${MAKE}
+ @cd ${WRKSRC}/common/mp4v2 && ${MAKE}
+ @cd ${WRKSRC}/plugins/xmms/src && ${MAKE}
+
+do-install:
+ @cd ${WRKSRC}/plugins/xmms/src && ${MAKE} install
+
+.include <bsd.port.post.mk>
diff --git a/audio/bmp-faad/files/patch-configure b/audio/bmp-faad/files/patch-configure
new file mode 100644
index 000000000000..071afa17bc84
--- /dev/null
+++ b/audio/bmp-faad/files/patch-configure
@@ -0,0 +1,13 @@
+--- configure.in.orig Thu Sep 2 13:17:44 2004
++++ configure.in Thu Sep 2 13:19:45 2004
+@@ -88,10 +88,6 @@
+ fi
+
+ if test x$WITHXMMS = xyes; then
+- AC_CHECK_PROGS(XMMS_CONFIG, xmms-config,"not_found")
+- if test "$XMMS_CONFIG" = "not_found"; then
+- AC_MSG_ERROR("*** xmms-config not found - xmms plugin can't be build")
+- fi
+ AC_CHECK_HEADER(pthread.h,,
+ AC_MSG_ERROR(*** pthread headers support not installed or not found))
+ AC_CHECK_HEADER(id3.h,,
diff --git a/audio/bmp-faad/files/patch-xmms-Makefile.am b/audio/bmp-faad/files/patch-xmms-Makefile.am
new file mode 100644
index 000000000000..8fc045eb0f16
--- /dev/null
+++ b/audio/bmp-faad/files/patch-xmms-Makefile.am
@@ -0,0 +1,21 @@
+--- plugins/xmms/src/Makefile.am.orig Fri Feb 6 11:05:07 2004
++++ plugins/xmms/src/Makefile.am Thu Sep 2 13:36:46 2004
+@@ -1,13 +1,13 @@
+-libdir = `$(XMMS_CONFIG) --input-plugin-dir`
++libdir = `pkg-config --variable=input_plugin_dir bmp`
+ lib_LTLIBRARIES = libmp4.la
+
+-libmp4_la_CFLAGS = `$(XMMS_CONFIG) --cflags` -Wall \
+- `$(GTK_CONFIG) --cflags` -DHAVE_GLIB_H=1 \
++libmp4_la_CFLAGS = `pkg-config gtk+-2.0 --cflags` -Wall \
++ `pkg-config bmp --cflags` \
+ -I$(top_srcdir)/include -I$(top_srcdir)/common/mp4v2
+
+ libmp4_la_LIBADD = $(top_builddir)/libfaad/libfaad.la \
+ $(top_builddir)/common/mp4v2/libmp4v2.la
+
+-libmp4_la_LDFLAGS = -module -avoid-version `$(XMMS_CONFIG) --libs` \
+- `$(GTK_CONFIG) --libs` -lpthread -lstdc++
++libmp4_la_LDFLAGS = -module -avoid-version `pkg-config bmp --libs` \
++ `pkg-config gtk+-2.0 --libs` -lpthread -lstdc++
+ libmp4_la_SOURCES = libmp4.c mp4_utils.c aac_utils.c