aboutsummaryrefslogtreecommitdiff
path: root/audio/bmp-mac/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-04-30 19:48:21 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-04-30 19:48:21 +0000
commit753d9be59faf1ced71cc0279fe33608636fd2d8b (patch)
tree018a9b8164d41d644e09e2ab3d5a48c10fe04563 /audio/bmp-mac/Makefile
parent5a3ae6c1ce86635eca562ba2f7cd27a642c5ccdf (diff)
downloadports-753d9be59faf1ced71cc0279fe33608636fd2d8b.tar.gz
ports-753d9be59faf1ced71cc0279fe33608636fd2d8b.zip
Notes
Diffstat (limited to 'audio/bmp-mac/Makefile')
-rw-r--r--audio/bmp-mac/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/audio/bmp-mac/Makefile b/audio/bmp-mac/Makefile
new file mode 100644
index 000000000000..063c5460c78d
--- /dev/null
+++ b/audio/bmp-mac/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: bmp-mac
+# Date Created: 17 January 2006
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= mac
+PORTVERSION= 0.1.1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= mac-port
+PKGNAMEPREFIX= bmp-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= Monkey's Audio Codec non-win32 port
+
+LIB_DEPENDS= beep.2:${PORTSDIR}/multimedia/beep-media-player \
+ mac.2:${PORTSDIR}/audio/mac
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
+USE_AUTOTOOLS= autoconf:259
+CPPFLAGS+= "-I${LOCALBASE}/include"
+PLUGDIR= lib/bmp/Input
+PLUGFILE= lib${PKGNAMEPREFIX}${PORTNAME}.so
+PLIST_FILES= ${PLUGDIR}/${PLUGFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/.libs/${PLUGFILE} ${PREFIX}/${PLUGDIR}/
+
+.include <bsd.port.mk>