aboutsummaryrefslogtreecommitdiff
path: root/audio/boodler/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-31 00:45:42 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-31 00:45:42 +0000
commit401acbd54f780eb446ff406f7246f03305c1a8dc (patch)
tree1341b09ff27315a30750360fe1bcb652cf57380c /audio/boodler/Makefile
parentbfded1e9e5d6972a29774846aeadeb2d587f1ffd (diff)
downloadports-401acbd54f780eb446ff406f7246f03305c1a8dc.tar.gz
ports-401acbd54f780eb446ff406f7246f03305c1a8dc.zip
Notes
Diffstat (limited to 'audio/boodler/Makefile')
-rw-r--r--audio/boodler/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/audio/boodler/Makefile b/audio/boodler/Makefile
new file mode 100644
index 000000000000..776fc338c024
--- /dev/null
+++ b/audio/boodler/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: boodler
+# Date created: 2003/12/30
+# Whom: Dan Pelleg <daniel+boodler@pelleg.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= boodler
+PORTVERSION= 1.5.3
+CATEGORIES= audio
+MASTER_SITES= http://www.eblong.com/zarf/boodler/ \
+ http://s89813419.onlinehome.us/
+DISTFILES= boodler-153.tar.gz boodler-snd-021902.tar.gz
+
+MAINTAINER= daniel+boodler@pelleg.org
+COMMENT= A programmable soundscape tool
+
+RESTRICTED= no commercial use
+RESTRICTED_FILES= boodler-snd-021902.tar.gz
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_PYTHON= yes
+DRIVER= oss
+WRKSRC= ${WRKDIR}/${PORTNAME}
+BHOME= ${PREFIX}/share/boodler
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS= %%PREFIX%%/share/boodler/boodle
+
+.if defined(DRIVER_FILE)
+DRIVER= FILE
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e "s|^booroot=.*|booroot=${PREFIX}/share/boodler|" ${WRKSRC}/wrapper/boodler
+ @${RMDIR} ${WRKDIR}/boodler-snd/string
+
+do-build:
+ (cd ${WRKSRC} && ${PYTHON_CMD} configure.py --driver ${DRIVER} && make)
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/effects ${WRKSRC}/boodle/
+
+do-install:
+ @${ECHO_MSG} "Installing files"
+ @${INSTALL_SCRIPT} ${WRKSRC}/wrapper/boodler ${PREFIX}/bin/
+ @${MKDIR} ${BHOME}
+ @${INSTALL_SCRIPT} ${WRKSRC}/boodler.py ${BHOME}
+ @${MKDIR} ${BHOME}/boodle/ ${BHOME}/effects/ ${BHOME}/boodler-snd/
+ @${CHMOD} -R u+w,a+r,og-w ${WRKDIR}/boodler-snd
+ @${FIND} ${WRKDIR}/boodler-snd -type d -print0 | ${XARGS} -0 ${CHMOD} 755
+ @cd ${WRKDIR} && ${CP} -pPR boodler/boodle boodler/effects boodler-snd ${BHOME}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>