aboutsummaryrefslogtreecommitdiff
path: root/audio/boodler
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-19 14:09:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-19 14:09:18 +0000
commit4a2a780340ea5aeef03830f395d9b730ab02121d (patch)
tree254f0153598f39bc87e124a3952debdbaa241763 /audio/boodler
parent833945f372e743d34daa694990ca250b1c54fff8 (diff)
downloadports-4a2a780340ea5aeef03830f395d9b730ab02121d.tar.gz
ports-4a2a780340ea5aeef03830f395d9b730ab02121d.zip
- Refine support for sound drivers
PR: ports/81212 Submitted by: Dan Pelleg <daniel+boodler@pelleg.org> (maintainer)
Notes
Notes: svn path=/head/; revision=135613
Diffstat (limited to 'audio/boodler')
-rw-r--r--audio/boodler/Makefile31
1 files changed, 26 insertions, 5 deletions
diff --git a/audio/boodler/Makefile b/audio/boodler/Makefile
index 8a929521801f..61286058dd70 100644
--- a/audio/boodler/Makefile
+++ b/audio/boodler/Makefile
@@ -21,19 +21,40 @@ RESTRICTED_FILES= boodler-snd-021902.tar.gz
USE_GMAKE= yes
USE_REINPLACE= yes
USE_PYTHON= yes
-DRIVER= oss
+DRIVER?= oss
WRKSRC= ${WRKDIR}/${PORTNAME}
BHOME= ${PREFIX}/share/boodler
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/share/boodler/boodle
-.if defined(DRIVER_FILE)
-DRIVER= FILE
+pre-everything::
+ @${ECHO} ""
+ @${ECHO} "The following build options are available for Boodler:"
+ @${ECHO} ""
+ @${ECHO} " DRIVER=OSS Configure to use /dev/dsp."
+ @${ECHO} " DRIVER=ESD Configure to use EsounD."
+ @${ECHO} " DRIVER=FILE Configure to write raw PCM data to a file."
+ @${ECHO} ""
+ @${ECHO} "Boodler can only be configured to use one of these"
+ @${ECHO} "interfaces. The default is to use OSS."
+ @${ECHO} ""
+
+.if ${DRIVER:L} == "oss"
+# Probably nothing here...
+.endif
+
+.if ${DRIVER:L} == "esd"
+LIB_DEPENDS+= esd.2:${PORTSDIR}/audio/esound
+PKGNAMESUFFIX= -esd
+.endif
+
+.if ${DRIVER:L} == "file"
+PKGNAMESUFFIX= -file
.endif
.include <bsd.port.pre.mk>
-.if ${MACHINE_ARCH} == "amd64" || ${MACHINE_ARCH} == "ia64"
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
PIC= --PIC
.endif
@@ -42,7 +63,7 @@ post-patch:
@${RMDIR} ${WRKDIR}/boodler-snd/string
do-build:
- (cd ${WRKSRC} && ${PYTHON_CMD} configure.py --driver ${DRIVER} ${PIC} && make)
+ (cd ${WRKSRC} && ${PYTHON_CMD} configure.py --driver ${DRIVER:L} ${PIC} --include ${PREFIX}/include --lib ${PREFIX}/lib && make)
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/effects ${WRKSRC}/boodle/
do-install: