aboutsummaryrefslogtreecommitdiff
path: root/audio/calf
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2015-06-20 09:24:26 +0000
committerWen Heping <wen@FreeBSD.org>2015-06-20 09:24:26 +0000
commitaa6b0e6396404e53bfb1b1cb11046881dee42557 (patch)
tree965ab9754dd8198d0a2dafef9053f5a8b98c8735 /audio/calf
parent63867ef5ca23b815d7f901914c4c4d1b3b17244e (diff)
downloadports-aa6b0e6396404e53bfb1b1cb11046881dee42557.tar.gz
ports-aa6b0e6396404e53bfb1b1cb11046881dee42557.zip
Notes
Diffstat (limited to 'audio/calf')
-rw-r--r--audio/calf/Makefile36
-rw-r--r--audio/calf/distinfo4
-rw-r--r--audio/calf/files/patch-src__calf__audio_fx.h10
-rw-r--r--audio/calf/files/patch-src__calf__osctl.h13
-rw-r--r--audio/calf/pkg-plist305
5 files changed, 216 insertions, 152 deletions
diff --git a/audio/calf/Makefile b/audio/calf/Makefile
index dcdfcaf5c813..caee641a13e3 100644
--- a/audio/calf/Makefile
+++ b/audio/calf/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= calf
-PORTVERSION= 0.0.19
-PORTREVISION= 4
+PORTVERSION= 0.0.60
CATEGORIES= audio
MASTER_SITES= SF
@@ -19,16 +18,16 @@ LIB_DEPENDS= libfluidsynth.so:${PORTSDIR}/audio/fluidsynth \
libfftw3f.so:${PORTSDIR}/math/fftw3-float \
libexpat.so:${PORTSDIR}/textproc/expat2
-USES= gmake pkgconfig libtool
+USES= compiler:c++11-lib gmake libtool pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
-INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
+INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= LASH LV2 DOCS
+OPTIONS_DEFINE= DOCS LASH LV2
OPTIONS_DEFAULT= LASH LV2
OPTIONS_SUB= yes
@@ -39,25 +38,23 @@ LV2_BUILD_DEPENDS= lv2core>0:${PORTSDIR}/audio/lv2core
LV2_RUN_DEPENDS= lv2core>0:${PORTSDIR}/audio/lv2core
LV2_CONFIGURE_WITH= lv2
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc
+CXXFLAGS+= -fno-inline -finline-functions-called-once
+.endif
post-patch:
@${FIND} ${BUILD_WRKSRC} -name '*.cpp' | ${XARGS} ${REINPLACE_CMD} -e \
- 's|<malloc.h>|<stdlib.h>|'
+ 's|<malloc.h>|<cstdlib>|'
@${REINPLACE_CMD} -e \
- '/CXXFLAGS/s|-O3|| ; \
- /CXXFLAGS/s|-finline-functions-called-once||' \
+ 's|"GNU strip"|"strip"| ; \
+ /CXXFLAGS/s|-O3 .* -Wall|-Wall|' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e \
'/AM_CXXFLAGS/s|-finline-limit=80|| ; \
/calf.so/s|$$(pkglibdir)|../../calf|' \
${WRKSRC}/src/Makefile.in
- @${REINPLACE_CMD} -e \
- 's|src\.size();|src->size();|' \
- ${WRKSRC}/src/calf/buffer.h
- @${REINPLACE_CMD} -e \
- 's|data\[(1<<IntBits)+1\]|data[]|' \
- ${WRKSRC}/src/calf/fixed_point.h
pre-build:
.if ${PORT_OPTIONS:MLV2}
@@ -65,17 +62,14 @@ pre-build:
@(cd ${WRKSRC} && ${PAX} -rw . ${WRKDIR}/calfmakerdf)
@${REINPLACE_CMD} -e 's|\(PKGLIBDIR\).*|\1 "${STAGEDIR}${DATADIR}"|' \
${WRKDIR}/calfmakerdf/config.h
- @(cd ${WRKDIR}/calfmakerdf/src && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
- ${MAKE_FLAGS} ${MAKEFILE} -j${MAKE_JOBS_NUMBER} ${MAKE_ARGS} \
- calfmakerdf)
+ @(cd ${WRKDIR}/calfmakerdf/src && ${DO_MAKE_BUILD} calfmakerdf)
.endif
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/calf/calf.so \
- ${STAGEDIR}${PREFIX}/lib/lv2/calf.lv2/calflv2gui.so
.if ${PORT_OPTIONS:MLV2}
@(cd ${WRKDIR}/calfmakerdf/src && ./calfmakerdf -m ttl \
-p ${STAGEDIR}${PREFIX}/lib/lv2/calf.lv2)
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/calf.lv2/calflv2gui.so
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/calf/distinfo b/audio/calf/distinfo
index e33553eec6b5..b5a059ffee50 100644
--- a/audio/calf/distinfo
+++ b/audio/calf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (calf-0.0.19.tar.gz) = 1106e7e27bcd18d47fc58c952a4dbf6c7a763272e13b2b94cee6f1b2fb922cec
-SIZE (calf-0.0.19.tar.gz) = 14960133
+SHA256 (calf-0.0.60.tar.gz) = a9e7156740b71b31b5c81730b57c56b9ed03bf3eff98938b3a416c09c0e32e05
+SIZE (calf-0.0.60.tar.gz) = 5881741
diff --git a/audio/calf/files/patch-src__calf__audio_fx.h b/audio/calf/files/patch-src__calf__audio_fx.h
new file mode 100644
index 000000000000..a77d45154949
--- /dev/null
+++ b/audio/calf/files/patch-src__calf__audio_fx.h
@@ -0,0 +1,10 @@
+--- src/calf/audio_fx.h.orig
++++ src/calf/audio_fx.h
+@@ -27,6 +27,7 @@
+ #include "inertia.h"
+ #include "giface.h"
+ #include "onepole.h"
++#include <sys/types.h>
+ #include <complex>
+
+ namespace calf_plugins {
diff --git a/audio/calf/files/patch-src__calf__osctl.h b/audio/calf/files/patch-src__calf__osctl.h
new file mode 100644
index 000000000000..73148947f48d
--- /dev/null
+++ b/audio/calf/files/patch-src__calf__osctl.h
@@ -0,0 +1,13 @@
+--- src/calf/osctl.h.orig
++++ src/calf/osctl.h
+@@ -26,7 +26,10 @@
+ #include <vector>
+ #include <string.h>
+ #include <errno.h>
++#include <sys/types.h>
++#include <sys/socket.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <netdb.h>
+ #include <iostream>
+
diff --git a/audio/calf/pkg-plist b/audio/calf/pkg-plist
index 920d364979cd..725834a37603 100644
--- a/audio/calf/pkg-plist
+++ b/audio/calf/pkg-plist
@@ -3,9 +3,14 @@ lib/calf/calf.a
lib/calf/calf.so
%%LV2%%lib/lv2/calf.lv2/Analyzer.ttl
%%LV2%%lib/lv2/calf.lv2/BassEnhancer.ttl
+%%LV2%%lib/lv2/calf.lv2/CompensationDelay.ttl
%%LV2%%lib/lv2/calf.lv2/Compressor.ttl
+%%LV2%%lib/lv2/calf.lv2/Crusher.ttl
%%LV2%%lib/lv2/calf.lv2/Deesser.ttl
+%%LV2%%lib/lv2/calf.lv2/Emphasis.ttl
+%%LV2%%lib/lv2/calf.lv2/EnvelopeFilter.ttl
%%LV2%%lib/lv2/calf.lv2/Equalizer12Band.ttl
+%%LV2%%lib/lv2/calf.lv2/Equalizer30Band.ttl
%%LV2%%lib/lv2/calf.lv2/Equalizer5Band.ttl
%%LV2%%lib/lv2/calf.lv2/Equalizer8Band.ttl
%%LV2%%lib/lv2/calf.lv2/Exciter.ttl
@@ -13,28 +18,40 @@ lib/calf/calf.so
%%LV2%%lib/lv2/calf.lv2/Filterclavier.ttl
%%LV2%%lib/lv2/calf.lv2/Flanger.ttl
%%LV2%%lib/lv2/calf.lv2/Gate.ttl
+%%LV2%%lib/lv2/calf.lv2/HaasEnhancer.ttl
%%LV2%%lib/lv2/calf.lv2/Limiter.ttl
+%%LV2%%lib/lv2/calf.lv2/MonoCompressor.ttl
%%LV2%%lib/lv2/calf.lv2/MonoInput.ttl
%%LV2%%lib/lv2/calf.lv2/Monosynth.ttl
%%LV2%%lib/lv2/calf.lv2/MultiChorus.ttl
-%%LV2%%lib/lv2/calf.lv2/Multibandcompressor.ttl
-%%LV2%%lib/lv2/calf.lv2/Multibandgate.ttl
-%%LV2%%lib/lv2/calf.lv2/Multibandlimiter.ttl
+%%LV2%%lib/lv2/calf.lv2/MultibandCompressor.ttl
+%%LV2%%lib/lv2/calf.lv2/MultibandGate.ttl
+%%LV2%%lib/lv2/calf.lv2/MultibandLimiter.ttl
%%LV2%%lib/lv2/calf.lv2/Organ.ttl
%%LV2%%lib/lv2/calf.lv2/Phaser.ttl
%%LV2%%lib/lv2/calf.lv2/Pulsator.ttl
%%LV2%%lib/lv2/calf.lv2/Reverb.ttl
+%%LV2%%lib/lv2/calf.lv2/ReverseDelay.ttl
+%%LV2%%lib/lv2/calf.lv2/RingModulator.ttl
%%LV2%%lib/lv2/calf.lv2/RotarySpeaker.ttl
%%LV2%%lib/lv2/calf.lv2/Saturator.ttl
-%%LV2%%lib/lv2/calf.lv2/Sidechaincompressor.ttl
-%%LV2%%lib/lv2/calf.lv2/Sidechaingate.ttl
+%%LV2%%lib/lv2/calf.lv2/SidechainCompressor.ttl
+%%LV2%%lib/lv2/calf.lv2/SidechainGate.ttl
+%%LV2%%lib/lv2/calf.lv2/SidechainLimiter.ttl
%%LV2%%lib/lv2/calf.lv2/StereoTools.ttl
+%%LV2%%lib/lv2/calf.lv2/TapeSimulator.ttl
+%%LV2%%lib/lv2/calf.lv2/TransientDesigner.ttl
%%LV2%%lib/lv2/calf.lv2/VintageDelay.ttl
+%%LV2%%lib/lv2/calf.lv2/Vocoder.ttl
+%%LV2%%lib/lv2/calf.lv2/XOver2Band.ttl
+%%LV2%%lib/lv2/calf.lv2/XOver3Band.ttl
+%%LV2%%lib/lv2/calf.lv2/XOver4Band.ttl
%%LV2%%lib/lv2/calf.lv2/calf.so
%%LV2%%lib/lv2/calf.lv2/calflv2gui.so
%%LV2%%lib/lv2/calf.lv2/manifest.ttl
%%LV2%%lib/lv2/calf.lv2/presets-Filter.ttl
%%LV2%%lib/lv2/calf.lv2/presets-Flanger.ttl
+%%LV2%%lib/lv2/calf.lv2/presets-MonoCompressor.ttl
%%LV2%%lib/lv2/calf.lv2/presets-Monosynth.ttl
%%LV2%%lib/lv2/calf.lv2/presets-Organ.ttl
%%LV2%%lib/lv2/calf.lv2/presets-Reverb.ttl
@@ -42,47 +59,21 @@ man/man1/calfjackhost.1.gz
man/man7/calf.7.gz
share/applications/calf.desktop
%%DATADIR%%/background_black.png
-%%DATADIR%%/background_blue.png
%%DATADIR%%/background_dark.png
-%%DATADIR%%/background_fur.png
-%%DATADIR%%/background_fur_bw.png
-%%DATADIR%%/background_fur_white.png
-%%DATADIR%%/background_light_alu.png
-%%DATADIR%%/background_light_calf.png
-%%DATADIR%%/background_light_green.png
-%%DATADIR%%/background_light_metal.png
-%%DATADIR%%/blank.png
-%%DATADIR%%/button.png
-%%DATADIR%%/button_active.png
-%%DATADIR%%/button_default.png
-%%DATADIR%%/button_default_active.png
-%%DATADIR%%/button_default_prelight.png
-%%DATADIR%%/button_insens.png
-%%DATADIR%%/button_normal.png
-%%DATADIR%%/button_prelight.png
-%%DATADIR%%/calf-gui.xml
+%%DATADIR%%/background_light.png
%%DATADIR%%/calf.rc
-%%DATADIR%%/combo.png
-%%DATADIR%%/combo_active.png
+%%DATADIR%%/calf-gui.xml
%%DATADIR%%/combo_arrow.png
-%%DATADIR%%/combo_inactive.png
-%%DATADIR%%/entry.png
-%%DATADIR%%/entry_inactive.png
-%%DATADIR%%/frame.png
-%%DATADIR%%/frame_bottom_end.png
-%%DATADIR%%/frame_bottom_start.png
-%%DATADIR%%/frame_left_end.png
-%%DATADIR%%/frame_left_start.png
-%%DATADIR%%/frame_right_end.png
-%%DATADIR%%/frame_right_start.png
-%%DATADIR%%/frame_top_end.png
-%%DATADIR%%/frame_top_start.png
%%DATADIR%%/gui-analyzer.xml
%%DATADIR%%/gui-bassenhancer.xml
+%%DATADIR%%/gui-compdelay.xml
%%DATADIR%%/gui-compressor.xml
+%%DATADIR%%/gui-crusher.xml
%%DATADIR%%/gui-deesser.xml
-%%DATADIR%%/gui-enhancer.xml
+%%DATADIR%%/gui-emphasis.xml
+%%DATADIR%%/gui-envelopefilter.xml
%%DATADIR%%/gui-eq12.xml
+%%DATADIR%%/gui-eq30.xml
%%DATADIR%%/gui-eq5.xml
%%DATADIR%%/gui-eq8.xml
%%DATADIR%%/gui-exciter.xml
@@ -91,8 +82,10 @@ share/applications/calf.desktop
%%DATADIR%%/gui-flanger.xml
%%DATADIR%%/gui-fluidsynth.xml
%%DATADIR%%/gui-gate.xml
+%%DATADIR%%/gui-haasenhancer.xml
%%DATADIR%%/gui-limiter.xml
%%DATADIR%%/gui-mono.xml
+%%DATADIR%%/gui-monocompressor.xml
%%DATADIR%%/gui-monosynth.xml
%%DATADIR%%/gui-multibandcompressor.xml
%%DATADIR%%/gui-multibandgate.xml
@@ -102,50 +95,71 @@ share/applications/calf.desktop
%%DATADIR%%/gui-phaser.xml
%%DATADIR%%/gui-pulsator.xml
%%DATADIR%%/gui-reverb.xml
+%%DATADIR%%/gui-reversedelay.xml
+%%DATADIR%%/gui-ringmodulator.xml
%%DATADIR%%/gui-rotaryspeaker.xml
%%DATADIR%%/gui-saturator.xml
%%DATADIR%%/gui-sidechaincompressor.xml
%%DATADIR%%/gui-sidechaingate.xml
+%%DATADIR%%/gui-sidechainlimiter.xml
%%DATADIR%%/gui-stereo.xml
+%%DATADIR%%/gui-tapesimulator.xml
+%%DATADIR%%/gui-transientdesigner.xml
%%DATADIR%%/gui-vintagedelay.xml
+%%DATADIR%%/gui-vocoder.xml
%%DATADIR%%/gui-wavetable.xml
-%%DATADIR%%/handle-h.png
-%%DATADIR%%/handle-v.png
-%%DATADIR%%/hline.png
+%%DATADIR%%/gui-xover2.xml
+%%DATADIR%%/gui-xover3.xml
+%%DATADIR%%/gui-xover4.xml
+%%DATADIR%%/icons/LV2/Allpass.svg
+%%DATADIR%%/icons/LV2/Amplifier.svg
+%%DATADIR%%/icons/LV2/Analyser.svg
+%%DATADIR%%/icons/LV2/Bandpass.svg
+%%DATADIR%%/icons/LV2/Chorus.svg
+%%DATADIR%%/icons/LV2/Comb.svg
+%%DATADIR%%/icons/LV2/Compressor.svg
+%%DATADIR%%/icons/LV2/Constant.svg
+%%DATADIR%%/icons/LV2/Converter.svg
+%%DATADIR%%/icons/LV2/Delay.svg
+%%DATADIR%%/icons/LV2/Distortion.svg
+%%DATADIR%%/icons/LV2/Dynamics.svg
+%%DATADIR%%/icons/LV2/EQ.svg
+%%DATADIR%%/icons/LV2/Envelope.svg
+%%DATADIR%%/icons/LV2/Expander.svg
+%%DATADIR%%/icons/LV2/Filter.svg
+%%DATADIR%%/icons/LV2/Flanger.svg
+%%DATADIR%%/icons/LV2/Function.svg
+%%DATADIR%%/icons/LV2/Gate.svg
+%%DATADIR%%/icons/LV2/Generator.svg
+%%DATADIR%%/icons/LV2/Highpass.svg
+%%DATADIR%%/icons/LV2/Instrument.svg
+%%DATADIR%%/icons/LV2/Limiter.svg
+%%DATADIR%%/icons/LV2/Mixer.svg
+%%DATADIR%%/icons/LV2/Modulator.svg
+%%DATADIR%%/icons/LV2/MultiEQ.svg
+%%DATADIR%%/icons/LV2/Oscillator.svg
+%%DATADIR%%/icons/LV2/ParaEQ.svg
+%%DATADIR%%/icons/LV2/Phaser.svg
+%%DATADIR%%/icons/LV2/Pitch.svg
+%%DATADIR%%/icons/LV2/Reverb.svg
+%%DATADIR%%/icons/LV2/Simulator.svg
+%%DATADIR%%/icons/LV2/Spatial.svg
+%%DATADIR%%/icons/LV2/Spectral.svg
+%%DATADIR%%/icons/LV2/Utility.svg
+%%DATADIR%%/icons/LV2/Waveshaper.svg
%%DATADIR%%/knob1.png
%%DATADIR%%/knob2.png
%%DATADIR%%/knob3.png
%%DATADIR%%/knob4.png
%%DATADIR%%/knob5.png
-%%DATADIR%%/led2_active.png
-%%DATADIR%%/led2_inactive.png
-%%DATADIR%%/led2_normal.png
-%%DATADIR%%/led2_prelight.png
-%%DATADIR%%/led_active.png
-%%DATADIR%%/led_inactive.png
-%%DATADIR%%/led_normal.png
-%%DATADIR%%/led_prelight.png
%%DATADIR%%/light_bottom.png
%%DATADIR%%/light_top.png
%%DATADIR%%/logo_button.png
-%%DATADIR%%/notebook.png
-%%DATADIR%%/notebook_bottom.png
-%%DATADIR%%/notebook_left.png
-%%DATADIR%%/notebook_right.png
-%%DATADIR%%/notebook_top.png
-%%DATADIR%%/null.png
%%DATADIR%%/presets.xml
-%%DATADIR%%/rect3155.png
%%DATADIR%%/screw1.png
%%DATADIR%%/screw2.png
-%%DATADIR%%/scroll-thumb-horiz.png
-%%DATADIR%%/scroll-thumb-vert.png
-%%DATADIR%%/scroller-horiz-insens.png
-%%DATADIR%%/scroller-horiz-prelight.png
-%%DATADIR%%/scroller-horiz.png
-%%DATADIR%%/scroller-vert-insens.png
-%%DATADIR%%/scroller-vert-prelight.png
-%%DATADIR%%/scroller-vert.png
+%%DATADIR%%/screw_black.png
+%%DATADIR%%/screw_silver.png
%%DATADIR%%/side_d_e.png
%%DATADIR%%/side_d_ne.png
%%DATADIR%%/side_d_nw.png
@@ -167,51 +181,40 @@ share/applications/calf.desktop
%%DATADIR%%/slider2-horiz.png
%%DATADIR%%/slider2-vert-prelight.png
%%DATADIR%%/slider2-vert.png
-%%DATADIR%%/spin_down_active.png
-%%DATADIR%%/spin_down_inactive.png
-%%DATADIR%%/spin_down_normal.png
-%%DATADIR%%/spin_down_prelight.png
-%%DATADIR%%/spin_up_active.png
-%%DATADIR%%/spin_up_inactive.png
-%%DATADIR%%/spin_up_normal.png
-%%DATADIR%%/spin_up_prelight.png
-%%DATADIR%%/tab_bottom_normal.png
-%%DATADIR%%/tab_bottom_prelight.png
-%%DATADIR%%/tab_left_normal.png
-%%DATADIR%%/tab_left_prelight.png
-%%DATADIR%%/tab_right_normal.png
-%%DATADIR%%/tab_right_prelight.png
-%%DATADIR%%/tab_top_normal.png
-%%DATADIR%%/tab_top_prelight.png
-%%DATADIR%%/toggle1_black.png
+%%DATADIR%%/tap_active.png
+%%DATADIR%%/tap_inactive.png
+%%DATADIR%%/tap_prelight.png
+%%DATADIR%%/toggle0_silver.png
%%DATADIR%%/toggle1_silver.png
-%%DATADIR%%/toggle2_black.png
%%DATADIR%%/toggle2_silver.png
-%%DATADIR%%/trough1-horizontal.png
-%%DATADIR%%/trough1-vertical.png
-%%DATADIR%%/trough2-horizontal.png
-%%DATADIR%%/trough2-vertical.png
%%DATADIR%%/tubeH1.png
%%DATADIR%%/tubeH2.png
%%DATADIR%%/tubeV1.png
%%DATADIR%%/tubeV2.png
-%%DATADIR%%/vline.png
%%PORTDOCS%%%%DOCSDIR%%/About.html
%%PORTDOCS%%%%DOCSDIR%%/Analyzer.html
%%PORTDOCS%%%%DOCSDIR%%/Bass Enhancer.html
%%PORTDOCS%%%%DOCSDIR%%/Calf.html
+%%PORTDOCS%%%%DOCSDIR%%/Compensation Delay Line.html
%%PORTDOCS%%%%DOCSDIR%%/Compressor.html
%%PORTDOCS%%%%DOCSDIR%%/Controls.html
+%%PORTDOCS%%%%DOCSDIR%%/Crusher.html
%%PORTDOCS%%%%DOCSDIR%%/Deesser.html
-%%PORTDOCS%%%%DOCSDIR%%/Equalizer12band.html
-%%PORTDOCS%%%%DOCSDIR%%/Equalizer5band.html
-%%PORTDOCS%%%%DOCSDIR%%/Equalizer8band.html
+%%PORTDOCS%%%%DOCSDIR%%/Emphasis.html
+%%PORTDOCS%%%%DOCSDIR%%/Envelope Filter.html
+%%PORTDOCS%%%%DOCSDIR%%/Equalizer 12 Band.html
+%%PORTDOCS%%%%DOCSDIR%%/Equalizer 30 Band.html
+%%PORTDOCS%%%%DOCSDIR%%/Equalizer 5 Band.html
+%%PORTDOCS%%%%DOCSDIR%%/Equalizer 8 Band.html
%%PORTDOCS%%%%DOCSDIR%%/Exciter.html
%%PORTDOCS%%%%DOCSDIR%%/Filter.html
%%PORTDOCS%%%%DOCSDIR%%/Filterclavier.html
%%PORTDOCS%%%%DOCSDIR%%/Flanger.html
+%%PORTDOCS%%%%DOCSDIR%%/Fluidsynth.html
%%PORTDOCS%%%%DOCSDIR%%/Gate.html
+%%PORTDOCS%%%%DOCSDIR%%/Haas Stereo Enhancer.html
%%PORTDOCS%%%%DOCSDIR%%/Limiter.html
+%%PORTDOCS%%%%DOCSDIR%%/Mono Compressor.html
%%PORTDOCS%%%%DOCSDIR%%/Mono Input.html
%%PORTDOCS%%%%DOCSDIR%%/Monosynth.html
%%PORTDOCS%%%%DOCSDIR%%/Multi Chorus.html
@@ -222,60 +225,104 @@ share/applications/calf.desktop
%%PORTDOCS%%%%DOCSDIR%%/Phaser.html
%%PORTDOCS%%%%DOCSDIR%%/Pulsator.html
%%PORTDOCS%%%%DOCSDIR%%/Reverb.html
+%%PORTDOCS%%%%DOCSDIR%%/Ring Modulator.html
%%PORTDOCS%%%%DOCSDIR%%/Rotary Speaker.html
%%PORTDOCS%%%%DOCSDIR%%/Saturator.html
%%PORTDOCS%%%%DOCSDIR%%/Sidechain Compressor.html
%%PORTDOCS%%%%DOCSDIR%%/Sidechain Gate.html
+%%PORTDOCS%%%%DOCSDIR%%/Sidechain Limiter.html
%%PORTDOCS%%%%DOCSDIR%%/Stereo Tools.html
+%%PORTDOCS%%%%DOCSDIR%%/Tape Simulator.html
+%%PORTDOCS%%%%DOCSDIR%%/Transient Designer.html
%%PORTDOCS%%%%DOCSDIR%%/Vintage Delay.html
+%%PORTDOCS%%%%DOCSDIR%%/Vocoder.html
+%%PORTDOCS%%%%DOCSDIR%%/Wavetable.html
+%%PORTDOCS%%%%DOCSDIR%%/X-Over 2 Band.html
+%%PORTDOCS%%%%DOCSDIR%%/X-Over 3 Band.html
+%%PORTDOCS%%%%DOCSDIR%%/X-Over 4 Band.html
%%PORTDOCS%%%%DOCSDIR%%/_blank.html
%%PORTDOCS%%%%DOCSDIR%%/images/About.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Analyzer.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Bass Enhancer.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Compressor.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Controls.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Deesser.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Equalizer 12 Band.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Equalizer 5 Band.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Equalizer 8 Band.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Exciter.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Filter.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Filterclavier.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Flanger.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Gate.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Limiter.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Mono Input.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Monosynth - Audio Path.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Monosynth - Modulation Matrix.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Monosynth - Modulation.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Multi Chorus.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Multiband Compressor.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Multiband Gate.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Multiband Limiter.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Organ - Advanced.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Organ - Sound Processor.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Organ - Tone Generator.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Phaser.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Pulsator.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Reverb.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Rotary Speaker.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Saturator.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Sidechain Compressor.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Sidechain Gate.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Stereo Tools.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Vintage Delay.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Calf.png
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Analyzer - Spectralizer.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Analyzer - Stereo Difference.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Analyzer - Stereo Image.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Analyzer.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Bass Enhancer.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Compensation Delay Line.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Compressor.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Controls.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Crusher.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Deesser.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Emphasis.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Envelope Filter.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Equalizer 12 Band.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Equalizer 30 Band.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Equalizer 5 Band.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Equalizer 8 Band.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Exciter.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Filter.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Filterclavier.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Flanger.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Fluidsynth.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Gate.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Haas Stereo Enhancer.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Limiter.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Mono Compressor.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Mono Input.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Monosynth - Audio Path.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Monosynth - Modulation Matrix.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Monosynth - Modulation.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Multi Chorus.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Multiband Compressor.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Multiband Gate.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Multiband Limiter.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Organ - Sound Processor.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Organ - Tone Generator.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Phaser.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Pulsator.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Reverb.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Reverse Delay.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Ring Modulator.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Rotary Speaker.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Saturator.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Sidechain Compressor.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Sidechain Gate.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Sidechain Limiter.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Stereo Tools.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Tape Simulator.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Transient Designer.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Vintage Delay.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Vocoder.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - Wavetable.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - X-Over 2 Band.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - X-Over 3 Band.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf - X-Over 4 Band.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf JACK Host.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf Studio Gear.jpg
+%%PORTDOCS%%%%DOCSDIR%%/images/Calf.jpg
%%PORTDOCS%%%%DOCSDIR%%/images/Index.png
-%%PORTDOCS%%%%DOCSDIR%%/images/background_dark.png
-%%PORTDOCS%%%%DOCSDIR%%/images/plugins.png
+%%PORTDOCS%%%%DOCSDIR%%/images/icons/delay.png
+%%PORTDOCS%%%%DOCSDIR%%/images/icons/distortion.png
+%%PORTDOCS%%%%DOCSDIR%%/images/icons/dynamics.png
+%%PORTDOCS%%%%DOCSDIR%%/images/icons/filters.png
+%%PORTDOCS%%%%DOCSDIR%%/images/icons/index.png
+%%PORTDOCS%%%%DOCSDIR%%/images/icons/modulation.png
+%%PORTDOCS%%%%DOCSDIR%%/images/icons/synthesizer.png
+%%PORTDOCS%%%%DOCSDIR%%/images/icons/tools.png
+%%PORTDOCS%%%%DOCSDIR%%/images/marrow.png
+%%PORTDOCS%%%%DOCSDIR%%/images/prettyPhoto/dark_rounded/btnNext.png
+%%PORTDOCS%%%%DOCSDIR%%/images/prettyPhoto/dark_rounded/btnPrevious.png
+%%PORTDOCS%%%%DOCSDIR%%/images/prettyPhoto/dark_rounded/contentPattern.png
+%%PORTDOCS%%%%DOCSDIR%%/images/prettyPhoto/dark_rounded/default_thumbnail.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/prettyPhoto/dark_rounded/loader.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/prettyPhoto/dark_rounded/sprite.png
%%PORTDOCS%%%%DOCSDIR%%/images/style_logo.png
%%PORTDOCS%%%%DOCSDIR%%/images/style_p.png
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/scripts/jquery.js
+%%PORTDOCS%%%%DOCSDIR%%/scripts/jquery.prettyPhoto.js
%%PORTDOCS%%%%DOCSDIR%%/scripts/manual.js
+%%PORTDOCS%%%%DOCSDIR%%/scripts/prettyPhoto.css
%%PORTDOCS%%%%DOCSDIR%%/scripts/style.css
-%%PORTDOCS%%%%DOCSDIR%%/scripts/thickbox.css
-%%PORTDOCS%%%%DOCSDIR%%/scripts/thickbox.js
share/icons/hicolor/128x128/apps/calf.png
share/icons/hicolor/128x128/apps/calf_plugin.png
share/icons/hicolor/16x16/apps/calf.png