aboutsummaryrefslogtreecommitdiff
path: root/audio/cantata
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-02-18 20:22:18 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-02-18 20:22:18 +0000
commit0c259cb520c7a65cd3b5173baf457c2be41a1132 (patch)
treeae94444ab0fa232d71a434fe70d03782fa05bb59 /audio/cantata
parent549662a0f89137f104210f43ab9ee5d1ed700b06 (diff)
Notes
Diffstat (limited to 'audio/cantata')
-rw-r--r--audio/cantata/Makefile74
-rw-r--r--audio/cantata/distinfo2
-rw-r--r--audio/cantata/files/patch-replaygain_ffmpeginput.cpp10
-rw-r--r--audio/cantata/files/patch-replaygain_mpg123input.cpp10
-rw-r--r--audio/cantata/pkg-descr3
-rw-r--r--audio/cantata/pkg-plist43
6 files changed, 142 insertions, 0 deletions
diff --git a/audio/cantata/Makefile b/audio/cantata/Makefile
new file mode 100644
index 000000000000..ac251d221002
--- /dev/null
+++ b/audio/cantata/Makefile
@@ -0,0 +1,74 @@
+# $FreeBSD$
+
+PORTNAME= cantata
+PORTVERSION= 1.5.1
+CATEGORIES= audio kde
+MASTER_SITES= https://drive.google.com/uc?export=download&id=0Bzghs6gQWi60UktwaTRMTjRIUW8&dummy=
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Graphical client for MPD using Qt5
+
+LICENSE= GPLv3
+
+USE_KDE4= oxygen
+USE_QT5= buildtools_build concurrent core dbus gui \
+ network qmake_build linguisttools svg widgets xml
+
+FETCH_BEFORE_ARGS= -o ${DISTFILES}
+
+CMAKE_ARGS= -DENABLE_QT5:BOOL=TRUE \
+ -DENABLE_KDE:BOOL=FALSE \
+ -DLCONVERT_EXECUTABLE:STRING=${QT_BINDIR}/lconvert \
+ -DLRELEASE_EXECUTABLE:STRING=${QT_BINDIR}/lrelease
+
+USES= cmake:outsource pkgconfig tar:bzip2
+USE_LDCONFIG= yes
+
+INSTALLS_ICONS= yes
+
+OPTIONS_DEFINE= CDDB CDPARANOIA FFMPEG MPG123 MTP MUSICBRAINZ TAGLIB
+OPTIONS_DEFAULT= TAGLIB
+OPTIONS_SUB= yes
+
+CDDB_LIB_DEPENDS= libcddb.so:${PORTSDIR}/audio/libcddb
+CDDB_CMAKE_ON= -DENABLE_CDDB:BOOL=TRUE
+CDDB_CMAKE_OFF= -DENABLE_CDDB:BOOL=FALSE
+
+CDPARANOIA_LIB_DEPENDS= libcdda_interface.so:${PORTSDIR}/audio/cdparanoia
+CDPARANOIA_CMAKE_ON= -DENABLE_CDPARANOIA:BOOL=TRUE
+CDPARANOIA_CMAKE_OFF= -DENABLE_CDPARANOIA:BOOL=FALSE
+
+FFMPEG_LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
+FFMPEG_CMAKE_ON= -DENABLE_FFMPEG:BOOL=TRUE
+FFMPEG_CMAKE_OFF= -DENABLE_FFMPEG:BOOL=FALSE
+
+MPG123_LIB_DEPENDS= libmpg123.so:${PORTSDIR}/audio/mpg123
+MPG123_CMAKE_ON= -DENABLE_MPG123:BOOL=TRUE
+MPG123_CMAKE_OFF= -DENABLE_MPG123:BOOL=FALSE
+
+MTP_LIB_DEPENDS= libmtp.so:${PORTSDIR}/multimedia/libmtp
+MTP_CMAKE_ON= -DENABLE_MTP:BOOL=TRUE
+MTP_CMAKE_OFF= -DENABLE_MTP:BOOL=FALSE
+
+MUSICBRAINZ_LIB_DEPENDS=libmusicbrainz5.so:${PORTSDIR}/audio/libmusicbrainz5
+MUSICBRAINZ_CMAKE_ON= -DENABLE_MUSICBRAINZ:BOOL=TRUE
+MUSICBRAINZ_CMAKE_OFF= -DENABLE_MUSICBRAINZ:BOOL=FALSE
+MUSICBRAINZ_DESC= Access MusicBrainz database for metadata lookup
+
+TAGLIB_LIB_DEPENDS= libtag.so:${PORTSDIR}/audio/taglib\
+ libtag-extras.so:${PORTSDIR}/audio/taglib-extras
+TAGLIB_CMAKE_ON= -DENABLE_TAGLIB_EXTRAS:BOOL=TRUE \
+ -DENABLE_TAGLIB:BOOL=TRUE
+TAGLIB_CMAKE_OFF= -DENABLE_TAGLIB_EXTRAS:BOOL=FALSE \
+ -DENABLE_TAGLIB:BOOL=FALSE
+TAGLIB_DESC= Reading and editing Meta-Data of audio files
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTAGLIB} && ( ${PORT_OPTIONS:MFFMPEG} || ${PORT_OPTIONS:MMPG123} )
+PLIST_SUB+= REPLAYGAIN=""
+.else
+PLIST_SUB+= REPLAYGAIN="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/cantata/distinfo b/audio/cantata/distinfo
new file mode 100644
index 000000000000..f77825476dda
--- /dev/null
+++ b/audio/cantata/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cantata-1.5.1.tar.bz2) = 57173bdd0033a2c0c2829a6e05f7579b0f13ae7794d843167c013e1c971dfe78
+SIZE (cantata-1.5.1.tar.bz2) = 1986772
diff --git a/audio/cantata/files/patch-replaygain_ffmpeginput.cpp b/audio/cantata/files/patch-replaygain_ffmpeginput.cpp
new file mode 100644
index 000000000000..5648cc8472e3
--- /dev/null
+++ b/audio/cantata/files/patch-replaygain_ffmpeginput.cpp
@@ -0,0 +1,10 @@
+--- replaygain/ffmpeginput.cpp.orig 2015-01-21 18:44:15 UTC
++++ replaygain/ffmpeginput.cpp
+@@ -8,7 +8,6 @@
+ */
+
+ /* See LICENSE file for copyright and license details. */
+-#define _POSIX_C_SOURCE 1
+ #ifdef __cplusplus
+ #define __STDC_CONSTANT_MACROS
+ #ifdef _STDINT_H
diff --git a/audio/cantata/files/patch-replaygain_mpg123input.cpp b/audio/cantata/files/patch-replaygain_mpg123input.cpp
new file mode 100644
index 000000000000..b87532e6bd22
--- /dev/null
+++ b/audio/cantata/files/patch-replaygain_mpg123input.cpp
@@ -0,0 +1,10 @@
+--- replaygain/mpg123input.cpp.orig 2015-01-21 18:46:32 UTC
++++ replaygain/mpg123input.cpp
+@@ -8,7 +8,6 @@
+ */
+
+ /* See LICENSE file for copyright and license details. */
+-#define _POSIX_C_SOURCE 1
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
diff --git a/audio/cantata/pkg-descr b/audio/cantata/pkg-descr
new file mode 100644
index 000000000000..437bc0bef047
--- /dev/null
+++ b/audio/cantata/pkg-descr
@@ -0,0 +1,3 @@
+Cantata is a graphical client for MPD.
+
+WWW: https://code.google.com/p/cantata/
diff --git a/audio/cantata/pkg-plist b/audio/cantata/pkg-plist
new file mode 100644
index 000000000000..765a05c48353
--- /dev/null
+++ b/audio/cantata/pkg-plist
@@ -0,0 +1,43 @@
+bin/cantata
+%%REPLAYGAIN%%lib/cantata/cantata-replaygain
+%%TAGLIB%%lib/cantata/cantata-tags
+share/applications/cantata.desktop
+share/cantata/config/lyrics_providers.xml
+share/cantata/config/podcast_directories.xml
+share/cantata/config/scrobblers.xml
+share/cantata/config/tag_fixes.xml
+share/cantata/config/weblinks.xml
+share/cantata/icons/bbc.svg
+share/cantata/icons/cbc.svg
+share/cantata/icons/npr.svg
+share/cantata/icons/podcasts.png
+share/cantata/icons/soundcloud.png
+share/cantata/icons/stream.png
+share/cantata/mpd/mpd.conf.template
+share/cantata/scripts/cantata-dynamic
+share/cantata/scripts/cantata-remote
+share/cantata/themes/adwaita.css
+share/cantata/themes/ambiance-dt.css
+share/cantata/themes/ambiance.css
+share/cantata/themes/elementary.css
+share/cantata/themes/faience.css
+share/cantata/themes/mint-x.css
+share/cantata/themes/radiance-dt.css
+share/cantata/themes/radiance.css
+share/cantata/translations/cantata_cs.qm
+share/cantata/translations/cantata_de.qm
+share/cantata/translations/cantata_en_GB.qm
+share/cantata/translations/cantata_es.qm
+share/cantata/translations/cantata_fr.qm
+share/cantata/translations/cantata_hu.qm
+share/cantata/translations/cantata_ko.qm
+share/cantata/translations/cantata_pl.qm
+share/cantata/translations/cantata_ru.qm
+share/cantata/translations/cantata_zh_CN.qm
+share/icons/hicolor/16x16/apps/cantata.png
+share/icons/hicolor/22x22/apps/cantata.png
+share/icons/hicolor/24x24/apps/cantata.png
+share/icons/hicolor/32x32/apps/cantata.png
+share/icons/hicolor/48x48/apps/cantata.png
+share/icons/hicolor/64x64/apps/cantata.png
+share/icons/hicolor/scalable/apps/cantata.svg