aboutsummaryrefslogtreecommitdiff
path: root/audio/cantus_3
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2004-12-04 19:12:10 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2004-12-04 19:12:10 +0000
commit9f7ad964d19d4c9a4c6c38a9cc359254e2f87824 (patch)
tree9898e14553d3f9b36f68bc00641ef4fcd904a15a /audio/cantus_3
parent4a5d9854c50962b069d61a791352d0132ea0c6a4 (diff)
downloadports-9f7ad964d19d4c9a4c6c38a9cc359254e2f87824.tar.gz
ports-9f7ad964d19d4c9a4c6c38a9cc359254e2f87824.zip
Notes
Diffstat (limited to 'audio/cantus_3')
-rw-r--r--audio/cantus_3/Makefile42
-rw-r--r--audio/cantus_3/distinfo2
-rw-r--r--audio/cantus_3/files/patch-build.sh15
-rw-r--r--audio/cantus_3/files/patch-src::libs::lib_charset.c11
-rw-r--r--audio/cantus_3/files/patch-src::plugins::lib_charset.c11
-rw-r--r--audio/cantus_3/pkg-descr7
-rw-r--r--audio/cantus_3/pkg-plist22
7 files changed, 110 insertions, 0 deletions
diff --git a/audio/cantus_3/Makefile b/audio/cantus_3/Makefile
new file mode 100644
index 000000000000..1036d24abdc7
--- /dev/null
+++ b/audio/cantus_3/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: cantus_3
+# Date created: 18 May 2004
+# Whom: asa@gascom.ru
+#
+# $FreeBSD$
+#
+
+PORTNAME= cantus_3
+PORTVERSION= 3.0.0
+CATEGORIES= audio
+MASTER_SITES= ftp://ftp.gascom.ru/pub/asa/ \
+ http://web222.mis02.de/releases/cantus_3/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1
+
+MAINTAINER= asa@gascom.ru
+COMMENT= Tool for tagging and renaming MP3 and OGG/Vorbis files
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2
+LIB_DEPENDS= gtkmm-2.0.6:${PORTSDIR}/x11-toolkits/gtk--2 \
+ glademm-2.0.1:${PORTSDIR}/devel/libglademm \
+ ogg.5:${PORTSDIR}/audio/libogg \
+ vorbis.3:${PORTSDIR}/audio/libvorbis
+
+USE_GMAKE= yes
+USE_GNOME= gnomehack libglade2
+USE_X_PREFIX= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= Does not build on 4.X.
+.endif
+
+BASH?= ${LOCALBASE}/bin/bash
+
+do-build:
+ @cd ${WRKSRC} && ${BASH} build.sh --prefix '${PREFIX}'
+
+do-install:
+ @cd ${WRKSRC} && ${BASH} build.sh --install --prefix '${PREFIX}'
+
+.include <bsd.port.post.mk>
diff --git a/audio/cantus_3/distinfo b/audio/cantus_3/distinfo
new file mode 100644
index 000000000000..0393c4fa16a9
--- /dev/null
+++ b/audio/cantus_3/distinfo
@@ -0,0 +1,2 @@
+MD5 (cantus_3-3.0.0-1.tar.gz) = 4bce0d2682ae2d03da2ff710d186bb78
+SIZE (cantus_3-3.0.0-1.tar.gz) = 185810
diff --git a/audio/cantus_3/files/patch-build.sh b/audio/cantus_3/files/patch-build.sh
new file mode 100644
index 000000000000..dbdee9110bde
--- /dev/null
+++ b/audio/cantus_3/files/patch-build.sh
@@ -0,0 +1,15 @@
+--- build.sh.orig Thu Apr 22 04:26:52 2004
++++ build.sh Tue May 18 14:57:02 2004
+@@ -165,11 +165,7 @@
+ INST_LOCALEDIR="$INST_PREFIX/share/locale"
+ INST_PIXMAPDIR="$INST_PREFIX/lib/$EXECUTABLE"
+ INST_DOCDIR="$INST_PREFIX/doc/$EXECUTABLE"
+-if [ -d "/usr/share/gnome/help/" ]; then
+- INST_GNOMEDOCDIR="/usr/share/gnome/help/$EXECUTABLE/C"
+-else
+- INST_GNOMEDOCDIR="/usr/local/share/gnome/help/$EXECUTABLE/C"
+-fi
++INST_GNOMEDOCDIR="$INST_PREFIX/share/gnome/help/$EXECUTABLE/C"
+
+ # Preprocessor macros:
+ MACROS="PACKAGE_LIB_DIR=$INST_LIBDIR/\
diff --git a/audio/cantus_3/files/patch-src::libs::lib_charset.c b/audio/cantus_3/files/patch-src::libs::lib_charset.c
new file mode 100644
index 000000000000..8e0b76fb72bd
--- /dev/null
+++ b/audio/cantus_3/files/patch-src::libs::lib_charset.c
@@ -0,0 +1,11 @@
+--- src/libs/lib_charset.c.orig Tue May 18 14:25:50 2004
++++ src/libs/lib_charset.c Tue May 18 14:25:59 2004
+@@ -207,7 +207,7 @@
+ outptr = out;
+
+ retry:
+- if (iconv(cd, (char**)&input, &length, &outptr, &outleft) == -1) {
++ if (iconv(cd, (const char**)&input, &length, &outptr, &outleft) == -1) {
+ int used;
+ switch (errno) {
+ case E2BIG:
diff --git a/audio/cantus_3/files/patch-src::plugins::lib_charset.c b/audio/cantus_3/files/patch-src::plugins::lib_charset.c
new file mode 100644
index 000000000000..d7c4e6df67bb
--- /dev/null
+++ b/audio/cantus_3/files/patch-src::plugins::lib_charset.c
@@ -0,0 +1,11 @@
+--- src/plugins/lib_charset.c.orig Tue May 18 14:17:18 2004
++++ src/plugins/lib_charset.c Tue May 18 14:17:34 2004
+@@ -191,7 +191,7 @@
+ outptr = out;
+
+ retry:
+- if (iconv(cd, (char**)&input, &length, &outptr, &outleft) == -1) {
++ if (iconv(cd, (const char**)&input, &length, &outptr, &outleft) == -1) {
+ int used;
+ switch (errno) {
+ case E2BIG:
diff --git a/audio/cantus_3/pkg-descr b/audio/cantus_3/pkg-descr
new file mode 100644
index 000000000000..19b2c242e91c
--- /dev/null
+++ b/audio/cantus_3/pkg-descr
@@ -0,0 +1,7 @@
+Cantus is an easy to use tool for tagging and renaming MP3 and OGG/Vorbis files.
+It has many features including mass tagging and renaming of MP3s, the ability to
+generate a tag out of the filename, filter definitions for renaming, recursive
+actions, CDDB (Freedb) lookup (no CD needed), copy between ID3V1 and ID3V2 tags,
+and a lot more.
+
+WWW: http://www.debain.org/software/cantus/
diff --git a/audio/cantus_3/pkg-plist b/audio/cantus_3/pkg-plist
new file mode 100644
index 000000000000..8e5d5a09125c
--- /dev/null
+++ b/audio/cantus_3/pkg-plist
@@ -0,0 +1,22 @@
+bin/cantus_3
+lib/cantus_3/id3v1.so
+lib/cantus_3/vorbis.so
+lib/cantus_3/id3copier.so
+lib/cantus_3/tag2filename.so
+lib/cantus_3/mpegheader.so
+lib/cantus_3/id3v2.so
+lib/cantus_3/cantus-3.glade
+lib/cantus_3/general.png
+lib/cantus_3/cantus_tag.png
+share/gnome/help/cantus_3/C/figures/cantus_start_window.png
+share/gnome/help/cantus_3/C/legal.xml
+share/gnome/help/cantus_3/C/cantus_3.xml
+share/gnome/help/cantus_3/C/cantus_start_window.png
+share/locale/de/LC_MESSAGES/cantus_3.mo
+share/locale/es/LC_MESSAGES/cantus_3.mo
+share/locale/fr/LC_MESSAGES/cantus_3.mo
+share/locale/pl/LC_MESSAGES/cantus_3.mo
+@dirrm lib/cantus_3/
+@dirrm share/gnome/help/cantus_3/C/figures
+@dirrm share/gnome/help/cantus_3/C
+@dirrm share/gnome/help/cantus_3/