aboutsummaryrefslogtreecommitdiff
path: root/audio/caps-plugins/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-06 18:45:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-06 18:45:54 +0000
commitf5206942b9bfba683b754536056e8fe4981cff72 (patch)
tree14cb04f760ed57b41098fa8b8a01672595eb4fb1 /audio/caps-plugins/Makefile
parent8a1644b8ef63b52a32905a69d755b16e27806c2d (diff)
Notes
Diffstat (limited to 'audio/caps-plugins/Makefile')
-rw-r--r--audio/caps-plugins/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/audio/caps-plugins/Makefile b/audio/caps-plugins/Makefile
new file mode 100644
index 000000000000..ea50fb405009
--- /dev/null
+++ b/audio/caps-plugins/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: caps-plugins
+# Date created: 2007-03-06
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= caps-plugins
+PORTVERSION= 0.3.0
+CATEGORIES= audio
+MASTER_SITES= http://quitte.de/dsp/
+DISTNAME= caps_${PORTVERSION}
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= The C* Audio Plugin Suite
+
+BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WRKSRC= ${WRKDIR}/caps-${PORTVERSION}
+USE_GMAKE= yes
+
+PLIST_FILES= lib/ladspa/caps.so
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
+CFLAGS+= -O6 -ffast-math -funroll-loops
+.endif
+
+.include <bsd.port.post.mk>