aboutsummaryrefslogtreecommitdiff
path: root/audio/caps-plugins
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2007-06-22 22:32:09 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2007-06-22 22:32:09 +0000
commit26dd12d3f0f9ccc2ef0664a8505b727c5d3ac6dc (patch)
treed89d7f4535132801ca4e0b2bed9ad868d4de86fd /audio/caps-plugins
parent03edaa9fcd0771dbccc8d8f253a91f908482fac4 (diff)
downloadports-26dd12d3f0f9ccc2ef0664a8505b727c5d3ac6dc.tar.gz
ports-26dd12d3f0f9ccc2ef0664a8505b727c5d3ac6dc.zip
Notes
Diffstat (limited to 'audio/caps-plugins')
-rw-r--r--audio/caps-plugins/Makefile5
-rw-r--r--audio/caps-plugins/distinfo6
-rw-r--r--audio/caps-plugins/files/patch-Makefile12
3 files changed, 12 insertions, 11 deletions
diff --git a/audio/caps-plugins/Makefile b/audio/caps-plugins/Makefile
index 7f9dab36756c..32c648a2b32f 100644
--- a/audio/caps-plugins/Makefile
+++ b/audio/caps-plugins/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= caps-plugins
-PORTVERSION= 0.4.0
+PORTVERSION= 0.4.2
CATEGORIES= audio
MASTER_SITES= http://quitte.de/dsp/
DISTNAME= caps_${PORTVERSION}
@@ -19,11 +19,12 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/caps-${PORTVERSION}
USE_GMAKE= yes
+CFLAGS+= -fPIC
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
-CFLAGS+= -O3 -ffast-math -funroll-loops
+CFLAGS+= -O2 -ffast-math -funroll-loops
.endif
.if ${OSVERSION} < 600000
diff --git a/audio/caps-plugins/distinfo b/audio/caps-plugins/distinfo
index 2d9ba747b2af..4bd3d53425fe 100644
--- a/audio/caps-plugins/distinfo
+++ b/audio/caps-plugins/distinfo
@@ -1,3 +1,3 @@
-MD5 (caps_0.4.0.tar.gz) = e4f76c5122a6e80861c22c9c679fa677
-SHA256 (caps_0.4.0.tar.gz) = 5cafd150c47ddd7a2c79948e3a77afadf0a40168b69f2f8dbd4a7bb77b0d8319
-SIZE (caps_0.4.0.tar.gz) = 784917
+MD5 (caps_0.4.2.tar.gz) = 041f3a6934ed34f7073117e34f78a5e9
+SHA256 (caps_0.4.2.tar.gz) = 2e781f8892ba4071c0f215573892fe2668b3c3fc42962c5720cefdcb12a2a813
+SIZE (caps_0.4.2.tar.gz) = 784363
diff --git a/audio/caps-plugins/files/patch-Makefile b/audio/caps-plugins/files/patch-Makefile
index 90c39636ccfb..a5fdf761cb50 100644
--- a/audio/caps-plugins/files/patch-Makefile
+++ b/audio/caps-plugins/files/patch-Makefile
@@ -1,12 +1,12 @@
---- Makefile.orig Sun Jun 17 12:32:01 2007
-+++ Makefile Mon Jun 18 14:58:10 2007
+--- Makefile.orig Tue Jun 19 10:19:01 2007
++++ Makefile Fri Jun 22 23:30:42 2007
@@ -1,12 +1,12 @@
PREFIX = /usr/local
-CC = g++
--OPTS = -O3 -ffast-math -funroll-loops -Wall -fPIC -DPIC
-+CC = $(CXX)
-+OPTS = -Wall -fPIC -DPIC
+-OPTS = -O2 -ffast-math -funroll-loops -Wall -fPIC -DPIC
+++ CC = $(CXX)
+++ OPTS = -Wall -fPIC -DPIC
#OPTS = -g -DDEBUG
-include defines.make
@@ -15,4 +15,4 @@
+CFLAGS += $(OPTS)
PLUG = caps
- VERSION = 0.4.0
+ VERSION = 0.4.2